Solved

HSRP Configuration

Posted on 2014-09-28
13
339 Views
Last Modified: 2014-09-29
I am trying to configure HSRP based on the topology shown below.
However for some reason I cannot ping from  PC0 to PC1 ip address.
I can ping from PC0 all interfaces of all routers , the interfaces facing PC0 as well as the interfaces on the other side...
I also can ping from each router the IP address of PC1

I do not think , being unable to ping from PC0 to PC1 is related to HSRP, but cannot pinpoint the issue.

I wonder if I need to configure HSRP on both sides of the Routers ??


HS

 Router0
========
Router#sh run
Building configuration...

Current configuration : 761 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524G0P6
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
 standby version 2
 standby 1 ip 19.168.0.10
 standby 1 preempt
!
interface GigabitEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


Router#
=====================

Router1
====================
Router#sh run
Building configuration...

Current configuration : 762 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15245P02
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
 standby version 2
 standby 1 ip 192.168.0.10
 standby 1 preempt
!
interface GigabitEthernet0/1
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


Router#
=============================
Router 2
===========================
Router#sh run
Building configuration...

Current configuration : 762 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524A6AR
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.3 255.255.255.0
 duplex auto
 speed auto
 standby version 2
 standby 1 ip 192.168.0.10
 standby 1 preempt
!
interface GigabitEthernet0/1
 ip address 192.168.1.3 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


Router#
==========================

Router 3
===========================

Router#sh run
Building configuration...

Current configuration : 786 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524Z0LL
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.4 255.255.255.0
 duplex auto
 speed auto
 standby version 2
 standby 1 ip 192.168.0.10
 standby 1 priority 110
 standby 1 preempt
!
interface GigabitEthernet0/1
 ip address 192.168.1.4 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


Router#
==========================

Open in new window

0
Comment
Question by:jskfan
  • 8
  • 3
  • 2
13 Comments
 

Author Comment

by:jskfan
ID: 40348779
I am posting the configuration of PC0 and PC1 below


PC0
======
PC>ipconfig

FastEthernet0 Connection:(default port)
Link-local IPv6 Address.........: FE80::201:43FF:FE9D:68A9
IP Address......................: 192.168.0.50
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.0.10
=============
PC1
====

PC>ipconfig

FastEthernet0 Connection:(default port)
Link-local IPv6 Address.........: FE80::2D0:FFFF:FEB4:419
IP Address......................: 192.168.0.60
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 0.0.0.0
0
 
LVL 27

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 200 total points
ID: 40348792
You don't have default gateway and even IP address for PC1 is wrong
it is 192.168.1.x network :) and you need default gateway
PC1
IP Address......................: 192.168.1.60
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.1.x - one of routers (or create standby group 2 for practice)

Solving problems alone, like this one, will help to have better troubleshooting skils, try harder before posting. :)

Host need to know what is exit from his network (default gateway) if frames need to leave network.
For host there is simple rule:
If host is not in same subnet send frames to default gateway.
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 40348834
First, Router0 is not participating in HSRP (bad virtual IP address).

Router0
interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 standby 1 ip 19.168.0.10
 
 Second, you have default routes on all the routers... and they're using an ethernet interface instead of the next hop address. So delete the default routes. There are only two networks and all the routers are connected to both networks so there is no need for the default route. And if you do have a default route, unless you're connected to a point-to-point (only two possible hosts) network, do not use an interface in lieu of a next-hop IP address (but that's not what is causing this problem).
 
 Finally, what is PC0 and PC1 using as their default gateway?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:jskfan
ID: 40349021
I corrected the " standby 1 ip 19.168.0.10"
and
Removed the Default route....

I believe the reason I cannot ping from PC0 to PC1 but I can ping from PC1 to PC0, is because PC0 has a default gateway, which is the Virtual IP of the HSRP 192.168.0.10...However PC1 does not have a default gateway, because I have not configured HSRP on the interfaces facing PC1...
I believe that 's the case.


PC>ipconfig

FastEthernet0 Connection:(default port)
 Link-local IPv6 Address.........: FE80::201:43FF:FE9D:68A9
 IP Address......................: 192.168.0.50
 Subnet Mask.....................: 255.255.255.0
 Default Gateway.................: 192.168.0.10
 =============
 PC1
 ====

 PC>ipconfig

 FastEthernet0 Connection:(default port)
 Link-local IPv6 Address.........: FE80::2D0:FFFF:FEB4:419
 IP Address......................: 192.168.0.60
 Subnet Mask.....................: 255.255.255.0
 Default Gateway.................: 0.0.0.0 

Open in new window

0
 

Author Comment

by:jskfan
ID: 40349029
another thing I want to mention is :
** From PC0 I can ping the virtual IP address 192.168.0.10, but I cannot tell which router I received the reply from.

** I also may need help configuring Preempt, in case the Active router goes down... how can this be done?

I will appreciate it !!
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40349084
I believe the reason I cannot ping from PC0 to PC1 but I can ping from PC1 to PC0, is because PC0 has a default gateway, which is the Virtual IP of the HSRP 192.168.0.10
Nope.  If PC0 can ping PC1, then PC1 has to be able to ping PC0 (unless there's an ACL or firewall involved).  Pings are bi-directional. Which means that when PC0 pings PC1, it receives a packet (ICMP echo reply) from PC1.

However PC1 does not have a default gateway
Bingo!  There's a problem.  But even bigger is that it appears both of the PC's have IP addresses on the same network.  One should be 192.168.0.x and the other should be 192.168.1.x

** From PC0 I can ping the virtual IP address 192.168.0.10, but I cannot tell which router I received the reply from.
"show standby brief" will tell you which router is the active router.

** I also may need help configuring Preempt, in case the Active router goes down... how can this be done?
First get it working. Then tune it.
0
 

Author Comment

by:jskfan
ID: 40349555
""However PC1 does not have a default gateway"

 <<Bingo!  There's a problem.  But even bigger is that it appears both of the PC's have IP addresses on the same network.  One should be 192.168.0.x and the other should be 192.168.1.x>>

I fixed that...
But what will be the Default Gateway of PC1 ? I have configured HSRP for interfaces facing PC0 and set up their DG to be the Virtual IP of AVG... as you can see in the configuration, all router interfaces facing PC0 are in Standby group 1....
I wonder if I will have to configure all Router interfaces facing PC1 in Standby group 2 and create a Virtual IP ???

Though I can make any IP of any of the 4 routers to be the DG of PC1, however if one of the routers has a problem, there will be no ping reply from PC1

Any suggestion on what will be the DG of PC1 ??
0
 

Author Comment

by:jskfan
ID: 40349613
OR
I guess I can configure Vlan Interface on Switch facing PC1 and assign it an IP address (192.168.1.x) and make that IP the DG of PC1
0
 
LVL 27

Expert Comment

by:Predrag Jovic
ID: 40349617
My  first post said all about gateway and wrong IP address of PC1.
Even what default gateway address you can assign to PC1.

15 minutes after you asked your question :)
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 300 total points
ID: 40349620
Any router can be the default gateway.

But for a practical implementation, I would configure HSRP on the other network as well.
0
 

Author Comment

by:jskfan
ID: 40349622
<<<OR
 I guess I can configure Vlan Interface on Switch facing PC1 and assign it an IP address (192.168.1.x) and make that IP the DG of PC1>>>

I take that back....it will get more complicated
0
 

Author Comment

by:jskfan
ID: 40349638
It worked !!
I configured HSRP on the other Network as well...and I can ping now from end to end on both ways...
0
 

Author Closing Comment

by:jskfan
ID: 40349640
Thank you Guys!!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question