Solved

cohabitation exchange 2010 sp3 and 2013 sp1

Posted on 2014-09-29
11
407 Views
Last Modified: 2014-10-01
HI,
I want to upgrade my exchange serv 2010 sp3 to a dag of exchange 2013 sp1.
For now three servers are in cohabitation mode (2 exch 2013 and 1 exch2010).
Everything look fine except the communicaion between a mailbox on a 2013 database and mailboxs still on exchange 2010 database. The other way work fine.
All mails from the exchange 2013 mbx to an exchange 2010 mbx are in state waiting and never deliver.

Can you help me?
Regards
Jérémy
0
Comment
Question by:Waycom
  • 5
  • 5
11 Comments
 
LVL 24

Expert Comment

by:-MAS
ID: 40349646
Make sure your connectivity is not blocking port 25.
Make sure firewall is off.
Make sure "Exchange server authentication" is ticked in Default Receive connector properties

Try to send a test email using the below site and post the error if any.

Please post the error from queue viewer as well
0
 

Author Comment

by:Waycom
ID: 40349771
Exchange server authenticatication is enable on both exchange server 2013, not in my exch 2010.
When I try to enable this feature on this server i get this error:

"f the AuthMechanism attribute on a receive connector contains the value ExchangeServer, you must set the FQDN parameter on the receive connector to one of the following values: the FQDN of the transport server "exchange box.*************.***", the NetBIOS name of the transport server "exchange box", or $null."

But i don't know where i can change this, i try to change the name of the receive connector but it didn't work.

All communication from or to external address of my company work well.

Regards
0
 
LVL 30

Expert Comment

by:Gareth Gudger
ID: 40349855
Most likely it is an issue with the Receive Connector on the 2010 box.

Do you have just the default receive connectors? Or did you create any additional receive connectors on 2010 for relay for applications for example?

One of the big issues I have seen is when an additional Receive Connector is created for application relay and is scoped for a network range that includes the IP address of other Exchange servers (the 2013 server).

If you go into the Queue Viewer in Exchange 2013 (its the Toolbox) and look at the queue. What is the error message of the last time it sent? Is it a permissions error? If so, it is likely the above issue.
0
 

Author Comment

by:Waycom
ID: 40350075
Thanks for your help,
I create a new receive connector as an internal connector with a subnet of my new exchange servers and the communication works between my 2013 user and 2010.
When i activate the new connector all my linux user came to say me that mail didn't go out of their soft with an error on starttls.
I copied all parameters of the other connector and still connexion doesn't work with starttls parameter.
Do you know what can i search to solve this problem?
I attach all parameters of my receive connecter and it still doesn't work.

Thanks
Regards
bug-exch.jpg
0
 
LVL 30

Accepted Solution

by:
Gareth Gudger earned 500 total points
ID: 40350279
Hmm you shouldn't have had to create a dedicated receive connector for 2010 and 2013 to talk. But glad it is working.

Was the Linux mail working prior to this new receive connector? If so, make sure your new receive connector does NOT include the IP address of the Linux server.
0
Shouldn't all users have the same email signature?

You wouldn't let your users design their own business cards, would you? So, why do you let them design their own email signatures? Think of the damage they could be doing to your brand reputation! Choose the easy way to manage set up and add email signatures for all users.

 

Author Comment

by:Waycom
ID: 40350325
I talk about linux client and their ip is not in the range of the receive connector.
Can I configure which computer use this or another receive connector?

Thanks
Regards
0
 
LVL 30

Expert Comment

by:Gareth Gudger
ID: 40350601
How you have the IP scope configured will determines who uses the Receive Connector. I don't know anything about Linux but if you feel the settings for the Receive Connector would work for Linux mail then you can try adding its IP as well.

To confirm though. Is this a Linux mail server or Linux clients with email software? If Linux clients, how were they sending mail through Exchange before.
0
 

Author Comment

by:Waycom
ID: 40351756
I talk about Linux client with email software.
They are configured with imap with starttls.

In the new connector I specified only my exchange server ip addres, so I don't understand why what I did change anything about users.
0
 
LVL 30

Expert Comment

by:Gareth Gudger
ID: 40353409
Right. Your Linux users should not be using the new Receive Connector you just created. Make sure the Scoping in the new receive connector does not include the IPs of the Linux clients.
0
 

Author Comment

by:Waycom
ID: 40354294
Finally I put all of my exchange 2013 ip in /32 and it works.
You shouldn't put a subnet because it doesn't work.

Thanks for your help

regards
0
 
LVL 30

Expert Comment

by:Gareth Gudger
ID: 40354574
You can use a subnet, but it can cause problems like this. So I always recommend using /32. Glad its working.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now