Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Windows Deployment MDT 2013 en-GB language only

Posted on 2014-09-29
14
1,175 Views
Last Modified: 2014-10-04
Hi, I have a reference computer that has been configured with a user account that has the language set to English (United Kingdom) only. The other account (administrator account is also set to English (United Kingdom)

When I deploy the image to a new PC using  Lite Touch , the deployed PC gets configured correctly for the administrator account, but for the main user account it always ends up with both English (United Kingdom) and English (United States) with the US version at the top.

My deployment share rules are set as below

SkipLocaleSelection=YES
SkipTimeZone=YES
TimeZoneName=GMT Standard Time
UILanguage=en-GB
UserLocale=en-GB
Systemlocale=en-GB
KeyboardLocale=0809:00000809

Bootstrap.ini
KeyboardLocale=en-GB

I have also looked at the Task Sequence unattend.xml under the OS Info tab and altered any reference that was created in there automatically to what I believe is correct (see 4 screenshots attached)

regards
Rick

screenshots of unattend.xml file
0
Comment
Question by:Rick_Penney
  • 8
  • 6
14 Comments
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 40350720
add a post-install task that:
REG DELETE "HKLM\SYSTEM\ControlSet001\Control\Keyboard Layouts\00000409" /f

or the folloiwng:
file1.xml
 <gs:User UserID="Current"/>
    </gs:UserList>
    <gs:InputPreferences>
	<gs:InputLanguageID Action="remove" ID="1009:00001009"/>
        <gs:InputLanguageID Action="remove" ID="1009:00001009"/>
        <gs:InputLanguageID Action="remove" ID="1009:00000409"/>
    </gs:InputPreferences>
    <gs:LocationPreferences>
    <gs:GeoID Value="242"/>
    </gs:LocationPreferences>
    <gs:UserLocale>
    <gs:Locale Name="en-GB" SetAsCurrent="true"/>
    </gs:UserLocale>
    </gs:GlobalizationServices>

Open in new window

file2.xml
 <!--User List-->
   <gs:UserList>
   <gs:User UserID="Current"/>
   </gs:UserList>
   <gs:InputPreferences>
   <gs:InputLanguageID Action="add" ID="0809:00000809" Default="true"/>
   </gs:InputPreferences>
   </gs:GlobalizationServices>

Open in new window


control intl.cpl,, /f:"<path_to_file1.xml>"
control intl.cpl,, /f:"<path_to_file2.xml>"

Please note the double commas and the space before /f
http://superuser.com/questions/353752/windows-7-change-region-and-language-settings-using-a-script
0
 

Author Comment

by:Rick_Penney
ID: 40351716
Hi, many thanks for your email.
I have run REG DELETE "HKLM\SYSTEM\ControlSet001\Control\Keyboard Layouts\00000409" /f  from a command prompt on the deployed pc just to test it.
The 00000409 key deletes fine, but the English (United States) remains in Language in Control Panel.

I've just tried both suggestions and it appears that this just deletes the language pack, but doesn't delete the keyboard layout option from the control panel.

thank you
Rick
0
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 40351722
  <gs:InputLanguageID Action="remove" ID="1009:00000409"/>

this is supposed to remove the en-US keyboard.
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 

Author Comment

by:Rick_Penney
ID: 40351802
Hi , unfortunately, that doesn't work
I did read here that the cmdlet control.exe intl.cpl is not available in Windows 8.1

http://social.technet.microsoft.com/Forums/systemcenter/en-US/8d869b0b-98ba-4b6a-a540-b2a308d89230/remove-language-from-control-panel?forum=w8itproinstall

Saying that, I can run control intl.cpl,,  from a cmd prompt and it does open up the region settings.
From the Administrators tab, I could copy the settings to all new accounts, and then re sysprep the PC and set everything back up in Windows Deployment Services but its a lot of work.
Or I could just remove the layout on each pc I deploy after its finished, but its bugging me now as it should work.

Just in case i'm doing it wrong, my batch file reads:
control intl.cpl,, /f: e:\language-remove.xml  (where e: is my usb stick)

My xml file reads:
<gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">
<gs:UserList>
<gs:User UserID="Current" CopySettingsToDefaultUserAcct="true" CopySettingsToSystemAcct="true"/></gs:UserList>
<gs:InputPreferences>

<gs:InputLanguageID Action="remove" ID="1009:00000409"/>

</gs:InputPreferences>
</gs:GlobalizationServices>
0
 

Author Comment

by:Rick_Penney
ID: 40351868
From a cmd prompt i ran  control intl.cpl ,,
From the  Administrative tab i clicked on copy settings
This will display all the language options, my Display language was set to English (United States).
 I download the EN_GB language pack from
http://social.technet.microsoft.com/Forums/en-US/ec4419df-ea0b-4da9-8750-063126debe97/language-pack-not-usable-message-in-windows-81?forum=w8itprogeneral
I then renamed the file to LP.mlc and  installed it
From Control Panel, Language, enter Advanced settings and  select English (United Kingdom) from drop down list for "Override for Windows Display Language"

I then rechecked the language settings as before
From a cmd prompt run  control intl.cpl ,,
Go to the Administrative tab and click on copy settings, mine now reads English (United Kingdom)

Check the boxes, copy your current settings to “Welcome screen and system accounts” and “new user accounts”

I'm going to now Re sysprep PC and set up in Windows deployment centre.
0
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 40351911
First install OS with Task Sequence then apply Dism to integrate language pack in state restore phase of TS as a command line. Then follow the steps as given below.
DISM /Online /Add-Package /PackagePath:C:\Path_to_lp.mic /norestart
bcdedit /set {current}locale EN-GB
bcdboot %WinDir% /l EN-GB
regedit delete en-US from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages

http://social.technet.microsoft.com/Forums/en-US/a8678316-f735-4a10-b5cb-1c07f620a703/how-to-add-language-pack-to-win7-professional-using-mdt?forum=mdt
0
 

Author Comment

by:Rick_Penney
ID: 40351914
Thanks Dave, I'm currently re sys-prepping the PC now, but once its done I will try your instructions on the original TS and redeploy it.
I'll post back a bit later
kind regards
Rick
0
 
LVL 80

Accepted Solution

by:
David Johnson, CD, MVP earned 500 total points
ID: 40351943
also testing here as well
0
 

Author Comment

by:Rick_Penney
ID: 40352309
Hi David, sorry its taken a while to test.
Unfortunately that didn't work and it also prevented me from deploying another image to the PC as it failed with "The task sequence has been suspended, Lite Touch is trying to install applications".
I ended up wiping the drive and redeploying the image that I sysprepped and captured earlier after I installed the language set and changed the welcome screen/Display language.
I would like to award you the points anyway as you have been very helpful in steering me in the write direction on what to search for and try out.
kind regards
Rick
0
 

Author Closing Comment

by:Rick_Penney
ID: 40352313
Many thanks again for your time spent today with this, regards, Rick
0
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 40360112
add the language pack to MDT and install it as part of the operating system deployment

http://www.screencast.com/t/lBZiVUdkvL
0
 

Author Comment

by:Rick_Penney
ID: 40360959
Hi David,
Thank you so much again for going to all this trouble.
 Looking through your video, I don't need anything in the Applications section?, I just need to add the Language Pack to the Packages section.

In my deployment rules I need to set these to entries to NO

 SkipLocaleSelection=NO
 SkipTimeZone=NO
SkipPackageDisplay=NO


Did you add this in anywhere and if so how?
regedit delete en-US from:
 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages

kind regards
Rick
0
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 40360980
Did you add this in anywhere and if so how?
regedit delete en-US from:
 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages

no I did not, and yes that is also correct just add the language pack to the packages
0
 

Author Comment

by:Rick_Penney
ID: 40361405
Top man, thanks
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

##the calculator has been updated to version 1.6 please download the use the updated version## Hi there, After the previous post of the original version of the calculator here : http://www.experts-exchange.com/articles/OS/Microsoft_Operatin…
Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found here: http://www.experts-exchang…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question