cannot resolve repository through bind.

Greetings.
I have two servers: cphq(192.168.1.15) and hdfs1(192.168.1.25)
my cphq server has named(bind)
I'm trying to install ambari-client.

My problem is that I am receiving this error:  Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

I have tried yum clean all, and other commands with no avail.
I am reasonably convinced it's my bind settings on cphq.
here they are:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
//	listen-on port 53 { 127.0.0.1; };
//	listen-on-v6 port 53 { ::1; };
	directory 	"/var/named";
	dump-file 	"/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
	allow-query     { any; };
        allow-transfer  { localhost; 192.168.1.15; };
	recursion yes;

	dnssec-enable yes;
	dnssec-validation yes;
	dnssec-lookaside auto;

	/* Path to ISC DLV key */
	bindkeys-file "/etc/named.iscdlv.key";

	managed-keys-directory "/var/named/dynamic";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
	type hint;
	file "named.ca";
};

zone "cutlerplace.net" IN {
     type master;
     file "cutlerplace.net.zone";
     allow-update { none; };
};

zone "google.com" {
type forward;
forwarders { 8.8.8.8 ; 8.8.4.4 ; };
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";

Open in new window


As you can see I even added a forward to google in attempt to run dns for it, but still nogo.  same error.
Any ideas?
thanks
LVL 9
Evan CutlerVolunteer Chief Information OfficerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
forwarders/forward-only should go in main options section to gain anything.
0
Evan CutlerVolunteer Chief Information OfficerAuthor Commented:
so how should it read?
forwarders { 8.8.8.8 ; 8.8.4.4 ; };
and that's in in the options section?
Thanks.
0
gheistCommented:
forward only;
forwarders {ip_your_provider_gave; other_ip;};
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Evan CutlerVolunteer Chief Information OfficerAuthor Commented:
Sorry it took me so long getting back.
This worked for me.
Thank you very much.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.