Solved

Server 2012 RDP Licensing

Posted on 2014-09-30
10
1,171 Views
Last Modified: 2014-09-30
Hi Guys

I have a "Windows Server 2012 Standard" which has been running for about 2 years with RDP.

yesterday I started getting the following message:
"Remote Desktop Services will stop working because this computer is past its grace period and has not contacted at least a valid Windows Server 2008 license server. On the RD Connection Broker server, use Server Manager to specify licensing settings"

I did some googling and found a registry entry to delete, which I deleted.
HKLM\System\CurrentControlSet\Control\Terminal Server\RCM\Grace Period

Now I get the following message:
"Remote Desktop Services will stop working in 120 days if this computer does not contact at least a valid Windows Server 2008 license server. On the RD connection Broker server, use Server Manager to verify or configure licensing settings"

Like I said it has been OK till now, we have no other server on the network.
Any ideas?
0
Comment
Question by:Ergs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40353209
You need to set up an RDS licensing server, buy RDS CALs, and install them on the licensing server. RDS has never been free.
0
 

Author Comment

by:Ergs
ID: 40353212
I just noticed something interesting. I went to "RD Licensing Diagnoser" and it is looking for this server but with the old IP address.

IMPORTANT NOTE: We changed IP addresses for this server a few days ago, hope this helps
0
 

Author Comment

by:Ergs
ID: 40353216
As I mentioned it has been running for 2 years and I do have valid licenses installed
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40353230
I've seen people misuse the two admin sessions, and your question didn't specify that you've actually configured any RDS roles. Working for two years isn't any guarantee that the system was set up properly.

If you are are certain that you have a licensing server and CALs, based on your followup, make sure all DNS entries are up to date. Delete old A records, flush DNS, and retest. In 2012, the RDCB is the arbiter of all and the entire infrastructure must be healthy.
0
 

Author Comment

by:Ergs
ID: 40353261
Would it be a matter of reconfiguring RDP Services?

as you can see from the attached image it is looking for a server with an IP address of 10.10.10.2
We changes our IP range a few days ago to 10.131.32.x
Capture.JPG
0
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40353266
IF the name didn't change then you shouldn't need to reconfigure. When setting up RDS, server FQDNs are the default, not direct IP addresses. So that is why making sure no old DNS records to the server name exist and why flushing DNS cache is important. Restarting the server wouldn't hurt either.
0
 

Author Comment

by:Ergs
ID: 40353351
OK so I checked DNS and made sure there are no entries to old IP address. I did a reboot. When I run RD Licensing Diagnoser it is still looking for a server with the old IP address.

Can't remember but I may have used IP address instead of FQDN when I first set it up.
0
 
LVL 58

Accepted Solution

by:
Cliff Galiher earned 500 total points
ID: 40353425
You'll probably want to remove and re-add the licensing sever in server manager then. Unless you decided to skip server manager and manually force settings via group policy (even worse.) in which case, you'll need to edit (or preferably remove) the group policy.
0
 

Author Comment

by:Ergs
ID: 40353607
OK all working now.... I cheated, I added the old IP as a secondary IP and RDP services seem to be happy.
0
 

Author Closing Comment

by:Ergs
ID: 40353610
didn't try it, it would have been my next attempt. Fixed the problem by adding the old IP as a secondary IP address
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
This article is in response to a question (http://www.experts-exchange.com/Networking/Network_Management/Network_Analysis/Q_28230497.html) here at Experts Exchange. The Original Poster (OP) requires a utility that will accept a list of IP addresses …
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question