Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 879
  • Last Modified:

PHP 5.5.x with Apache 2.2

What are the dr

Hi,

I installed from sources PHP 5.5 on Ubuntu 12.04 apache 2.2, I have read that 5.5x versions are apache 2.4  compatible.
But I find my wordpress based app run smooth on PHP 5.5.16 with Apache 2.2
It's running and all now run 24 hours without errors.
What are the drawbacks? Shall I expect some problems and why it always can be seen that PHP 5.5 require Apache 2.4 as min but looks like it's not a true?
Please comment.

I wonder if I should expect some issues unpredicted and maybe switch back to 5.3 or 5.4 ?

Please advice.
0
Ian Simonv
Asked:
Ian Simonv
  • 2
1 Solution
 
gheistCommented:
Yes, in-memory mod_php is incompatible.

All apache versions can use mod_fcgi and map to php-cgi or php-fpm.
That isolates ram-hungry PHP from high-performance threaded webserver lika apache-event
At that point it does not matter you run apache 2.0 or nginx prerelease - PHP is one app server and webserver is busy with it;s task.
0
 
Ian SimonvAuthor Commented:
If that is incomatible why it work without errors?
0
 
gheistCommented:
While you use single-threaded apache-prefork it works. problems always start with multi-threaded usage. But I think no new there, it was same with 5.3, 5.4 and probably before...
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now