Error when trying to install .NET 3.5 on Windows Server 2012 R2

Hi,

I'm having issues while trying to enable .NET 3.5 on windows 2012 R2
I tried the following:

1. add  Roles And Features - and I specified the correct location of the files
2. I tried installing with DISM commands
3. reinstalling windows update service

below you can see the errors that I get:
2014-10-01 14:28:29, Error                 DISM   DISM Package Manager: PID=2444 TID=2796 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x800f081f)

2014-10-01 14:28:29, Error                 DISM   DISM Package Manager: PID=2444 TID=2796 The source files could not be found; their location must be specified using the /source option to restore the feature. - GetCbsErrorMsg

2014-10-01 14:28:29, Error                 DISM   DISM Package Manager: PID=2444 TID=2796 Failed processing package changes with session options - CDISMPackageManager::ProcessChangesWithOptions(hr:0x800f081f)

2014-10-01 14:28:29, Error                 DISM   DISM Package Manager: PID=2444 TID=2796 Failed ProcessChanges. - CPackageManagerCLIHandler::Private_ProcessFeatureChange(hr:0x800f081f)

2014-10-01 14:28:30, Error                 DISM   DISM Package Manager: PID=2444 TID=2796 Failed while processing command enable-feature. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x800f081f)
Add Role Screen 1Add Role Screen 2
will appreciate any help
compx_itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Paris VicenteSystems and Comunications  Administrator Commented:
Hi compx_it,

This server have internet access?

In TechNet they mention a solution for this error 0x800f081f.
Please follow this link to see if can help you solve the issue.

In the top of the page you will see a link mention to the Resolution for error code 0x800F081F, click it to go directly to the solution in the top of the page.

Or you can follow this how to install .Net 3.5

Let us know if helped.

Regards
0
Cliff GaliherCommented:
If you have another server that is at the same patch level and already has 3.5, specify that SxS folder as the source. This is the easiest way. Otherwise you'll need to build an image that has the same patches slipstreamed that your server has, which is a PITA. You can also try configuring the server to not use WSUS and get updates directly from the internet, and the server will obviously need internet access. That is *supposed* to work using the "features on demand" functionality. But I've found that it too can be very particular about patch levels.
0
compx_itAuthor Commented:
Hi,

tried all the ideas, still the same error
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

David Paris VicenteSystems and Comunications  Administrator Commented:
Did you try with other media?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cliff GaliherCommented:
I can't stress how important being at the same patch level is when pointing to another server. Ideally, you'd generate a list of every security update and match them on both servers, with the only difference being the "source" server already has 3.5 installed.  When that process is used, I've never seen the role install fail with the error code you've posted.

But when a security update is missed, even seemingly benign ones like a .Net 4.0 update (which nobody would assume is related), DISM will see the "media" as out of date and will not install the role from the source. If you are really struggling, what I'd do is stand up a new VM, install .Net 3.5 as the first thing you do, and then, using a list of patches installed on the target, install each patch manually on the source. Then use that as the source. I've had to do this literally dozens of times but it never fails. I've even written some scripts that mostly automates the patching from destination and source. They aren't really shareable for political reasons I can't go into, but it demonstrates that the process is sound.

-Cliff
0
Seth SimmonsSr. Systems AdministratorCommented:
I had no issues using powershell to install it last month even with those updates installed.

Install-WindowsFeature Net-Framework-Core -source D:\Sources\SxS
0
Seth SimmonsSr. Systems AdministratorCommented:
please specify the article and the solution
0
compx_itAuthor Commented:
found the article that solved the issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.