Outlook 2007 / Office 365 / high-latency Internet connection

We have a client whose office Internet connection is via a high-latency satellite connection.  They use Office 365, and connect to their mailboxes using Outlook 2007.

Users are reporting that Outlook 2007 takes several minutes to open, and performance is generally dreadful (yes, they are using cached Exchange mode!).

I've run some very basic tests using Outlook 2013 connecting to my own Office 365 mailbox while visiting their office, and find that its performance isn't as bad.  It seems on the face of it that Outlook 2013 handles this type of high-latency connection better than its predecessor.

Are there any configuration options for Outlook 2007 specifically that could help with performance when working with a high-latency Internet connection?  (apart from just buying new software!)
LVL 1
wakatashiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Acosta Technology ServicesCommented:
I would check the Exchange proxy settings in Outlook.  

Tools -> Account Settings -> Change -> More Settings -> Connection Tab

ensure the checkbox for "On slow networks..." is checked.
0
wakatashiAuthor Commented:
Thanks, good idea!  Am visiting them Tuesday next week so will have a look at a few of their PCs and see how that's configured.
0
wakatashiAuthor Commented:
I've had a look, and "On slow networks, connect using HTTP first, then connect using TCP/IP" is indeed checked.

There's nothing else as far as I can see in the ordinary GUI that relates to optimising things for slow/high-latency network connections.  Perhaps there are some Registry tweaks that could be applied?
0
wakatashiAuthor Commented:
Well, we ended up giving up on Outlook connecting via RPC over HTTP (or whatever it's called now) and ended up connecting via IMAP instead.   A workaround with lots of disadvantages, of course, but it works better if not brilliantly.

Moral of the story - don't get yourself a satellite Internet connection unless you really really REALLY have no other option!

Thanks for your help, Acosta Technology Services.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wakatashiAuthor Commented:
Found workaround myself (but not a very good one!)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.