Solved

IPhone 6 and Exchange 2003 issue

Posted on 2014-10-01
36
977 Views
Last Modified: 2014-11-18
One of our employees just got the new iPhone 6. I set up his Exchange account on it and for some reason incoming mail isn't working. Strangely enough it is sending mail OK. But no incoming mail. No errors, just a blank inbox.

We have Exchange 2003. I know it is old and we need to upgrade. But budget is an issue as usual. We have iPads running ios 8 and they sync just fine. And we've never had a problem syncing any older iPhones.

Any ideas would be appreciated.
0
Comment
Question by:ChrisEDavis
  • 15
  • 10
  • 5
  • +2
36 Comments
 
LVL 32

Expert Comment

by:it_saige
ID: 40355823
Have you checked to ActiveSync logs for authentication related issues?

-saige-
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40355862
Is the iPhone 6 on iOS 8.0.2 yet?

Does the problem account work happily on a non iPhone 6 device happily?

Alan
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40355867
When it sends out, are you sure it is sending out via the Exchange account? It isn't just sending out from another account on their iPhone is it?

What happens when you manually try and sync? Any errors?

Any errors when you set up the account initially? During initial sync the Security Inheritance on the users account in AD can sometimes cause problems. But it sounds like you may be passed that point.

Can't say I have personally tried an iPhone 6 yet on 2003.
0
 

Author Comment

by:ChrisEDavis
ID: 40355868
I am looking at the IIS logs. But I don't really know what I am looking for?
0
 

Author Comment

by:ChrisEDavis
ID: 40355882
The test e-mails I sent from the iPhone show they were sent from the Exchange account. No errors during set up or during syncing. I've tried syncing manually, no errors, just a blank inbox. He is receiving mail on his iPad perfectly and that is running ios 8. So I know ActiveSync is working on his account. And as I said I haven't had this problem with any other mobile device, Apple or Android.

I thought that maybe Apple had ceased to support Exchange 2003 in ios 8. But his iPad is running ios 8. And if they had stopped support for 2003,  it wouldn't send mail.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40355889
I assume you have already tried removing and recreating the account on the iPhone? Reboot the phone, etc.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40355899
Upgrade the phone to 8.0.2 and see if that fixes the issue.
0
 

Author Comment

by:ChrisEDavis
ID: 40355902
OK we'll try upgrading the iPhone to 8.0.2
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40355952
Also - is the iPhone 6 using Wi-Fi or 3/4G when it fails?
0
 

Author Comment

by:ChrisEDavis
ID: 40356018
I tired it on wifi and on hi Verizon 3g/4g. But I will try again. I had read somewhere that if you connect an i device to to wifi and then set up an Exchange account, that can lead to issues. I did hook the iPhone into our wifi before I set up he mail account. So I then deleted the account, switched off wifi and recreated it. Still no luck. The wifi it is connected to is on the same domain as the Exchange server, although in a different subnet.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40356072
It makes no difference to the account if you set it up over WiFi or 3g/4g.  The only problem might arise if it can't resolve DNS internally on WiFi, as it won't setup the account.

Alan
0
 
LVL 1

Expert Comment

by:JTOCCO
ID: 40357399
We are having the same issue with iOS 8 and Exchange 2013 (CU5). If we issue a new iPhone, whether 5 or 6 with 8.0.x, email doesn't come through. If a user has an iPhone 5 and is already connected to Exchange, and they update to iOS 8.0.x it works.
It seems like a new iOS 8 device will not register with Exchange. I look in OWA and look at my Devices and there is nothing in there.
Others have suggested making sure you don't have over 10 devices registered, resetting Network Settings on the iPhone, holding the power button and home button until reset, resetting the iPhone to factory. None of these things have worked for us.
If we find a solution I will post here. Hopefully someone finds something out soon.
0
 
LVL 32

Expert Comment

by:it_saige
ID: 40357434
@JTOCCO - I did find, (really didn't look into the IPhone versions), that setting up an IPhone on Exchange 2013 CU5.  The domain would, sometimes, have data in it.  When we cleared the domain field (especially since it is an optional field) the IPhone would connect without any problems.

Now this may also just be specific to my environment and Exchange server setup.  But I really did not do anything special with the AutoDiscover or OutlookAnywhere configuration.

I just went to someone who bought a new IPhone 6 to have them test connecting.  All this person did was specify Exchange, put in their username and password.  Viola.  No errors or hiccups.

-saige-
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40357440
Does https://testexchangeconnectivity.com (Activesync test) show up any errors for any of the accounts?
0
 
LVL 32

Expert Comment

by:it_saige
ID: 40357453
@JTOCCO - I did just check with them and they are using IOS 8.0.2.

-saige-
0
 

Author Comment

by:ChrisEDavis
ID: 40357467
JTOCCO.
That's interesting. This user has an iPad running ios 8. But Exchange was et up on it before it was upgraded to ios 8. It receives and sends mail just fine. But the new iPhone 6 with ios 8 already installed only send mail, it does not receive any. We d not have Office 365. We are running an internal Exchange 2003 server. This user changes devices often. He has had a least 3 iPads. He went from an iPhone 5 to an Android phone. Now he has the new iPhone 6. So he could have a lot of devices registered. But I don't know how to look that up on Exchange 2003? If he does have old devices registered can I unregister them somehow to see if it helps with the issue?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40357485
You need this installed to manage Mobiles on Exchange 2003:

http://www.microsoft.com/en-us/download/details.aspx?id=22243

Instructions on it's use here:
http://technet.microsoft.com/en-us/library/bb508837(v=exchg.65).aspx

Alan
0
 
LVL 1

Expert Comment

by:JTOCCO
ID: 40357515
-saige-
I deleted the entry for Domain and when I click on Done I get the following:
"Exchange Account
Unable to verify account information"

I tried to do that when first setting up the account and had the same message. Thanks for the suggestion though.

I did see in another Apple forum that they restarted IIS on the Exchange servers and that worked for them.
https://discussions.apple.com/thread/6561442
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:ChrisEDavis
ID: 40357689
Ok what I have tried so far.
1. I have checked the ios 8 version and it is 8.0.2
2. I have tried it on Verizon LTE and WiFi.
3. I have installed the ActiveSync Web Administration tool as Alan suggested. He has 7 devices listed/ I deleted all but two his iPad and new phone. Then deleted and re-installed the Exchange account on the iPhone.
4. Tried setting up with our domain and without. Both ways set up ok without error. But neither work.

After all that the phone still sends mail ok. But the inbox is blank. It's as of there is a filter or something hiding the mail?
0
 
LVL 32

Expert Comment

by:it_saige
ID: 40357719
Not to ask a dumb question, but have you checked to ensure that the IPhone is set to synchronize mail?  Especially since you can control not only what get's synchronized but also how much of it to synchronize.

-saige-
0
 

Author Comment

by:ChrisEDavis
ID: 40357800
What I have tried now is:
1.  Setting up a different Exchange user account on that iPhone. It didn't work ether. So doesn't seem to be a problem with his account.
2. I've set up his Exchange account as Imap instead of using the Exchange option. That works, it is sending and receiving mail.

Unless one of you experts comes up with a something to try I am out of ideas and will just tell him to use Imap.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40357844
Have you run the Activesync test on the test site (as per my previous comment)?

Specify manual server settings and tick the ignore trust for SSL if you use a self-issued certificate.

If that passes/fails then please check your settings using my article to make sure everything is configured 100% as it should be:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 

Author Comment

by:ChrisEDavis
ID: 40358108
Sorry Alan.  I ran the test with our server set as it was. It said there is a missing intermediate certificate. I then made some changes to the Exchange and ActiveSync virtual servers to match what your article specified. Ran test again. Same error. The certificate it shows is the cert that is installed and it is valid as far as I can see.

Should I try the iPhone again to see if the changes made a difference?

As I said all mobile devices and OWA etc have always worked up to this iPhone. Surely if the cert was bad we would have had problems before now?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40358335
Is the certificate self-issued or from a trusted 3rd party source (if so - who)?

Did you run iisreset after making the changes to the virtual directories?

If you did run iisreset - try the phone again, if not, please run iisreset and test again on the phone.

What settings did you have to change (out of curiosity)?

Alan
0
 

Author Comment

by:ChrisEDavis
ID: 40358352
Yes I did run IISRESET. It stopped and started the IIS service. The certificate is from GoDaddy. I can see it in IIS. It is in date and the correct url for our mail server. I'll try the phone again.
0
 

Author Comment

by:ChrisEDavis
ID: 40358359
The testconnectivity web utility says the GoDaddy cert is missing. But the cert I see in IIS i
s the same cert ... same serial number. So it isn't missing?

If I understand correct, if the cert were missing we would get errors when we connect mobile devices. But all mobile devices have connected just fine so far without any cert errors.
0
 

Author Comment

by:ChrisEDavis
ID: 40358376
I ran the sslchainsaver utility. It found 3 certs. But below that says "WARNING: needed 2 certs from the server but got 1. You must install the intermediate certs onto the device."

iPhone still doesn't receive mail only sends.

 Now I'm really confused?
0
 
LVL 1

Expert Comment

by:JTOCCO
ID: 40359658
Restarted IIS last night. No change. No email on new iOS 8 phones. Not sure what to do next. Looks like you can't downgrade to iOS 7 either.
0
 
LVL 1

Expert Comment

by:JTOCCO
ID: 40359874
Ran this PS cmd and found the Device ID:

Export-ActiveSyncLog -Filename:"c:\inetpub\logs\LogFiles\W3SVC1\u_ex141003.log" -OutputPath:"d:\exreports\easreports"

Found the Device ID in the Users.csv file.
So the device is showing as hitting the CAS server. I then ran this PS cmd:

Set-CASMailbox -Identity username -ActiveSyncAllowedDeviceIDs xxxxxxxxxxxxxxxxxxxxxxxxxx

Didn't help. I saw this idea on one of the Apple forums and it worked for that administrator. He mentioned that the Apple Device ID's were 12 digits, but with iOS 8 they are 26 digits.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40359945
Can you instal the intermediate certificate please, then re-test and see if the test is 100% happy.

https://support.godaddy.com/help/article/868/what-is-an-intermediate-certificate?countrysite=uk

What AV software is installed on the server (if any)?

Alan
0
 
LVL 1

Expert Comment

by:JTOCCO
ID: 40360391
We got it to work. We use Soti MobiControl as an MDM. There is a check box for using Soti's security. Our Soti admin unchecked that box and everything worked. Our new iOS phones connected and download email, received contacts, etc. He is going to check with Soti to see if there is an update for their software.
The checkbox is called "Enable Secure Email Access". We have since re-enabled this setting because we don't want employees registering their personal iPhones with corporate email.
Check your MDM if you have one. Hope that helps someone.
0
 

Author Comment

by:ChrisEDavis
ID: 40400609
The iPhone 6 connectivity is still a problem for us. Strangely enough the iPhone 6 I had the problem with when I started this thread suddenly started working. I didn't change anything. But now the owner has a new iPhone 6 and same problem - sends mail OK but won't receive any. I am hoping that phone will simply start working like the first one did. They both have the same settings so should. I'll keep you posted.
0
 

Author Comment

by:ChrisEDavis
ID: 40411659
Well would you believe it. The second iPhone 6 suddenly started working, days later, all on its own, just like the first one did. Both the IMAP and Exchange clients are now sending and receiving on both iPhone 6s perfectly. I am totally confused. I have never seen a system do that.

Someone suggested that it may be due to the recent SSL change. In that SSL certs can't use .local names any more. Not sure how that would have affected our situation as the domain on the cert is for our .com domain. However the mail server where the cert was installed does have a .local address? So maybe somehow that did cause the problem. If so why would it now be working ok?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40411992
A bit random!

Mail servers can have .local in their name and (internally), but the SSL cert Fully Qualified Domain Name (FQDN) MUST use the public FQDN that resolves externally to the Public IP Address of the Exchange Server.

If the SSL cert got changed and the name used changed too, then that could be the main reason.
0
 

Accepted Solution

by:
ChrisEDavis earned 0 total points
ID: 40440757
As I said earlier, the two iPhone 6's I had problems with connected on their own days later. I still have no idea why or what caused the problem. Thanks all for your suggestions.
0
 

Author Closing Comment

by:ChrisEDavis
ID: 40449397
Problem went away on its own
0

Featured Post

Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

Join & Write a Comment

Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now