Solved

Configuring GLBP

Posted on 2014-10-01
8
154 Views
Last Modified: 2014-10-02
I have the Topology shown in the screenshot below.
When I run Traceroute from R4 or R5 to R1 interface, it will show that it will go to R2 then R3 or the other way around before it reaches R1 interface:

============================================
R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 52 msec
    10.10.10.3 40 msec
    10.10.10.2 16 msec
  2 20.20.20.1 52 msec *  64 msec
R4#
====================================
R5#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 48 msec
    10.10.10.2 28 msec
    10.10.10.3 20 msec
  2 20.20.20.1 52 msec 36 msec 44 msec
R5#

Open in new window

 


Configuration of the Routers

R1#sh run
Building configuration...

Current configuration : 1434 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
 
!
ip tcp synwait-time 5
!
 
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 20.20.20.1 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/4
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/5
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/6
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/7
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 network 20.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
!
 
control-plane
!
 
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R1#
==================================
==================================

R2#sh run
Building configuration...

Current configuration : 1094 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup

!
ip tcp synwait-time 5
!

interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.2 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 glbp 1 ip 10.10.10.100
 glbp 1 timers 1 3
 glbp 1 priority 120
 glbp 1 preempt
 glbp 1 authentication md5 key-string cisco
!
interface GigabitEthernet1/0
 ip address 20.20.20.2 255.255.255.0
 negotiation auto
!
router rip
 network 10.0.0.0
 network 20.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
!
 
control-plane
 
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R2#
===========================
=============================

R3#sh run
Building configuration...

Current configuration : 1073 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
 
!
ip tcp synwait-time 5
!
 
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.3 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 glbp 1 ip 10.10.10.100
 glbp 1 timers 1 3
 glbp 1 preempt
 glbp 1 authentication md5 key-string cisco
!
interface GigabitEthernet1/0
 ip address 20.20.20.3 255.255.255.0
 negotiation auto
!
router rip
 network 10.0.0.0
 network 20.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
!

control-plane
 
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R3#
============================
============================
R4#sh run
Building configuration...

Current configuration : 866 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
 
!
ip tcp synwait-time 5
!
 
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.4 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
router rip
 network 10.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
 
!
control-plane
 
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R4#
===============================
===============================
R5#sh run
Building configuration...

Current configuration : 866 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
 

ip tcp synwait-time 5
!
 
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.5 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
router rip
 network 10.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
 
!
control-plane
 
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R5#
===========================================

Open in new window


GLBP
0
Comment
Question by:jskfan
  • 4
  • 3
8 Comments
 
LVL 27

Accepted Solution

by:
Predrag Jovic earned 460 total points
ID: 40356352
When I run Traceroute from R4 or R5 to R1 interface, it will show that it will go to R2 then R3 or the other way around before it reaches R1 interface:

R5#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 48 msec
    10.10.10.2 28 msec
    10.10.10.3 20 msec
  2 20.20.20.1 52 msec 36 msec 44 msec
R5#

No, that's not what is shown.

Traceroute sends 3 packets - the output shows that there is a load balancing present, and that your traffic is using both gateway routers to reach R1. First and third packets are using 10.10.10.3 as gateway, and second packet uses 10.10.10.2 as gateway.
If there is a looping you would see output like this (and somehow routers resolve loop):
1 10.10.10.3 48 msec 28 msec 20 msec
2 10.10.10.2 28 msec 28 msec 20 msec
3 10.10.10.3 20 msec 28 msec 20 msec
4 20.20.20.1 52 msec 36 msec 44 msec
0
 

Author Comment

by:jskfan
ID: 40356490
OK... that 's good to know that 's how Traceroute works...

Even though I have not configured Tracking, I simulated a failure on a link between R2 and R1, and still managed to connect to R1 from  R4, it shows that it is going through R3.

R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1  *
    10.10.10.3 32 msec 28 msec
  2  *
    20.20.20.1 60 msec 56 msec

Open in new window


So I am not sure when tracking will come into play, considering my topology shown above.
0
 
LVL 27

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 460 total points
ID: 40356729
Tracking come into play when link after default gateway is down...

Let assume you track link between R2 and R1 - if that link fail  - router will send packets only to R3 router.

But in your case (reason why packets are sent to both routers) I think what causes that behavior is routing protocol - RIP. If you list show ip route on R4 and R5 you will see that you have two equal cost paths to  R1 one have R2 as next hop, and one have R3 as next hop. Correct me if I'm wrong.

All this trouble right now is because your routers R4 and R5 are using routing protocol to send packets.
Issue no ip routing command in global configuration mode, and set ip default-gateway X.X.X.X on both of those routers. So they can act like hosts.
0
 

Author Comment

by:jskfan
ID: 40357266
Regarding  the routing table , you are correct, I have an equal cost to R1 with RIP.
I have used No IP Routing on R4 and R5
I have not configured a DG yet on R4 and R5 as you suggested, but when I traceroute from R4 to R1 , it will always go through R2 (AVG) even when I Clear Arp-Cache on R4.
When I trace from R5 to R1 it will work fine it will go one time through R2 and when I clear arp-cache, next time it will go through R3 (I believe that's the normal behavior of Round Robin)
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:jskfan
ID: 40357282
After I configured IP Default-Gateway 10.10.10.100 (Virtual  IP)

Now R4 works fine, one time Traceroute to R1 goes through R2 and after clear arp-cache it will go through R3

But R5 it will always go through R2
0
 
LVL 27

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 460 total points
ID: 40357310
GNS 3 have bugs, maybe it's one of them. (Just in case always triple check IP addresses - I know I always do, lots of times I miss stupid mistakes like IP Default-Gateway 10.10.10.10 instead of IP Default-Gateway 10.10.10.100 etc )

I had my own nightmares with GNS 3, but ... usually works good with some Cisco images.

:)

And of course you can unplug cable on  router R2 (or shutdown) interface g0/0 - in that case R5 should be forced to use R3 router as gateway if everything is OK.
0
 
LVL 45

Assisted Solution

by:Craig Beck
Craig Beck earned 40 total points
ID: 40357353
It's fair to say you're using per-packet load-balancing here, so everything is working as it should.
0
 

Author Closing Comment

by:jskfan
ID: 40357398
Thank you Guys!!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SSH logs Cisco switch 4 66
fiber and Gig ports on 3650 5 40
using BGP Attributes 2 54
How to route a specific IP address to a specific port on a Fortinet 90D 2 26
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now