SSl error after changing default accepted domain sbs 2011

I recently had to change the default sending domain and remove the previous default sending domain. I rekey the the ssl cert and it has been issued to the new domain name. The issue i am having is all of our existing and newly created outlook profiles get an ssl certificate error message and the old domain name is displayed but when i go the Subject alt names i see the new domain name and it is issues to the right organization. Also, everytime i create a new outlook profile, i see that the url to connect to owa is the old address. Please let me know if you need more clarification.
dsclaAsked:
Who is Participating?
 
Gareth GudgerConnect With a Mentor Commented:
The just means that what you have specified in your URLs in Exchange do not match a name on your certificate. Can you confirm that each of the URLs in Exchange are listed on your cert?
0
 
Gareth GudgerCommented:
You need to update your Exchange URLs to reflect a name on the cert.
http://supertekboy.com/2014/05/27/designing-a-simple-name-space-for-exchange-2010/
0
 
Simon Butler (Sembee)ConsultantCommented:
As this is SBS, did you run through the wizards in the SBS console to change the domain? If you didn't, you need to do that. Then once complete, use the certificate wizard to enable your new SSL certificate.
Trying to do it outside of the SBS console will cause you nothing but problems.

Simon.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
dsclaAuthor Commented:
i have tried both suggestions, none have resolved the issue of my ssl. any other suggestions? the message i get says "the name of the security certificate is invalid or does not match the name of the site. "
0
 
dsclaAuthor Commented:
urls are listed. Once i created an a record for autodiscover the ssl issue seems to be resolved.
0
 
Gareth GudgerCommented:
All problems good?
0
 
dsclaAuthor Commented:
Yes sir, thank you lending hand in figuring this out
0
 
Gareth GudgerCommented:
Glad to help.
0
All Courses

From novice to tech pro — start learning today.