Windows DNS Server Not Returning Correct Resolve

I have a public DNS server our company uses for itself and a few customers.  I have not had any issues with the server till today.  Here is what we have

Windows Server 2008 R2
Primary DNS Server

Windows Server 2008 R2
Secondary DNS Server

History of issue:
3 days ago we changed an “A” Record for as we had a web server change.  This server also has a ticket system on it that receives emails so we have a “MX” record that points to the same as the A record.
In the DNS Manager all records look correct.
The Secondary DNS Server has synced with the primary and has all the same records.

But we are still getting emails to the old server. We thought it was simply a propagation issue but come to find out our NS01 is returning the old record even though it has been updated.  When we go to mxtoolbox and check NS01 gives us the old record but NS02 gives us the correct one.  This is extremely odd as how could NS02 have the right one sense it gets it from NS01?  We have tried the following

Clear Cash
Update Server Data Files
Scavenge Stale Resource Records.
All from the GUI in DNS Manager.

We have followed all of the Technet check lists and troubleshooting guides and we are not getting anything to work.  Please help.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris HInfrastructure ManagerCommented:
Have you checked your reverse records?  Make sure you don't have an incorrect PTR record in there for your subnet.

Found this hotfix.  Shot in the darK?
Iggy79Author Commented:
I do have a PTR for and it points to the correct IP address.

This also does not explain why I am getting correct resolves from NS02 but not from NS01.  I have also checked the Windows Event log and I cannot find anything that looks like it is a red flag.
Chris HInfrastructure ManagerCommented:
On NS01, are forwarders set up?  Is there a public name server listed above your domain server?
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Iggy79Author Commented:
NS01 Config
I have attached a screen shot of NS01
Chris HInfrastructure ManagerCommented:
Right click NS01, click properties and then check the fowarders tab.  Please paste that screenshot.
Iggy79Author Commented:
Here is the screen shoot.NS01 Forwarders
jkaiosIT DirectorCommented:
try to ping the IP Address and see if that correctly resolves it to the correct name, using the -a switch:

ping -a

if it doesn't resolve correctly, then there is possibly a problem (sometimes duplicate) with your Reverse DNS Lookup records.
Iggy79Author Commented:
This issue was resolved but removing all the static IP settings on the NIC and reapplying them.  not sure why this solved the issue as I put in all the same values that it had previous.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Iggy79Author Commented:
I solved it myself.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.