Solved

How to Test GLBP Load-Balancing

Posted on 2014-10-02
47
342 Views
Last Modified: 2014-10-05
I am trying to Test GLBP Load balancing (The default Round Robin), I ran Traceroute from R4 and R5 to R1(20.20.20.1) , but cannot tell if there is any Load-balancing since the Output is the same.

Thanks

glbp
R5#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 36 msec 20 msec 20 msec
  2 10.10.10.3 48 msec 32 msec 32 msec
  3 20.20.20.1 64 msec 44 msec 44 msec
R5#clear arp-cache
R5#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 1020 msec 40 msec 24 msec
  2 10.10.10.3 44 msec 32 msec 24 msec
  3 20.20.20.1 52 msec 64 msec 44 msec
R5#

Open in new window


R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 52 msec 20 msec 20 msec
  2 10.10.10.3 40 msec 32 msec 32 msec
  3 20.20.20.1 56 msec 40 msec 32 msec
R4#clear arp-cache
R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 1036 msec 16 msec 12 msec
  2 10.10.10.3 40 msec 20 msec 20 msec
  3 20.20.20.1 56 msec 52 msec 32 msec
R4#

Open in new window

0
Comment
Question by:jskfan
  • 23
  • 18
  • 6
47 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40357843
Look at the ARP cache of the hosts for the default gateway entry. If load balancing is properly configured and working, the two hosts should have different MAC addresses.
0
 

Author Comment

by:jskfan
ID: 40358541
Apparently the MAC addresses of the Default gateway are the same:

R4#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.10.10.4              -   ca03.216c.0008  ARPA   GigabitEthernet0/0
Internet  10.10.10.100            0   0007.b400.0101  ARPA   GigabitEthernet0/0
R4#


R5#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.10.10.5              -   ca00.18d8.0008  ARPA   GigabitEthernet0/0
Internet  10.10.10.100            0   0007.b400.0101  ARPA   GigabitEthernet0/0
R5#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40358558
Then you don't have load balancing enabled.
0
 

Author Comment

by:jskfan
ID: 40358633
I thought GLBP uses Round Robin Load balancing by default ..
0
 

Author Comment

by:jskfan
ID: 40358648
I have just configured Load balancing manually to be Round Robin
show arp still shows the same MAC address for the default gateway on both R4 and R5
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40358902
Please post the config of the two GLBP routers.
0
 

Author Comment

by:jskfan
ID: 40359619
I will ....thanks
Just noticed

R2#sh run
Building configuration...

Current configuration : 1104 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.2 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 glbp 1 ip 10.10.10.100
 glbp 1 timers 1 3
 glbp 1 priority 120
 glbp 1 preempt
 glbp 1 authentication md5 key-string cisco
!
interface GigabitEthernet1/0
 ip address 20.20.20.2 255.255.255.0
 shutdown
 negotiation auto
!
router rip
 network 10.0.0.0
 network 20.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R2#

Open in new window

==========================================================
==========================================================

R3#sh run
Building configuration...

Current configuration : 1073 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.3 255.255.255.0
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
 glbp 1 ip 10.10.10.100
 glbp 1 timers 1 3
 glbp 1 preempt
 glbp 1 authentication md5 key-string cisco
!
interface GigabitEthernet1/0
 ip address 20.20.20.3 255.255.255.0
 negotiation auto
!
router rip
 network 10.0.0.0
 network 20.0.0.0
 no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R3#
0
 

Author Comment

by:jskfan
ID: 40359634
Sorry....
I noticed even after I configured on R2 and R3  Load- balancing , the command does not show up in the :Show Running Configuration, maybe because is the default:
(config)#interface gigabitEthernet 0/0
(config-if)#glbp 1 load-balancing round-robin
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40359705
please post the output of a "show glbp" for both routers.
0
 

Author Comment

by:jskfan
ID: 40359713
R2#sh glbp
GigabitEthernet0/0 - Group 1
  State is Active
    2 state changes, last state change 08:44:37
  Virtual IP address is 10.10.10.100
  Hello time 1 sec, hold time 3 sec
    Next hello sent in 0.644 secs
  Redirect time 600 sec, forwarder time-out 14400 sec
  Authentication MD5, key-string "cisco"
  Preemption enabled, min delay 0 sec
  Active is local
  Standby is 10.10.10.3, priority 100 (expires in 2.444 sec)
  Priority 120 (configured)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    ca02.0e94.0008 (10.10.10.2) local
    ca04.216c.0008 (10.10.10.3) authenticated
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      1 state change, last state change 08:44:34
    MAC address is 0007.b400.0101 (default)
    Owner ID is ca02.0e94.0008
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 100
    Arp replies sent: 56
  Forwarder 2
    State is Listen
      16 state changes, last state change 00:45:13
    MAC address is 0007.b400.0102 (learnt)
    Owner ID is ca04.216c.0008
    Redirection enabled, 599.524 sec remaining (maximum 600 sec)
    Time to live: 14399.524 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 10.10.10.3 (primary), weighting 100 (expires in 2.520 sec)
    Arp replies sent: 53
R2#

Open in new window



R3#sh glbp
GigabitEthernet0/0 - Group 1
  State is Standby
    33 state changes, last state change 00:45:58
  Virtual IP address is 10.10.10.100
  Hello time 1 sec, hold time 3 sec
    Next hello sent in 0.192 secs
  Redirect time 600 sec, forwarder time-out 14400 sec
  Authentication MD5, key-string "cisco"
  Preemption enabled, min delay 0 sec
  Active is 10.10.10.2, priority 120 (expires in 2.404 sec)
  Standby is local
  Priority 100 (default)
  Weighting 100 (default 100), thresholds: lower 1, upper 100
  Load balancing: round-robin
  Group members:
    ca02.0e94.0008 (10.10.10.2) authenticated
    ca04.216c.0008 (10.10.10.3) local
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Listen
      22 state changes, last state change 00:46:01
    MAC address is 0007.b400.0101 (learnt)
    Owner ID is ca02.0e94.0008
    Time to live: 14399.184 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 10.10.10.2 (primary), weighting 100 (expires in 2.184 sec)
  Forwarder 2
    State is Active
      1 state change, last state change 08:45:23
    MAC address is 0007.b400.0102 (default)
    Owner ID is ca04.216c.0008
    Preemption enabled, min delay 30 sec
    Active is local, weighting 100
R3#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40359716
And round-robin is the default.
0
 

Author Comment

by:jskfan
ID: 40359732
And round-robin is the default.
Correct..

But I am not sure if Traceroute uses Round Robin... I am trying Traceroute to R1 from R4 and R5 but they seem to be both using R2 then R3 to get to R1....
AS you said in the previous topic that 's the behavior of Traceroute...
But what tool should I use to confirm that there is Round Robin Load balancing ?
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40359764
config looks OK
and in show glbp you have

  Load balancing: round-robin
  Group members:
    ca02.0e94.0008 (10.10.10.2) local
    ca04.216c.0008 (10.10.10.3) authenticated
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40359770
Please post the config of R4 & R5.  Something's not right here.
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40359809
Traceroute don't use Round Robin. Traceroute is just sent, and whereever it goes - it  just sends message back.

The only strange thing that I notice here is:
R3#sh glbp
GigabitEthernet0/0 - Group 1
  State is Standby
    33 state changes, last state change 00:45:58

R2#sh glbp
GigabitEthernet0/0 - Group 1
  State is Active
    2 state changes, last state change 08:44:37

Somehow I expect to see similar number of state changes on both routers. And that time from last state change is the same.
0
 

Author Comment

by:jskfan
ID: 40359834
R4 and R5 Configuration:


R4#sh run
Building configuration...

Current configuration : 905 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip routing
no ip icmp rate-limit unreachable
!
no ip cef
no ip domain lookup
 !
ip tcp synwait-time 5
 !
interface Ethernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.4 255.255.255.0
 no ip route-cache
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
ip default-gateway 10.10.10.100
!
no ip http server
no ip http secure-server
! 
control-plane
!
 
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R4#
===========================================

R5#sh run
Building configuration...

Current configuration : 905 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip routing
no ip icmp rate-limit unreachable
!
no ip cef
no ip domain lookup
 
!
ip tcp synwait-time 5
 
!
interface Ethernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
!
interface GigabitEthernet0/0
 ip address 10.10.10.5 255.255.255.0
 no ip route-cache
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
ip default-gateway 10.10.10.100
!
no ip http server
no ip http secure-server
 
!
control-plane
 
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R5#

Open in new window

0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40359842
What cisco image you use in GNS3?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40359867
Nope. Doesn't make sense. Your traceroute output is totally wrong.  It's showing the packet going to R2. Which then forwards it to R3. Who then sends it to 20.20.20.1

Forget GLBP, there's something else going on. I'm thinking R2's link is down...

That's it. The G1/0 interface on R2 is still shutdown.
0
 

Author Comment

by:jskfan
ID: 40359868
Image 7200
0
 

Author Comment

by:jskfan
ID: 40359884
You are correct Don.
R2#sh ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         10.10.10.2      YES NVRAM  up                    up
GigabitEthernet1/0         20.20.20.2      YES NVRAM  administratively down down
R2#

However even after I brought the interface UP, still Traceroute to R1 goes through R2 only:

R5#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 28 msec 32 msec 20 msec
  2 20.20.20.1 68 msec 40 msec 44 msec
R5#clear arp-cache
R5#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 1028 msec 32 msec 20 msec
  2 20.20.20.1 64 msec 44 msec 44 msec
R5#


R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 44 msec 20 msec 12 msec
  2 20.20.20.1 52 msec 44 msec 32 msec
R4#clear arp-cache
R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.2 1028 msec 44 msec 20 msec
  2 20.20.20.1 44 msec 32 msec 32 msec
R4#
0
 

Author Comment

by:jskfan
ID: 40361586
Hi Don and Petrag,

I am not sure if you saw my last comment...
I am still trying to find out why Traceroute from R4 and R5 is not using R3
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40361595
Round Robin load balancing is enabled.  There's no question about that.

The two hosts (R4 & R5) have their default-gateway set to the GLBP virtual IP.

Yet for some reason, AVG is not alternating the AVF MAC address.

It could be just GNS weirdness.

The only other thing that I can think to try is to reload all the devices. Maybe there's some vestige of something in a cache or buffer or something.
0
 

Author Comment

by:jskfan
ID: 40361670
The Round Robin Load balancing works jus fine when I Traceroute to the GLBP Virtual IP address 10.10.10.100
R4#traceroute 10.10.10.100

Type escape sequence to abort.
Tracing the route to 10.10.10.100

  1 10.10.10.2 28 msec 28 msec 20 msec
R4#clear arp-cache
R4#traceroute 10.10.10.100

Type escape sequence to abort.
Tracing the route to 10.10.10.100

  1 10.10.10.3 40 msec 28 msec 20 msec
R4#

Open in new window



Round Robin Load Balancing to R1 is not obvious, May be it is supposed to work just for the Virtual IP address of GLBP.


R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 24 msec
    10.10.10.2 44 msec
    10.10.10.3 16 msec
  2 20.20.20.1 52 msec 48 msec 40 msec
R4#clear arp-cache
R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 36 msec
    10.10.10.2 28 msec
    10.10.10.3 20 msec
  2 20.20.20.1 68 msec 40 msec 40 msec
R4#

Open in new window

0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 50

Expert Comment

by:Don Johnston
ID: 40361702
The results of what you're seeing when sending to R1 is consistent with a router that has two equal cost paths (ECMP).

What does the routing table of R4 look like after pinging R1?
0
 

Author Comment

by:jskfan
ID: 40361730
After pinging R1

R4#ping 20.20.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/50/72 ms
R4#
R4#
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    20.0.0.0/8 [120/1] via 10.10.10.3, 00:00:07, GigabitEthernet0/0
                [120/1] via 10.10.10.2, 00:00:23, GigabitEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, GigabitEthernet0/0
R4#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40361735
There's your problem.  You've got two RIP routes to the 20.0.0.0 network.
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40361848
You turned on ip routing on R4 and R5 again?
:)
My sugestion

Turn off RIP on all routers.
Create GLBP on routers R2 and R3 for both networks 10.10.10.0/24 and 20.20.20.0/24.
Turn off ip routing on R4, R5 and R1. Give them default gateway IP address of Virtual IP address of GLBP  for their network.
0
 

Author Comment

by:jskfan
ID: 40362032
If I turn off RIP, I cannot ping from R4 or R5 to R1. So I left RIP on R1,R2,R3.
I have created GLBP group 2 for Network 20.20.20.0

 Now Round Robin Load Balancing works fine, it just depends on the Clear Arp-cache .
Sometimes Traceroute goes through the same router for several tries before it changes to anther router...
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362037
If you're running RIP on the hosts, GLBP is totally unnecessary.  It's also not very realistic since hosts typically don't run routing protocols.
0
 

Author Comment

by:jskfan
ID: 40362053
I turned off RIP on all Routers. Now from R4 and R5 I can ping GLBP virtual IP addresses for group 1(10.10.10.100) and Group 2(20.20.20.100), but cannot ping R1 ip address(20.20.20.1).
 Do not you think I need Routing Protocol since R4 and R5 are in 10.10.10.0 network while R1 is in 20.20.20.0 Network ?

R4#ping 10.10.10.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/23/40 ms
R4#ping 20.20.20.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.100, timeout is 2 seconds:
!!.!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/275/1036 ms
R4#ping 20.20.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R4#

Open in new window


R5#ping 10.10.10.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/36 ms
R5#ping 20.20.20.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/44 ms
R5#ping 20.20.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R5#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362058
If you're trying to emulate a real network with R4 and R5 acting as computers, running RIP (or any routing protocol) is not realistic.

Create a static, default route on R4 and R5 pointing to the GLBP virtual IP
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40362068
ip default-gateway  10.10.10.100  on R4 R5
ip default-gateway  20.20.20.100  on R1

if 0.0.0.0 0.0.0.0 10.10.10.100 is used I not sure it will work  if you have no ip routing issued
0
 
LVL 26

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 100 total points
ID: 40362251
Go to R1 and issue debug ip icmp
Then ping from R4 and R5
ping 20.20.20.1

if ping is coming to 20.20.20.1 (you'll see debuging messages) then problem is that R1 don't know way back to 10.10.10.x and to go back R1 either need default gateway or default route to 10.10.10.0 network
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362284
A routing protocol is not necessary in this environment since there are only two networks and both routers are connected to both networks.

Just disable RIP on all routers and create a default route on R4 & R5 pointing to the GLBP virtual IP address.  On R1, create a default route and point it to either 20.20.20.2  or 20.20.20.3

There's no benefit to making this more complicated than it needs to be.
0
 

Author Comment

by:jskfan
ID: 40362689
Just disable RIP on all routers and create a default route on R4 & R5 pointing to the GLBP virtual IP address.  On R1, create a default route and point it to either 20.20.20.2  or 20.20.20.3

I followed your above suggestion, but still cannot ping from R4 or R5 to R1 or the other way around.
I cannot even ping from R4 or R5 to the 20.20.20.X interfaces of R2 or R3
I cannot also ping from R1 to R2 and R3 interfaces located on 10.10.10.0 network
0
 

Author Comment

by:jskfan
ID: 40362694
Please Disregard my Last Comment for Now
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362700
post the output of a "show ip route" for all the routers please.
0
 

Author Comment

by:jskfan
ID: 40362713
below is the Output of Show IP Route of all Routers:
R1#sh ip route
  
Gateway of last resort is 20.20.20.3 to network 0.0.0.0

     20.0.0.0/24 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, GigabitEthernet0/0
S*   0.0.0.0/0 [1/0] via 20.20.20.3
R1#
=====================================
R2#sh ip route
 
Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, GigabitEthernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, GigabitEthernet0/0
R2#
=====================================
R3#sh ip route
 
Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, GigabitEthernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, GigabitEthernet0/0
R3#
========================================
R4#sh ip route
 
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, GigabitEthernet0/0
R4#
==============================================

R5#sh ip route
 

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, GigabitEthernet0/0
R5#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362728
R4 & R5 need a default route or default gateway.
0
 

Author Comment

by:jskfan
ID: 40362733
they do have DG.
R4#sh run | include ip default
ip default-gateway 10.10.10.100
R4#

Open in new window


R5#sh run | include ip default
ip default-gateway 10.10.10.100
R5#

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362735
Personally, I don't like the "ip default-gateway" command on routers. It's fine on L2 switches, but I've found it buggy on routers. I would use a default route.
0
 

Author Comment

by:jskfan
ID: 40362746
I removed DG from R4 and R5 and added Default Route
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip route 0.0.0.0 0.0.0.0 10.10.10.3

I can reach R1 now, but the Load balancing does not seem to work. the Traceroute  goes through R3

R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 44 msec
    10.10.10.2 32 msec
    10.10.10.3 28 msec
  2 20.20.20.1 72 msec *  76 msec
 R4#clear arp-cache
R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 48 msec
    10.10.10.2 28 msec
    10.10.10.3 28 msec
  2 20.20.20.1 88 msec 88 msec 72 msec
R4#
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 400 total points
ID: 40362752
The route has to point to the GLBP virtual IP address (10.10.10.100)
0
 

Author Comment

by:jskfan
ID: 40362759
The route has to point to the GLBP virtual IP address (10.10.10.100)

It looks like it is working fine now


R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1  *
    10.10.10.2 32 msec 20 msec
  2  *
    20.20.20.1 76 msec 92 msec
R4#clear arp-cache
R4#traceroute 20.20.20.1

Type escape sequence to abort.
Tracing the route to 20.20.20.1

  1 10.10.10.3 48 msec 20 msec 28 msec
  2 20.20.20.1 100 msec 52 msec 100 msec
R4#
0
 

Author Closing Comment

by:jskfan
ID: 40362772
Thank you very much Guys  for your Help !!!
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40362846
In the future, you will find this process is much easier and faster if you

A) Get the basic network functionality working.  No fancy protocols, authentication, encryption, etc.  Just build the fundamental network topology and get that working.

B) Post the actual output requested

C) If you change the configuration, tell us so we're not trying to troubleshoot a different configuration than is actually running.
0
 

Author Comment

by:jskfan
ID: 40362853
Will do ...Thanks Don
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now