How to configure MS Outlook to view HTML emails?

Hey all.

We have HTML emails that go out and we are hearing of issues with MS Outlook and how it is not rendering the HTML emails properly; it loses styling, images, everything. Other email clients work as expected.

I did a quick Google search and read where MS Outlook, and how it renders HTML emails, is dependent on Internet Explorer settings.

First, is this indeed true?

Second, what settings should I look for in MS Outlook / IE?
WebspeederAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guru JiCommented:
Hi What version of outlook you use and is IE the default browser with clients having html rendering issues ?

IE does act as it's HTML rendering engine, but if you tell us the version of outlook and IE that would help anyone to give you further information.
David LeeCommented:
No, that is not true unless the users are on an old version of Outlook.  With Outlook 2007, Microsoft switched to using Word's rendering engine.  It does not support the full HTML/CSS specification.  These two pages explain what it does and does not support.

http://msdn.microsoft.com/en-us/library/aa338201%28v=office.12%29.aspx
http://msdn.microsoft.com/en-us/library/aa338200%28v=office.12%29.aspx

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WebspeederAuthor Commented:
The issue is with Outlook 2010, I'm testing it on Windows 7.

I tried doing the "trusted sites" thing, from here: http://office.microsoft.com/en-us/outlook-help/block-or-unblock-automatic-picture-downloads-in-email-messages-HP010355038.aspx#_Toc301246507

That sounded like the answer but it didn't work.

BlueDevilsFan, I will look at those links, but are you saying images don't download to Outlook? Or is it a matter of configuring the Word version?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

WebspeederAuthor Commented:
BlueDevilsFan, I think I found the issue. background-image is not supported apparently, I'll do some testing to confirm
Guru JiCommented:
In Outlook 2010

1. Click the New Email button or press Ctrl+N while viewing the Inbox.
2. Go to the new message's File, Options dialog.
3. Click Mail, then Editor Options
4. Select Advanced and look near the bottom of the dialog for the option to Show Picture Placeholders.
5. Close the dialog then close the message.

After changing the settings, close the message. Do not sent it! This, like many other message settings (zoom, etc), will apply only to the current message if you send it. You need to close the message to change the global setting.
WebspeederAuthor Commented:
The background-image is not supported, I changed it to <img ….> and it worked.

Thanks for the links.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.