Solved

.Net Debugger is not displaying the values for highlighted variabled

Posted on 2014-10-02
10
145 Views
Last Modified: 2014-10-23
For some reasons, this specific project debugger is not displaying the values for the highlighted variable. I have tested for other projects which are working fine.

My Windows Application calls the Web service - which calls this Class Project. I was able to debug in the past, I am not sure what i am missing for now. I couldnt debug it.
C--Users-ZHQ8HPV-Desktop-DebuggerVariabl
0
Comment
Question by:chokka
  • 6
  • 3
10 Comments
 
LVL 40

Accepted Solution

by:
Kyle Abrahams earned 250 total points
ID: 40358304
in the immediate window did you try typing
?_userId

I'm assuming you're looking for the right hand side?

Where are those variables defined?
0
 

Author Comment

by:chokka
ID: 40358324
Thank you @Kyle, I have to try again by running the project !!
0
 
LVL 69

Assisted Solution

by:Éric Moreau
Éric Moreau earned 250 total points
ID: 40358474
it sometimes happen to me. Normally, a clean and rebuild do the trick
0
 

Author Comment

by:chokka
ID: 40359814
@kyle, My command window is not detecting the variable values.

I tested in a separate project, Command window automatically pulls the variable and can see the values.

This Project has a different architecture.


Windows App - Calls Web Layer Application -

I am not able to see the debugger in the Web Layer Application.

I was able to see till Yesterday.
C--Users-ZHQ8HPV-Desktop-DebuggerCommand
0
 
LVL 40

Expert Comment

by:Kyle Abrahams
ID: 40359897
What URL are you hitting for the webservice?  If you're not hitting local host you may have to attach the debugger manually.
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 

Author Comment

by:chokka
ID: 40360230
I am using the local host. I have attached the asp.net worker process w3wp.exe
0
 
LVL 40

Expert Comment

by:Kyle Abrahams
ID: 40363777
You're not breaking on that line  (otherwise you'd have the yellow arrow with it).  The variable might be out of scope.  

Also I don't see _userId declared anywhere, is it somewhere else in the class?

Try first calling that function (even with a test button) and then seeing if you can get at it.
0
 

Author Comment

by:chokka
ID: 40373669
Still now, i am not able to give an exact reason. Sometime debugger works and sometimes, it fail to work !! Couldnt able to find out the exact reason
0
 

Author Comment

by:chokka
ID: 40399617
@kyle and @Éric Moreau, Thank you guys !!

But i feel like, i found the solution.

.suo file is the debugger for the .sln file.

Delete the .suo file. Probably debugger might have corrupted.

.suo will create automatically when we run the solution. We can debug.
0
 

Author Closing Comment

by:chokka
ID: 40399625
Thanks
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Just a quick little trick I learned recently.  Now that I'm using jQuery with abandon in my asp.net applications, I have grown tired of the following syntax:      (CODE) I suppose it just offends my sense of decency to put inline VBScript on a…
Wouldn’t it be nice if you could test whether an element is contained in an array by using a Contains method just like the one available on List objects? Wouldn’t it be good if you could write code like this? (CODE) In .NET 3.5, this is possible…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now