Solved

remote desktop services

Posted on 2014-10-03
19
151 Views
Last Modified: 2014-10-30
I am running a virtual machine in VMware workstation version 10
This VM is Windows server 2012 R2
The VM is working  fine and I have installed and configured Remote desktop services and published some applications

If I access these services on the VM server from Internet explorer:
https://ticktockit-sbs/REweb

I get the logon screen and log on as Administrator
I can successfully open the Published apps

If I access the VM from outside the VMworkstation - ie from my laptop
I can log on successfully and get the message the the "Connected to RemoteApps and Desktop connection" message in the bottom right hand side of my screen

If I try to open an app I can click it and I get the following message (see attachment)

Any ideas?
I have tried all the obvious things such as user permissions, added the url to the trusted sites etc
Doc1.pdf
0
Comment
Question by:doctorbill
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 8
  • 2
19 Comments
 
LVL 13

Assisted Solution

by:Rizzle
Rizzle earned 168 total points
ID: 40358936
Hi,

What version of IE are you using? Have you tried resetting IE's settings? Have you tried another browser? Also have you got a ts cal license in place?
0
 

Author Comment

by:doctorbill
ID: 40359035
Version 11
Firefoxand chrome
I do not have a ts cal but I was under the impression I had a grace period
If not then would that be the cause?
0
 
LVL 13

Assisted Solution

by:Rizzle
Rizzle earned 168 total points
ID: 40359038
Try what I've mentioned above. But yeah it could be the cause. Just to see if it is try it from another vm connected to your network?
0
Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

 
LVL 58

Assisted Solution

by:Cliff Galiher
Cliff Galiher earned 332 total points
ID: 40359040
How did you configure RDS on this server? Did you use the wizards or did you try to install and configure the roles manually?  The most common cause for these issues is manually configuring RDGateway role and not getting the certificate names right. But several other misconfigurations can occur as well. The wizards really streamline the process and remove the common mistakes people make.
0
 
LVL 58

Assisted Solution

by:Cliff Galiher
Cliff Galiher earned 332 total points
ID: 40359043
I mention this because I noticed your browser address bar is that nice shiny red that is often associated with certificate errors. Browsers can be forced to ignore certificate errors. But RDP clients connecting through an RDGateway server cannot. Certificates *must* be valid, trusted, and have no errors.
0
 

Author Comment

by:doctorbill
ID: 40359053
If it is a cert error how can I trust it in my browser (the one I am using to access outside the vm) or check it's validity in the vm server
0
 
LVL 58

Accepted Solution

by:
Cliff Galiher earned 332 total points
ID: 40359061
Nothing unique to RDS in that answer. You have to trust the issuer, names have to match, it can't be expired, etc. Most browsers provide a way to click on the error in the browser to view details about the certificate and get specifics on any failures. How you fox the issue depends on the cause. Fixing a name issue is very different than fixing an expired certificate, for example. This is really basic SSL stuff here, and there is plenty of SSL knowledge out there if you Google/Bing.
0
 

Author Comment

by:doctorbill
ID: 40359070
The server domain is: ticktock.local
the server name is: ticktockit-sbs

The cert details:
Issued to: webssl.ticktock.local
Issued by: webssl.ticktock.local
Valid from: 27/09/2014 to 29/03/2015

Also - there is no ts CAL in place
0
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40359079
"the server name is: ticktockit-sbs"

Please tell me you aren't trying to set up RDS on an SBS/Essentials server.

You also didn't post anything regarding errors. I can point you in the right direction, but I'm not psychic, and I normally charge my clients for detailed troubleshooting. If you need in-depth assistance, like any profession, you should hire and pay a specialist you trust.
0
 

Author Comment

by:doctorbill
ID: 40359090
The vm server is server 2012 R2

When I click on the app I get the following:
"A wesite wants to run a Remote app program make sure that you trust the publisher before you connect to run the program "
I have added the cert to my Trusted Cert store on my client machine
0
 

Author Comment

by:doctorbill
ID: 40359091
Sorry to elaborest:
"A wesite wants to run a Remote app program make sure that you trust the publisher before you connect to run the program "

Publisher: Unknown Publisher
Type: RemoteApp program
Path: wordpad
Name: WordPad
Remote Computer: ticktock-sbs.ticktock.local
Gateway server: webssl.ticktock.local
0
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40359105
Are you still seeing a cert error in the browser? Is this an essentials machine? The "unknown publisher" item would at least hint that you still have a certificate trust issue.
0
 

Author Comment

by:doctorbill
ID: 40359108
I have installed the cert on the client machine in the trusted root location but still see the cert error
0
 
LVL 58

Assisted Solution

by:Cliff Galiher
Cliff Galiher earned 332 total points
ID: 40359143
Well, you'll need to solve that...
0
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40359144
I also can't help but notice that you've avoided the SBS/Essentials question multiple times now. You are aware that SBS and Essentials *cannot* be used as RDS servers, right.
0
 

Author Comment

by:doctorbill
ID: 40359151
Yes - iI already stated I am using server 2012 R2 ad the vm
0
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 40359164
Yes, and windows server 2012 R2 comes in four editions: foundation, ***essentials***, standard, and datacenter. So saying you were running 2012 R2 does not tell me which edition, and does not eliminate essentials as a possibility. You wouldn't be the first person to try to misuse essentials. And again, I'm not psychic.

Based on your answers (and lack of answers) I will strongly encourage you to call in an IT Pro consultant. There is a fundamental knowledge gap that can't be covered in a forum such as EE.
0
 

Author Comment

by:doctorbill
ID: 40360183
Just for reference:
The VM is server 2012 R2 Datacenter
0
 

Author Closing Comment

by:doctorbill
ID: 40414379
food for thought
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question