Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Issues with Routing Group Connector. E2K3 server delayed in sending email to E2K10 server

Posted on 2014-10-03
10
Medium Priority
?
184 Views
Last Modified: 2014-10-03
I have a strange issue that I solved by rebooting a couple times but it's back. I have an old E2K3 server that I'm pretty much just using as a relay because I have some developers who have the old server name in a ton of scripts and can't change it for now.

What I'm noticing is anything sending emails to that E2K3 server gets stuck in the E2K3 --> E2K10 Routing Group Connector queue. Whether it send the email seems to be hit or miss. Sometimes its delayed for several minutes to several hours. In fact I sent a test email at 8:30am this morning and it hasn't arrived. While i am tying this i decided to go ahead and reboot the E2K3 server and once i hit restart the email i sent at 8:30am came through. maybe it was a coincidence but im not sure.

I've deleted and recreated the RGC and restarted SMTP on E2K3 and Transport.exe on E2K10. I am not sure what changed in our environment. We don't touch the exchange servers other than to add and delete people.

One other thing of note, and I'm not sure if it's always been like this but it seems as though some of the emails from the developers servers send a mail from: <> which causes E2K10 to say Invalid system Resources, even though we have plenty of space.

The E2K3 server rebooted and some of the emails are being sent but i currently have 408 messages in the queue.

RGC
0
Comment
Question by:msidnam
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 7

Accepted Solution

by:
Satyendra Sharma earned 2000 total points
ID: 40359479
Is there anything between your E2k3 and E2010 server or are they on same network?
when the messages start getting backed up can you telnet to Exchange 2010 from 2003 server?

What is the frequency of the messages it also could be that 2010 transport throtling kicks in depending on your configuration - http://technet.microsoft.com/en-us/library/bb232205(v=exchg.141).aspx 

And if your developers are using Exchange 2003 servers name in their script can't you redirect that DNS record to resolve to 2010 and allow the developer's host to relay off Exchange 2010 instead?
0
 
LVL 2

Author Comment

by:msidnam
ID: 40359492
I will take a look at the link. It's been working for the past 3 years and I'm not sure what has changed. We don't have anything between the two servers, they are both on the same network.

I would change DNS to point to the E2K10 server but I'm not sure what issues that will cause since the E2K3 server is still up and running. I'm not sure if queries meant for the E2K3 server will hit the E2K10 server and cause strange issues.

I can telnet from 2003 to 2010 with no problem and I can even send a test email using the mail from, rcpt to and data commands and it comes in very quickly. It seems as though the connector is getting stuck for some reason and I can't tell why.
0
 
LVL 7

Expert Comment

by:Satyendra Sharma
ID: 40359504
If you turn up logging on Exchange 2003 and grab all the ip's that are connecting to that server for email submission and allow them within a relay connector in Exchange 2010 followed by DNS update should get them switched over.  To get more comfort you may want to work with a developer and just switch 1 script and see how it goes. But it will be a cutover at some point unfortunately.

I had to do something similar in the past in that case it was all email relay traffic, and exchange 2003 by default allows all internally authenticated servers and from 2007 onwards it doesn't unless allowed by relay connector or change permissions on default receive connector.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Author Comment

by:msidnam
ID: 40359555
As i'm going through i noticed I still have my old Internet Mail connector under routing groups. That had a smart host in it. i changed it so that it would use DNS and made the E2K3 server the bridgehead server.

Now the emails shifted to the "Messages with an unreachable destination" folder.

If the developers would change their scripts i would be golden. but they says it might take them a while to do so. I would uninstall the old e2K3 server but I know how picky exchange is and half the time it doesnt uninstall correctly. I've also been very bad and still have to change the policies from 2003 to 2010.
0
 
LVL 2

Author Comment

by:msidnam
ID: 40359682
I'm looking at the logs and i see a lot of event 7002:

This is an SMTP protocol warning log for virtual server ID 1, connection #608. The remote host "192.168.0.115", responded to the SMTP command "mail" with "452 4.3.1 Insufficient system resources  ". The full command sent was "MAIL FROM:<> AUTH=<>  ".  This may cause the connection to fail.

On the exchange 2010 server I am not getting any back pressure alerts in the event viewer.
0
 
LVL 2

Author Comment

by:msidnam
ID: 40359807
Folder permissions are. While i didn't see the above article one of the searches i was doing last night took me in the direction of folder permissions.

I'm beginning to think its something with the E2K10 server. Its very sluggish when issuing PS commands and even throws out errors.  and when i do the command again it works but after about a minute.

I deleted the RGC and recreated but this time pointed it to my CAS server and not my mailbox server. going to run some tests now.
0
 
LVL 7

Expert Comment

by:Satyendra Sharma
ID: 40359811
Sounds like your 2010 servers are all-in-one, cuz you need to point to a transport role in RGC.
0
 
LVL 2

Author Comment

by:msidnam
ID: 40360321
The server it was pointed to does have all the roles (it was our first server before we added the CAS).

After pointing to the CAS server it seems to be working a lot better. but now im noticing a mail.que file of 16GB. If its not one thing its another.
0
 
LVL 2

Author Closing Comment

by:msidnam
ID: 40360873
Even though i have space on the hard drive, something is triggering backpressure when my server does the journaling to mimecast. for our journaling send connector i had our mailbox server as the source server. when i set it to the CAS server i didnt get anymore insufficient resource problems.

but im still not sure why since im not getting anything in the event logs.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
Are you an Exchange administrator employed with an organization? And, have you encountered a corrupt Exchange database due to which you are not able to open its EDB file. This article will explain all the steps to repair corrupt Exchange database.
This video discusses moving either the default database or any database to a new volume.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question