Solved

Windows Server 2008 R2 won't boot after hard drive removed

Posted on 2014-10-03
39
613 Views
Last Modified: 2014-10-08
I'm working on a Poweredge 1950 with RAID 1. Disk management only showed one hard drive. I pulled the 2nd drive to see what type it was. Then I shut down the server before pulling the working hard drive to see if it matched. I reinstalled both drives and then it wouldn't boot. I connected both drives to a PC & ran CHKDSK. Some errors were corrected but it still doesn't boot. I have it in my shop now. It says foreign configuration is found on adapter (LAN is unplugged) but continues to boot. Then It says :
Broadcom Base Code PXE-2.1 v1.1.0
Copyright (C) 200-2008 Broadcom Corporation
Copyright (C) 1997-2000 Intel Corporation
PXE-E61: Media test failure, check cable
PXE-M0F: Exiting Broadcom PXE ROM.
I reseated the cable inside on both ends.  What is next?
0
Comment
Question by:Albatross1953
  • 13
  • 9
  • 7
  • +3
39 Comments
 
LVL 9

Expert Comment

by:nattygreg
ID: 40360720
you pulled the drive while server running, it could have writing to the drive when you did that, and now a valuable piece if file is missing. If its not booting then its a rap, nothing else to do. rule of thump never removed hard ware without shutting down the server unless you have hot swappable drives
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40360752
Was this server a DC Domain Controller) ?

Do you have a backup ?

If a DC do you have another DC?

If not a DC then rebuild the server and restore any data from backups
0
 

Author Comment

by:Albatross1953
ID: 40360754
I thought RAID 1 was hot swappable, but I only pulled the drive that wasn't working. It continued to run after I pulled it. It just didn't boot after I shut  it off.  Can the boot sector be rebuilt like in Windows 7?
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40360760
0
 

Author Comment

by:Albatross1953
ID: 40360762
Backup was not installed yet. It was just put in service a few weeks ago & things were still getting ironed out. The data is still visible on the hard drive when connected to another computer, so that's not a problem. It is the only server on the domain. Can I rebuild the boot sector or do I have to do a clean install?
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40360763
I would copy the data off first then do a reinstall that would be the quickest way.
0
 
LVL 9

Expert Comment

by:nattygreg
ID: 40360764
remove the bad disk, and try reboot with good disk only, if the machine boot up, try and clone the harddisk and back up your data, then put in the new disk, the raid should rebuild itself.

If that does not work, then put your good disk in an enclosure and try to backup your data that way, then start over.
0
 
LVL 9

Expert Comment

by:nattygreg
ID: 40360766
yes that would be the quickest way
0
 
LVL 21

Expert Comment

by:Larry Struckmeyer MVP
ID: 40360787
Dell will support any server for as long as you have it, regardless of where it came from or how long you have it.  What they won't do is supply parts for an out of warranty box.

Call them.  Have the express service code ready to give to them.
0
 

Author Comment

by:Albatross1953
ID: 40360807
The server doesn't see any hard drives, old or new. The message displays that all the old drives are gone, then it doesn't see any new drives when trying to install OS. I installed one new hard drive.
0
 
LVL 21

Expert Comment

by:Larry Struckmeyer MVP
ID: 40360810
Can't say what happened to the old drives, but for the new one with a new OS install you have to inject the Raid Controller drivers into the installation sequence.

this assumes that the RAID controller BIOS can see the drive.  There is a key stroke sequence displayed on boot that will let you access the controller's bios.
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40360814
Boot from your windows 2008 DVD

Then see if the install see the drives
0
 

Author Comment

by:Albatross1953
ID: 40360824
Correction: The hard drive that was in port 01 failed & had a flashing orange light. It is still visible in both slots but is seen as offline. It triggers the RAID configuration when it is in slot 00. The drive that was in slot 00 & was still running when the server was shut down is no longer visible in either slot. The new hard drive is also not visible in either slot.
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40360830
Use the raid configuration bios and reconfigure your raid.

All data will be lost

The reinstall the server.

Again if you can get the data copied off on another computer I would do that first.

Raid 1 is not the best raid level to use

I would look into using raid 5

I understand you have two drives   Raid 1 is really only a mirror and when one fails sometimes you can access the data

But you need to get at it before powering off the system

Again copy the data if you can then rebuild your raid config and then you can install the OS
0
 
LVL 21

Expert Comment

by:Larry Struckmeyer MVP
ID: 40360848
Raid 1 is not the best raid level to use

A RAID controller, as opposed to software raid or onboard mobo raid, does not really care what type of raid is used.  RAID1, or mirror, is actually very safe and quite resilient.  It has the advantage of being able to read from the drive where the heads are closest.  The advantage of RAID5 or 6 is being able to use many drives to build the SIZE of the volume.  But in all cases except RAID6, if two drives fail at the same time, or close to each other, you will experience a lose of the volume.  A hot spare is always a good idea.

I suspect you did lose both drives in close sequence, but you could tell by putting then in a dock to see if you can access the data.  And there is a very reliable program called Get Data Back that will help you retrieve your data.

No version of RAID is a substitute for backup.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 40360865
I think there has been too much activity to hope to get this back online now.  You SHOULD have simply imported the foreign configuration in the beginning, and you'd be at home watching Star Trek or Gilmore Girls now.

If you want some more help, explain CONCISELY and PRECISELY what has happened since the beginning, and I'll let you know if you have any options, although glancing through this thread, I wouldn't hold my breath.
0
 
LVL 87

Expert Comment

by:rindi
ID: 40360945
Were you using the controller's RAID functions, or Windows builtin software RAID?

I ask because you say "Diskmanagement only showed one disk". If you were using your RAID controller, diskmanagement would naturally only see one disk, the controller takes care of RAID and presents the disks as an array to the OS, and array appears as a single disk. Diskmanager can't be used in this situation to check the state of your RAID array, for that you need to install the RAID controller's utility and consult that.

I suspect you tried to "fix" something that was working fine, and in the course of action your "fix" actually broke it.
0
 

Author Comment

by:Albatross1953
ID: 40361091
This was a used server that was installed in a business a few months ago. I watched the guy install it. He is no longer available. He did not set up RAID, so it must be using what was already in the BIOS because the disks are mirrored. I saw an error about physical disk total.  I looked in disk management & saw only one disk. There was an orange light on disk 01. I pulled it & the system kept running. Then I shut down the server & pulled disk 00. I put both disks back in their original slots but it wouldn't boot up.  I've swapped slots & tried booting with both disks & also tried booting to individual disks in either slot. It always says there is a foreign configuration on the adapter but continues the boot process. I noticed that it gives a default IP address instead of the one I believe is installed, but that could be the other port. If I put disk 01 in slot 00 , the RAID sees it & responds. Any other disk, old or new, in either slot does not get a RAID response. It always ends with "PXE-E61: Media test failure, check cable
                                 PXE-M0F: Exiting Broadcom PXE ROM."
The cable inside is plugged into SAS 0. There is no connector on SAS 1.
I connected the disks to a PC & ran CHKDSK. It made some corrections to one disk. Both disks are readable when connected with an external harness to a PC. I can get the data, but I don't have the activation key for the OS if I reinstall. I tried booting to the installation disk with a new disk installed, but it says there are no disks to install the OS on.
0
 
LVL 87

Expert Comment

by:rindi
ID: 40361120
The first thing to do when a disk reports an error is to verify your backups are good. If no backups were made up to then, It would have been what you'd have need to do.

As I mentioned above, Disk management will only show you one disk in a RAID controller's RAID array, so that is not how you would check the state of the array. You need the manufacturer utility for that, or use the RAID controller's ctrl + somekey to get into the controller's BIOS utility to check the state of it.

When a disk is bad and the backups are fine, wait until the new disk has arrived, then replace it while the server is running with the new disk. If everything is fine it should start rebuilding. That again should be visible through the controller's utility. If it doesn't automatically rebuild,you sometimes have to assign the new disk as a hot-spare.

I haven't seen any new disks fail so fast in a server. Are you sure you got enterprise class disks that are certified for that server? The safest way is to directly order them from the manufacturer (Dell) particularly for that server. Desktop class disks aren't suited for Servers and RAID controllers, those are likely to fail very soon, even if they actually work fine on a desktop. So make sure you have the proper disks.

You should really have the product key somewhere. Check the invoices and documentation. If you can't find them, and the person who installed the OS can't tell you either, and if it isn't possible to recover the installation, You can try installing one of the disks to a PC as you did when you ran chkdsk,  but make sure you removed the other disks of that PC, then boot it with a UBCD for windows. It has a tool installed (SIW), which allows you to read out product keys:

http://ubcd4win.com

You will need an XP installation CD to create the boot CD.

When you install an OS on a Dell Server you should use the OpenManage boot cd or DVD that came with it. Using that CD you prepare the server (RAID etc), and select the OS you want to install. This then supplies the drivers for the RAID controller, and when ready, the CD pops out and asks you to insert the OS installation DVD which you selected. It will then install without the need for you to supply the drivers manually.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 87

Expert Comment

by:rindi
ID: 40361122
Forgot to add, I assume PoweredgeTech will probably help you with the steps you need to take to try to get the current system running again. I don't know the exact steps you have to take with your RAID controller.
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40361129
I have a Dell PowerEdge 1950 here that I use for testing.

What is the model of your raid controller?


If you have a Perc 5 controller try hitting CTRL R at power up time

If you have Perc 5 controller the CTRL R will put you into the raid controller setup.
I can give you some info if I have the model number.
0
 

Author Comment

by:Albatross1953
ID: 40361165
Controller is Perc 6/i; It says "no configuration present" when I use a single new hard drive. The old drive is copying data for back up right now.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 40361244
Boot up with only disk 00 in slot 00 ... does it boot the OS ok?
0
 

Author Comment

by:Albatross1953
ID: 40361521
No. It doesn't boot the OS from either slot with either disk.
0
 

Author Comment

by:Albatross1953
ID: 40361528
With both disks installed, it finds 1 virtual disk & 1 disk offline.
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40361529
If you have a raid controller it will not see the drives or boot up the drives unless the raid is configured.

As I mentioned before what type of raid controller card do you have?

Perc 5?

You need to config the raid before you can start the OS
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 40361549
Slow down.  When you insert only disk 00 in slot 00, WHAT do you see in the CTRL-R utility on both the VD and PD MGMT screens?
0
 

Author Comment

by:Albatross1953
ID: 40361682
Controller is Perc 6/i. VD mgmt shows no configuration present. PD mgmt shows the 1 disk in slot 00 in Foreign state. With both disks installed, VD mgmt shows Virtual Disk 0 at RAID level 1 but offline. It shows 1 physical disk with no space on it. PD mgmt shows  disk 0 Foreign & disk 1 Offline.
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40361685
0
 
LVL 32

Accepted Solution

by:
PowerEdgeTech earned 500 total points
ID: 40361691
If disk 0 shows as Foreign, then with ONLY disk 0 in slot 0, boot to CTRL-R, VD MGMT, highlight controller, F2, Foreign, Import.

Does the OS boot?  If not, what happens?
0
 

Author Comment

by:Albatross1953
ID: 40361709
With disk 0 in slot 0 VD MGMT shows No Configuration Present. PD MGMT shows the disk but says it's foreign. There was an option before going into the mgmt console to import the foreign profile though.
0
 

Author Comment

by:Albatross1953
ID: 40361716
I imported the profile in the boot process & the disk showed up ini VD MGMT. I rebooted & it booted up!! Now what do I do with the other disk?
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40361721
Are both disk showing now?

Is the raid configuration correct?

If so it should start mirroring which will take a long time. But you can continue to run the os now
0
 
LVL 32

Assisted Solution

by:PowerEdgeTech
PowerEdgeTech earned 500 total points
ID: 40361728
The other disk can be inserted HOT (don't power down), and use OMSA to CLEAR the foreign configuration, then assign it as a hot-spare to start it rebuilding.

Do you have OMSA installed?

Since the disk had already failed, you may want to simply replace it. You could run diagnostics on it to verify its health status before attempting to rebuild.
If you don't already have a backup image, get one now.
0
 
LVL 87

Expert Comment

by:rindi
ID: 40361858
And as I mentioned earlier, make sure your disks are enterprise class disks. If they aren't, don't rebuild the array. Rather wait until you get enterprise class disks (for both), and either just create an array with the new disks, then restore from your backup, or insert one of the new disks first to rebuild the array to, and when that is done replace the disk that you are booting from now.
0
 

Author Comment

by:Albatross1953
ID: 40362031
I don't have OMA. I inserted disk 01 & it lit up solid green. How long should I wait before powering down? I have to take it back to the business site.
0
 
LVL 32

Assisted Solution

by:PowerEdgeTech
PowerEdgeTech earned 500 total points
ID: 40362100
Disk 01 is foreign, and you can't do anything with it until you clear it.

Install OMSA:
http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=V1JDD&fileId=3365593125&osCode=WS8R2&productCode=poweredge-1950&languageCode=EN&categoryId=SM

Download and run to extract files, then run C:\Openmanage\windows\setup.exe.  Choose Custom and make sure that Storage Management is installed.  Add yourservernameorip:1311 to IE's Intranet zone.  

To clear the foreign config associated with disk 01, open OMSA, Storage, PERC, Information/Configuration (link at top of page), Foreign/Clear from the dropdown menu of Available Tasks for the controller.  

Then to start the rebuild on disk 01, go to Storage, PERC, Virtual Disks, and assign a hot-spare, choosing disk 01 as the hot-spare, then the rebuild should start.

If the disk is bad, you aren't doing the business any favors, AND it could fail the rebuild anyway.  It is possible that the disk failed for some reason other than being faulty.  The firmware should be updated as well - BIOS and ESM first, then the PERC driver/firmware and HDD firmware to reduce the likelihood of it happening again.  And as noted, if using non-enterprise disks (like the WD Blue, etc.), they will probably experience a number of failures or other issues.
0
 

Author Closing Comment

by:Albatross1953
ID: 40367461
I had to import the 2nd drive during the boot process also. It sounds like OMSA is the way to avoid that. Thanks!
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 40368563
If you have it resolved to your satisfaction, then I'm glad, BUT ...

1. You should have inserted disk 01 "HOT" (while the system is up and running) - NEVER power down a server to introduce/replace a hot-swappable drive to an array.  Powering down should only happen when your drives are cabled inside the system (even then it is optional), or when you are moving an entire healthy array to a new controller.

2. You should have CLEARED the foreign configuration on disk 01, NOT import.  Importing likely caused data corruption, although how much is impossible to determine.  Had you inserted the drive "hot", you would not have had to deal with it - could have simply cleared it from OMSA, rebuild the drive, and be done with it - with data loss only from all the shuffling done early on.

Take care.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Know what services you can and cannot, should and should not combine on your server.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now