Lenovo u430p USB 2.0 not working

I have a Lenovo u430p laptop running windows 7 and the 2 USB 2.0 ports are not working.  they will not recognize a flash drive or my iphone (all i have plugged in so far).  Is there a driver i am missing?  I checked device manager and there are no yellow exclamation points on anything.  I also tried uninstalling the USBs and rebooting and still no yellow exclamation marks.  The USB 3.0 is working fine.

thanks in advance.
szadrogaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darrell PorterEnterprise Business Process ArchitectCommented:
Are the ports enabled in BIOS?  The USB 2.0 ports can be enabled or disabled separately.
Have the ports ever worked for you in the past?
0
rindiCommented:
Try using a bootable USB stick and boot the PC from that (from the USB2 ports). If it won't boot (and if the USB 2 ports are enabled in your BIOS), then the ports are bad. If it boots, they are fine.

Should secure boot be enabled on the notebook, make sure to disable it during the process. Xou can use unetbootin to create such a stick, and select one of the linux distro's it offers to download directly. Puppy Linux is a good example, as it is small to download and fast:

http://portableapps.com/apps/utilities/unetbootin-portable
0
szadrogaAuthor Commented:
i assume bad ports means bad hardware.  i am going to check BIOS now.  i didnt test these USB2 ports before upgrading to a SSD.  laptop had a HDD and basically right out of the box i put in the SSD
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

szadrogaAuthor Commented:
only thing i could find in regards to USB in BIOS had to do with USB power always on....i set that to enabled but still no luck.
0
Darrell PorterEnterprise Business Process ArchitectCommented:
Open Device Manager (press Windows key+R and the Run window will appear. Type devmgmt.msc.  If the UAC prompt appears, click Yes
 
Navigate to Universal Serial Bus Controllers and uninstall ALL USB Root Hubs.
When done, right click on Universal Serial Bus Controllers and click Scan For Hardware Changes (this should re-initialize the USB ports) and test the USB ports.
0
noxchoGlobal Support CoordinatorCommented:
Download a free version of Reskue Kit: http://www.paragon-software.com/home/rk-free/
Create a bootable CD with it and boot the laptop from it. Before you boot connect to "bad" port a usb stick with some data on it.
In Reskue Kit menu start File Transfer Wizard and find your stick. Is it there? This way you make it sure if the hardware is bad or the culprit is Windows.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
szadrogaAuthor Commented:
I uninstalled ALL the Universal Serial Bus Controllers and did the scan for hardware changes and the Windows reinstalled all the drivers.  tried the  USB2 ports but no luck.  the USB3 is working fine.

beginning to think its hardware...
0
rindiCommented:
As I mentioned earlier, boot from a USB stick, or try noxcho's test, it is a similar option.
0
Darrell PorterEnterprise Business Process ArchitectCommented:
Yes, using your USB 3.0 port, build a bootable flash drive then shut the computer off (power it down, remove the battery, unplug it from power, then attempt to turn it on to remove any capacitive charge.  Unplug the newly created flash drive from the USB 3.0 port and connect it to one of the USB 2.0 ports.

Reinstall the battery, connect the computer to power and turn it on.  Press the appropriate key to force it to boot from the USB drive.  If it boots to Windows somehow, try again.

It may also help to reset the BIOS to factory defaults and try again.
0
Danny ChildIT ManagerCommented:
may also want to update the chipset driver

It's available here (plus the BIOS):
http://support.lenovo.com/us/en/products/laptops-and-netbooks/ideapad-u-series-laptops/ideapad-u430-touch-notebook/?tabName=Downloads

If you fitted the SSD, do you still have the original HDD available and working?  Does it show the fault too?
0
nobusCommented:
i usually use a Knoppix live cd to test if the usb is working  http://distrowatch.com/table.php?distribution=knoppix      

how did this happen?  did you install a fresh OS?
0
szadrogaAuthor Commented:
yes, I put a brand new 500gb SSD in the laptop with a fresh install of Windows 7 PRO.  i never tested them with the HDD the laptop came with.  i am going to put that one back in and test.
0
nobusCommented:
did you install ALL the drivers ? sinc e they have only windows 8 drivers -  look for chipset driver
did the usb 2 ports work before?
can you post a screenshot of the usb devices ? enlarged  (click on + sign)
0
web_trackerComputer Service TechnicianCommented:
I agree if you did not install the most recent chipset drivers for this laptop after the OS reinstall, the proper usb drivers may not be installed.  Go to the manufacturers website and download and install all the most recent drivers for your laptop. Eventhough you may not get the typical exclamation mark saying that the incorrect drivers are installed, the drivers installed may be generic drivers that windows found for your devices, which may not be the optimal drivers for your system. It is therefore always best practice to go to the manufacturer to install the proper drivers for your system. If the ports did not work properly after you reinstalled the original drive from the system, then it could be bad usb ports. If the usb ports work fine after reinstalling the old drive you know that the usb ports are working fine and it is most likely a driver issue that is causing the ports not to function properly.
0
szadrogaAuthor Commented:
attached is a screenshot of the USBs.  I went to Lenovo's website for the chipset driver and installed it when i first put the new drive in.
usb.png
0
nobusCommented:
i see the usb 3 installed ok  - as you know, but no USB2.0

did you install all the drivers and software from the lenovo sit, especially the intel management utility?

do you have any unknown devices in device manager?
0
szadrogaAuthor Commented:
i will try reinstalling the intel management utility and see what happens.  i will get the driver from the lenovo site.  there are no unknown devices in device manager
0
noxchoGlobal Support CoordinatorCommented:
Just try the method I suggested. It will let you know if the USB ports are working at all.
If they are working then simply will know that correct driver is needed.
0
nobusCommented:
it is strange that there are no usb devices installed, nor unknown devices...
but i noticed there are many pages of drivers and software - did you check them all ?
there 's intel rapid storage; intel smart connect and card reader driver on page 4
0
szadrogaAuthor Commented:
i am going to try the drivers now.  i have windows 7 pro installed so i should be able to at least apply that filter.
0
szadrogaAuthor Commented:
no luck with the drivers.  going to test the USBs using noxcho's suggestion
0
szadrogaAuthor Commented:
noxcho - i need to download the the Windows Automated Install Kit in order to build the bootable CD?
0
szadrogaAuthor Commented:
definitely appears to be hardware.  put the old HDD that came with the laptop back in and booted the machine.  usb2 still not working but usb3 works fine.
0
nobusCommented:
did you image the old HD to the new one?  then it can be IN the image
test with knoppix live cd if the usb ports work ; a simple download, and create the bootable cd from it :
http://distrowatch.com/table.php?distribution=knoppix      
no need to install anything
0
noxchoGlobal Support CoordinatorCommented:
noxcho - i need to download the the Windows Automated Install Kit in order to build the bootable CD?
Not necessarily. The second option there is to build a Linux based Boot CD from a rescue Kit package you download. It must be enough for you.
0
szadrogaAuthor Commented:
laptop is being replaced with a new one.
0
szadrogaAuthor Commented:
I would like to award points for everyone's help, but not sure i can do this without a solution being in the answer....suggestions?
0
nobusCommented:
select multipla answers  - then distribute to helpful posts
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.