Problems connecting Windows XP SP3 and Windows 7

Hi Folks,

Let me begin by saying that I've read many online tutorials and haven't found a solution that worked.

Here's the setup:
Machine 1: Windows XP SP3 Professional
Machine 2: Windows 7 Ultimate
Both machines have a wired connection to the same router.
Printer is physically connected to machine 1.

Both have the same workgroup name (not using Homegroup on machine 2). Can access Windows XP shared folders on the Windows 7 machine, but can't access the Windows 7 shared folders (Access denied). Nor can I connect the printer to the Windows 7 machine (get error 0x000000d when running the wizard).
LVL 28
MacroShadowAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
n2fcConnect With a Mentor Commented:
1) Make sure the network on the Windows 7 machine is listed as PRIVATE (Work or Home, and not PUBLIC)

2) Make sure you TURN ON File & Printer sharing in Advance Sharing Settings

3) Turn OFF Password Protected Sharing and ENABLE 40-56 bit encryption

4) Set permissions on the shared folders on WIN7 to include R/W access for EVERYONE

As to Printer sharing:
    Is your WIN 7 box 64 bit? And your XP box 32 bit?
Perhaps a driver issue....
1) Add the printer to be shared as a LOCAL (attached) printer FIRST (LPT1)... Then,
2) Use the "NET USE" command to redirect to the network printer:
(In a command prompt)
Use the net.exe command to establish a persistent connection. To do this, use the following syntax at a command prompt
net use lpt1 \\printserver\sharename /persistent:yes
0
 
arnoldCommented:
Advanced sharing, change the encryption requirement from 128 bit.

The other deals with using group policy editor adjusting access to shares.

Do both systems have the same username/passwords for the accounts?

Are you trying to share with everyone's?

Check sharing/security settings on the shared folder
0
 
MacroShadowAuthor Commented:
<Advanced sharing, change the encryption requirement from 128 bit.>
How do I do that and on which machine (7 or Xp)?

<The other deals with using group policy editor adjusting access to shares.>
I don't understand, can you please explain.

<Do both systems have the same username/passwords for the accounts?>
No, the Windows 7 doesn't have a password.

<Are you trying to share with everyone's?>
Yes.

<Check sharing/security settings on the shared folder>
Can you please walk me through?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
QlemoDeveloperCommented:
No, the Windows 7 doesn't have a password.
That's it! You MUST provide a password with the account, and if the user is the same, the password should be the same. If the user is different, a user/password prompt should appear.
0
 
MacroShadowAuthor Commented:
I created the same password on the Windows 7 machine but I still can't access the Windows 7 nor can I connect the printer.
0
 
MacroShadowAuthor Commented:
<1) Make sure the network on the Windows 7 machine is listed as PRIVATE (Work or Home, and not PUBLIC)>
It is already.

<2) Make sure you TURN ON File & Printer sharing in Advance Sharing Settings>
It is already.

<3) Turn OFF Password Protected Sharing and ENABLE 40-56 bit encryption>
Password Protected Sharing is off already.
Will enable 40-56 bit encryption when I get back to work.

<4) Set permissions on the shared folders on WIN7 to include R/W access for EVERYONE>
That is the current setting. Do I have to add users from the XP Machine?

<Is your WIN 7 box 64 bit? And your XP box 32 bit?>
No both are 32 bit. I installed the printer locally, So I don't think it's a driver issue.

<1) Add the printer to be shared as a LOCAL (attached) printer FIRST (LPT1)... Then,>
This may be the missing step. I tried redirecting the network printer without this step. Will try when I get back to work.
0
 
MacroShadowAuthor Commented:
Ok, vacation's over, back to work...

@n2fc

Following your advice to "enable 40-56 bit encryption" the network now works. Thanks.

I added the printer as a local printer then used the "NET USE" command to redirect to the network printer, as you suggested. The command completed successfully. Yet nothing will print, the status always is error-printing.

Adding the remote printer as a network printer fails with error 0x0000000d.

Eagerly awaiting your response.
0
 
MacroShadowConnect With a Mentor Author Commented:
Here's the update:

Shortened the printer's share name so it won't be longer than 8 chars.
Created a local printer using local port.
Used the network share as the port (\\MyShare).
Installed the proper driver.

Viola! It works!
0
 
MacroShadowAuthor Commented:
Half the question was answered by the expert, the second half I solved myself as explained in my accepted comment .
0
All Courses

From novice to tech pro — start learning today.