Solved

How to configure server 2008 to not lookup email adres locally but to the hosted exchange on the Internet

Posted on 2014-10-05
7
106 Views
Last Modified: 2014-11-16
Hi all,

I have a 2008 server with Exchange and 10 mailboxes. The mailboxes are moved to Hosted Exchange so I need to reconfigure Outlook. Hosted Exchange works with autodiscover, but Outlook defaults to de local server and not to Internet, so it configures the mailadres which I do now want to use (local). I do not yet want to remove the local adresses because off fallback and backup.

How do I configure server 2008 so that the Outlook client checks the autodiscover through the Internet?
0
Comment
Question by:Agrippa
7 Comments
 
LVL 23

Assisted Solution

by:Suliman Abu Kharroub
Suliman Abu Kharroub earned 167 total points
ID: 40362642
Configure the internal DNS records to be resolved externally. for example, if mail.company.com points to 192.168.1.1 internally change it to 1.1.1.1 (Public exchange CAS ip).
0
 

Author Comment

by:Agrippa
ID: 40362647
Hi Suliman,

that is not the solution I seek, time and again I would need to bother users while I am making changes when adding a new hosted exchange user. Also I work through Teamviewer remote, so I will lose connection. I need to disable the local seek for mailadresses.
0
 
LVL 31

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 167 total points
ID: 40362782
Hey Elisys. This shouldn't require bothering any users. You would make this change once on your internal DNS server. If anything, you just need to make sure that users flush their DNS cache (or reboot) to pick up the new DNS entries.

As Suliman mentioned, you need to modify DNS records on your internal DNS server to point to their cloud provider.

Assuming you have Office 365 you would do something like this.

Create a CNAME record in your internal DNS that resolves "autodiscover" to "autodiscover.outlook.com"
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 166 total points
ID: 40363297
If you remove Exchange from the server, then local Autodiscover will not take place.
You would only need additional DNS records if the internal WINDOWS domain name is the same as the external domain name (so domain.com instead of something like domain.local).

You can make as many internal DNS record changes as you like - all the time that Exchange is installed on the server they aren't going to work, because the client will ALWAYS look at the local domain first.

If you don't want to remove the Exchange server then you will have to reconfigure it.

get-clientaccessserver | set-clientaccessserver -AutodiscoverServiceInternalURI https://host.example.com/Autodiscover/Autodiscover.xml

where host.example.com is the name of the host the hosted Exchange company has told you to use for Autodiscover.

Simon.
0
 
LVL 13

Expert Comment

by:vishal_breed
ID: 40363431
This is a shared hosting and it is better to have emails going through Local Exchange servers than connecting local server over internet (you are loosing MS Exchange advantage be seeking solution otherway).

Following articles are talking about Exchange 2007, please let us know if other Exchange Version you are using.

http://www.msexchange.org/articles-tutorials/exchange-server-2007/migration-deployment/shared-hosting-exchange-2007-part1.html
http://www.msexchange.org/articles_tutorials/exchange-server-2007/migration-deployment/shared-hosting-exchange-2007-part2.html
http://www.msexchange.org/articles_tutorials/exchange-server-2007/migration-deployment/shared-hosting-exchange-2007-part3.html
0
 

Accepted Solution

by:
Agrippa earned 0 total points
ID: 40434649
Hi all,

thankx for every reactie. I also guess that changing DNS might actually work, but I cannot do that since I am not on site, I am logged on remote. Also the suggestion of removing Exchange would work, but I want to keep a fallback situation, so therefore this would not be an option for me. What I did was changing the internal email adres so I does not match the email adres from the hosted exchange. So once I give in the right mail address in the Outlook profile config it checks if it exists internally, if not it will go by autodiscover to the Internet.

So: just change the internal address to f.i.: name-old@company.com
0
 

Author Closing Comment

by:Agrippa
ID: 40445441
Own solution is the easiest solution
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Updating Email Addresses in exchange 2013 2 23
Outlook 2016 backdated email without sending 6 30
exchange, email gateway 2 31
outloo, calendar 11 18
Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question