Group Policy schedule task not appearing on Windows 8.1 machines - error code 0x80070057 "The parameter is incorrect"

I need to set up a GPO that wakes up our desktops from sleep for off-hours virus scans.  I am using a scheduled task to run the virusscan with "wake up the computer to run the task"  selected.  This is currently being done with WOL but some combinations of NICs and Windows 8.1 don't respond.  The new GPO works by installing a scheduled task on our Windows 7-64 boxes, but fails on Win 8.1.  (I am just using ping for now for testing).  

I enabled logging and see these errors:

2014-10-03 16:33:15.141 [pid=0x398,tid=0xac4] Properties handled. [ hr = 0x80070057 "The parameter is incorrect." ]
2014-10-03 16:33:15.141 [pid=0x398,tid=0xac4] Error suppressed. [ hr = 0x80070057 "The parameter is incorrect." ]

The task is being set up on one of the DCs running Server 2012.  It occurred to me that the Task Version may be incorrect but I don't understand the logic behind setting it ("Configure for").

First, I don't see any place in the GP/Scheduled task interface to even control this option.  How do I select it?

Second, the task arrives at the W7 desktops configured for for "Server 2003, WinXP, Win2000".  The W7 boxes work, but is this correct for Win8.1? Possibly the reason for the failure?

If I make a local scheduled task on the Server 2012 box it defaults to "Server 2008, Win Vista".  Why is this different?

Please explain to me how this "configured for" is used, and how to modify it in a sched task GPO.  

The goal here is to get the Win8.1 boxes to accept the policy and install the task. I am just surmising that the task version is related so please redirect me if I'm on the wrong road.

Thanks.
dvanakenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Hi.

You setup the task using group policy preferences like shown here:
Screenshot?

Then it should work. Please try to schedule the start of notepad. Does that work?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dvanakenAuthor Commented:
Thank you for the response.

Well don't I feel stupid :-).  I must have just missed those other options to create a task.  However, I only had a few minutes to try it and used the default "Configure for" that says Server 2008/Vista.  The W7 box worked but the task is still not showing in the W8.1 box.  I will test further tomorrow - should I select "configure for Windows 7"?
0
McKnifeCommented:
Yes, you should.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

dvanakenAuthor Commented:
Will try again tomorrow. That's confusing because it already works on W7 so on the surface there seems to be no benefit to selecting that option for W8.1 .  But, Microsoft  options have not always made sense through history. ... I will post back.  One thing. On the W7 box the task clearly ran since the box woke up out of sleep but notepad was not running. Is this to be expected?
0
McKnifeCommented:
Might run invisible. Depends on what account you configure for the task. If not the same as the logged on user, that's expected behavior.
0
dvanakenAuthor Commented:
That's  probably it. W7 logged in as me, task set to run as domain admin...
0
dvanakenAuthor Commented:
Just changing the "configure for:" to Windows 7 did not do it.  But I finally got it working - here are the things I did differently:  

Run as User : SYSTEM, rather than domain\administrator
Configure for: Windows 7
don't check "run with highest privileges"

Then rather than logging in to the W8.1 box as domain\admin, I logged in with my own credentials.   Somewhere along the way these changes did the trick.

Now I just have to figure out how to run the SEP scan from the command line and with appropriate permissions.

Thanks for the help!
0
dvanakenAuthor Commented:
Ok, one more twitch here.  While I was experimenting with Win8.1, all the W7 boxes were getting the test scheduled tasks installed.  I did not see that and so I deleted the scheduled tasks from the GPO.  Now those boxes are stuck with the test tasks.  if I re-create a task for "delete" and name it the same name, will GP eventually delete them?
0
McKnifeCommented:
Yes it will.
0
dvanakenAuthor Commented:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.