Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Problem Configuring Email Alerts with File Server Resource Manager 2012

Posted on 2014-10-06
8
Medium Priority
?
3,494 Views
Last Modified: 2015-06-03
I am trying to configure the File Resource Manager to send me email notifications when quotas are hit and so forth.  I have configured the Email Notifications tab as follows:

SMTP Server Name: exchange.ad.mydomain.com
Default Administrator Recipient: administrator@mydomain.com
Default "From" email address: fileserver@mydomain.com

When I try to send the test email I get the following error:

"Failed to send the test email due to the following error: Cannot send the email due to an error.  Check the application event log for more information."

Upon checking the event log, I see the following:

"The SMTP server requires a secure connection or the client was not authenticated.  The server response was 5.7.1. Client was not authenticated."

Upon my research, the server needs the Send-As privileges on the user account.  With that said, I created a user account "svc_FSRM" and ran the following powershell command:

Add-ADPermission -Identity “svc_FSRM” –user “ad.mydomain.com\fileserver$” -ExtendedRights “Send-as”

When I go into the Exchange ECP and access the svc_FSRM user account, under mail delegation section "fileserver" is listed under the "Send As" section.

Unfortunately, when I try to send the test email again from File Server Resource Manager....I am still given the same error as before.  For the life of me, I cannot seem to figure out why the test message will not come through.  Any thoughts?
0
Comment
Question by:csimmons1324
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 9

Expert Comment

by:RantCan
ID: 40364284
Allow anonymous authentication on the receive connector.
0
 
LVL 25

Expert Comment

by:Mohammed Khawaja
ID: 40364294
In order for this to work, the logged on user must be svc_farm.  Best way for things such as this (as well as any future monitoring/alerting), what you should do is to use an IIS server for mail relay and lock it down by IP address.  Create a remote domain pointing to your Exchange server and forward all messages to your CAS server.  Just ensure to configure CAS server to accept messages from the IIS server.  This way, you are not making changes to Exchange and you can control very easily as to what machines can relay messages.
0
 

Author Comment

by:csimmons1324
ID: 40364597
I forgot to mention that I am using Server 2012 R2 and Exchange 2013 which are both run in-house.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 25

Expert Comment

by:Mohammed Khawaja
ID: 40364605
I think the issue is that you are specifying the computer name as the username which will not work.  Try it with a username.
0
 

Author Comment

by:csimmons1324
ID: 40364611
Mohammed,

From what I have read, FSRM attempts to send the email using the computer account.  For this reason, the computer account needs to be granted "Send-As" permissions on the mailbox that is used in the "FROM" email address.
0
 
LVL 25

Expert Comment

by:Mohammed Khawaja
ID: 40364705
I have a suggestion and that is to create a new/separate SMTP connection which will be used by FSRM only.  To do this, you could run the powershell listed below:

new-receiveconnector -FSRMmail -usage custome -bindings y.y.y.y:25 -remoteIPranges x.x.x.x -authmechanism basicauth -permissiongroup anonymous

y.y.y.y would be the IP of the SMTP server (your Exchange server) and x.x.x.x would be the IP of the FSRM.  Later on you could add more IPs to the allowed relay list.
0
 

Accepted Solution

by:
csimmons1324 earned 0 total points
ID: 40384586
I had to enable "Exchange Users" on the Send Connector to resolve the problem.
0
 

Author Closing Comment

by:csimmons1324
ID: 40394082
I discovered the solution on my own.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question