• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 367
  • Last Modified:

How Can I change the Default Desktop Resolution for Remote Desktop Users?

I want to be able to set the default desktop resolution the remote desktop services users get deployed.

This is for Server 2008 R2 Standard.

I Looked everywhere, time for the experts

Thanks
0
ParisBP
Asked:
ParisBP
  • 7
  • 6
1 Solution
 
pcelbaCommented:
1. Click the Remote Desktop icon on your PC - RDC dialog appears
2. Click the Options button - a set of tabs appears
3. Click on the Display tab and select the resolution
4. Connect to the remote computer - the remote screen resolution will be used next time
0
 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
How are you deploying access to users?  Copy of .rdp files to the users desktops or copying the file to a share?  If it is a RDP file, create your connection, edit it and then change resolution and re-save it.  You should publish your apps as remote apps and this way, applications will be seamless.
0
 
ParisBPAuthor Commented:
I am looking at how to set it from the server end.
so all users have the same resolution.
without editing, several,  .rdp files
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
I would recommend publishing applications by using RD Web.
0
 
ParisBPAuthor Commented:
I can force the remote users to a 1024 x 768 resolution this way?
0
 
ParisBPAuthor Commented:
Is there a setting in Remote Desktop Services that sets the same resolution for all?
0
 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
When you are running remote applications, applications will launch just as if you are running it locally on your computer (i.e. Excel) and you do not see the desktop of the RD server.  If you must publish remote desktop then publishing it as a remote app, you could force what resolution it should run as.  Refer to links below for more information:

http://blogs.msdn.com/b/rds/archive/2009/06/12/introducing-remoteapp-user-assignment.aspx
http://letstalktechtalk.blogspot.ca/2012/10/70-646-remote-desktop-services-in.html
http://technet.microsoft.com/en-us/library/cc730673(v=ws.10).aspx
0
 
ParisBPAuthor Commented:
Running as an app isn't going to work in my environment.
folks need their desktops.
0
 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
You could put a link on web page which users can launch which may contain something like this:

mstsc /v:rdpserver /h:768 /w:1024

You said your users have their applications on their desktop on the terminal server?  If that is the case, why don't you implement VDI?
0
 
ParisBPAuthor Commented:
I am really chasing down ones users desktop resolution on TS.

VDI is overkill in my environment. good thought though.

Ok.. explain how to implement
mstsc /v:rdpserver /h:768 /w:1024 via link?

Do I put that in the .rdp?
thanks
0
 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Create an RDP with all the settings you want.  Save it on your intranet/web server.  The link will point to the RDP file (i.e. http://intranet.mydomain.local/TSApp.rdp
0
 
ParisBPAuthor Commented:
How does this play into this?
mstsc /v:rdpserver /h:768 /w:1024
0
 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
The command you have posted tells the client the server name is rdpserver and to use resolution of 1024x768.  You could simply run mstsc, configure the parameters and save it as an RDP file.  The content of the RDP file will be as per below and you can see the parameters in it:

screen mode id:i:1
use multimon:i:0
desktopwidth:i:1024
desktopheight:i:768
session bpp:i:32
winposstr:s:0,1,147,42,1187,849
compression:i:1
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:7
networkautodetect:i:1
bandwidthautodetect:i:1
displayconnectionbar:i:1
enableworkspacereconnect:i:0
disable wallpaper:i:0
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:rdpserver
audiomode:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:0
use redirection server name:i:0
rdgiskdcproxy:i:0
kdcproxyname:s:
drivestoredirect:s:
0
 
ParisBPAuthor Commented:
Thank You
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now