Citrix Web Interface 5.4 - Idle Timer

Dear Experts - My question is one of convenience for my user community.  .  .

Our environment uses a Citrix 6.5 Farm using WI 5.4.  The user launches (say) Microsoft Outlook and our ERP application - each runs as expected.  

Our "problem" arises after 20 minutes - if the end-user returns to the WI page to open another application (s)he must log back into the web interface.  Their active applications continue to function.

Our session timeout and idle timer configuration works as expected for the established sessions.

What I would like to do is extend the WI timeout past 20 minutes.  

1.  In the Web Interface Management console - the Web Session - Session timeout is set to 1 hour
2. the webinterface.cfg timeout is also 60 minutes.

Any suggestions on how to adjust the Interface timeout so it coincides with the session timeout would be very much appreciated.  

Thank you in advance - Su
sgillilandAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sekar ChinnakannuStaff EngineerCommented:
Can you give a try to install this hotfix and check http://support.citrix.com/article/CTX130660 also try to modify config file too for steps http://support.citrix.com/article/CTX103672
0
sgillilandAuthor Commented:
Sekar -

Thank you for your suggestions - unfortunately neither applies to my environment, as I mentioned in my earlier post we are operating in a Citrix (XenApp) 6.5 and Web Interface 5.4 environment.  I did look at our webinterface config file - c:\inetpub\webroot\citrix\XenApp\webinterface.cfg file and the WebSessionTimeOut and TimeOut parameters are set to 60.

Our user sessions seem to comply with these parameters - it is just the need to re-signon at the WI to open an additional application that I am trying to extend and cannot seem to find that last parameter to do so.
0
Daniel BorgerSenior Citrix Engineer- CCEECommented:
Open the IIS Manager on the web server, and open the properties of the CitrixWebInterfaceAppPool. (or default if using that site)On the Performance tab change the value of the worker process time out to a value greater or equal to the value in web.config

end of this blog shows a screenshot.

http://danielruiz.org/tag/web-interface-5-4/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sgillilandAuthor Commented:
Thank you for the assist - I have made the change to equal the .config file and will circle back tomorrow. (I don't want to do the issreset in the middle of the day)
0
sgillilandAuthor Commented:
This was a grade A solution - it took into account the environment explained in the original post and addressed comments/advice around those parameters and most significantly - It worked like a Charm - Thank you for the assist.  Su
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.