[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

Emails failing to just a few recipients

We are getting emails rejected with "Delivery has failed to these recipients" or "Delivery is delayed to these recipients" messages from just a handful of customers, most emails get through no problems, I have performed the SMTP check with mxtoolbox and the results are below,

Connecting to xxx.xxx.xxx.xxx

220 remote.mydomain.com Microsoft ESMTP MAIL Service ready at Tue, 7 Oct 2014 20:41:30 +0100 [686 ms]
EHLO MXTB-PWS3.mxtoolbox.com
250-remote.mydomain.com Hello [64.20.xxx.xxx]
250-SIZE 10485760
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH
250-8BITMIME
250-BINARYMIME
250 CHUNKING [764 ms]
MAIL FROM: <supertool@mxtoolbox.com>
250 2.1.0 Sender OK [749 ms]
RCPT TO: <test@example.com>
550 5.7.1 Unable to relay [5756 ms]

MXTB-PWS3v2 9376ms


Now the problem is our A record is mail.mydomain.com so I have run the following command in Exchange managment shell,

set-sendconnector “Windows SBS Internet Send mydomain” –fqdn mail.mydomain.com

and also tried  changing the FQDN in the Exchange managment console GUI but nothing is changed? it remains as remote.mydomain.com ?

Any ideas? I'm sure I am just mssing somthing obvious ;)

(this is on SBS2008 with Exchange 2007)

Thanks all
0
Leigh2004
Asked:
Leigh2004
  • 2
  • 2
1 Solution
 
Alan HardistyCo-OwnerCommented:
As you have SBS - you need to use the Wizards in the SBS console to change things - don't change them manually.

You also don't need to change the Send Connector FQDN - but you do need to make sure your Reverse DNS record on your Public IP Address is set to remote.yourdomain.com and that you have an A record called remote for your domain that points to your Public IP address.

Then you might find fewer sending problems

Have a read of my article for other guidance:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/A_2427-Problems-sending-mail-to-one-or-more-external-domains.html

Alan
0
 
Leigh2004Author Commented:
Thanks Alan, I have run the Reverse DNS lookup from dnsgoodies and get the following result,

Server: 4.2.2.1
Address: 4.2.2.1#53

Non-authoritative answer:
xxx.xxx.xxx.xxx.in-addr.arpa name = no-dns-yet-assigned.vfast.co.uk.

Authoritative answers can be found from:


I guess thats the problem you describe in the first part of your guide, right?
0
 
Alan HardistyCo-OwnerCommented:
Yep - that means you don't have a proper Reverse DNS setup, so please setup your A record for remote.yourdomain.com first and then ask your ISP to configure Reverse DNS on that IP as remote.yourdomain.com and then once added, please test again and things should be happier.

If you want - ping a test email to testmail @ sohomail.co.uk and my Anti-Spam may well reject you - and tell you why!

Alan
0
 
Leigh2004Author Commented:
Thanks Alan, I had our ISP set the reverse DNS all is good now, and I spent so much time looking at the exchange server for no reason ;)
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now