Solved

Second IP address is not appearing as a binding choice in IIS 7.5

Posted on 2014-10-07
8
973 Views
Last Modified: 2014-10-08
Hi.  Currently, we have a test site up and running.  We are looking to add a second test site to our IIS 7.5 server.  I'm using these instructions:

https://www.youtube.com/watch?v=uhWZIlgiTk4

I have added another IP address to the ethernet adapter.  Everything seems to work, I can ping it from other servers, etc... but the ip address does not appear in IIS when I go edit the bindings.  It's not showing in the drop down.

I have tried restarting the service, restarting the server.   I also tried manually adding  it in, the site doesn't load.

One thing I noticed is if I do a netstat -a , it doesn't appear that ip is listening to anything.  so I added in this line: netsh http add iplisten xx.xxx.xx.xx (new ip), but it still didn't work, and it also took down the existing test site.  So, I deleted that iplisten line.

Any ideas?
0
Comment
Question by:paradigm_IS
  • 4
  • 3
8 Comments
 
LVL 28

Expert Comment

by:becraig
ID: 40367096
Can you provide an ipconfig /all for that server.

You can also just try resetting the TCP stack
netsh int ip reset c:\resetlog.txt


Also run:
appcmd list sites  

These details will help to identify the issue and find a solution.
0
 

Author Comment

by:paradigm_IS
ID: 40367244
the ip address exists when I do an ipconfig /all.

Tried resetting the tcp stack.  readded the ip's and rebooted.  Still doesn't show up in iis.

The results of the appcmd list sites command doesn't seem to help much:

SITE "Default Web Site" (id:1,bindings:http/xx.xxx.xx.12:80:testsite1.com,net.tcp/808:*,net.pipe/*,net.msmq/localhost,msmq.formatname/localhost,https/xx.xxx.xx.12:443:,state:Started)
SITE "testsite2" (id:2,bindings:http/xx.xxx.xx.13:80:testsite2.com,state:Started)
0
 
LVL 28

Expert Comment

by:becraig
ID: 40367256
Looks like this might be an IIS bug in the UI

See a previously answered question:
http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_25347559.html

Just go ahead and enter the address manually in IIS when adding the new binding.
0
 

Author Comment

by:paradigm_IS
ID: 40367260
Hmmm... I already tried that.  see above:  "I also tried manually adding  it in, the site doesn't load."

Does something in the host file need to be edited?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 28

Expert Comment

by:becraig
ID: 40367274
No host file changes need to be made to create a mapping to to an ip in IIS (unless the DNS name you are adding is not resolvable)

Try doing this from appcmd:
Set appcmd =C:\Windows\System32\inetsrv\appcmd.exeSet SiteName=Default Web SiteSet IP=192.168.0.1:80Set FQDN=www.contos.com

%appcmd% set site “% SiteName%” /+bindings.[protocol='http',bindingInformation='%IP%:%FQDN%']

Reprinted from:
http://blog.billbrockbank.net/2010/06/21/configuring-iis-7-site-binding-with-appcmd-exe/

It seems like something about your IIS might be hosed, but this command should help.


If your problem is that the site was created and manually bound to the IP and you are unable to call it using the hostname, then try running :
ping <host-header>

If that does not resolve, then you need a host file entry or DNS entry.
0
 
LVL 28

Accepted Solution

by:
becraig earned 500 total points
ID: 40367277
Also MS has a hotfix for this behavior not sure if it is applicable for your situation:
http://support2.microsoft.com/kb/2551090
0
 
LVL 24

Expert Comment

by:Mohammed Khawaja
ID: 40367312
You do not need a second IP if you are willing to use host headers.  What this means is that instead of IIS binding to an IP, it will bind to a FQDN name.  This way you could add multiple sites by using just one IP address.  Refer to technet article below:

http://technet.microsoft.com/en-us/library/cc753195(v=ws.10).aspx
0
 

Author Closing Comment

by:paradigm_IS
ID: 40368714
becraig.  That hotfix worked.  I also had to add the site to the host file with the new ip address.  After that, it was golden.

Thanks man.
0

Featured Post

Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

Join & Write a Comment

Lync server 2013 Backup Service Error ID 4049 – After File Share Migration
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now