OWA Error after SP3 upgrade - The custom error module does not recognize this error.

I upgrade Exchane 2007 to SP3 and it went without errors.
However on using OWA I get an error.

https://mailserver.domain.co.uk/owa/auth/owaauth.dll

The custom error module does not recognize this error.

This error appears regardless of a correct username/password combination.

OWAApppool show net 2.0.50727.
owaauth.dll version is 8.3.83.0

Any help appreciated

Thank you
MajicthiseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Did you install the latest rollup after installing the service pack?
If not, go and do that to begin with.

Simon.
0
MajicthiseAuthor Commented:
No, wanted to make sure everything worked before I went ahead and did anything else.
0
Simon Butler (Sembee)ConsultantCommented:
I would patch it to begin with. SP3 on its own is very old. Bring the server fully up to date.

Simon.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

MajicthiseAuthor Commented:
OK. Well we'll see how it goes...
0
MajicthiseAuthor Commented:
Problem has not gone away after Rollup 14.
0
MajicthiseAuthor Commented:
owaauth.dll version now 8.3.377.0
0
Simon Butler (Sembee)ConsultantCommented:
Have you seen this TechNet forum thread?
http://social.technet.microsoft.com/Forums/office/en-US/94c812b5-4bd5-41eb-8396-462e03295201/exchange-2007and-iis7?forum=exchangesvrclientslegacy

Don't want to go over old ground if you have.

Is there anything else on the server that could have changed the netframework configuration?

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MajicthiseAuthor Commented:
There's nothing thats changed other than the SP£ upgrade and rollup.

I saw that link but the instructions aren't clear.
I found the same problems as the OP.
Menu options suggested weren't listed etc.

However if I select basic settings for the web site the pysical path is correct
There is a button to test settings

Which throws an error

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.

C:\Program Files\Microsoft\Exchange Server\ClientAccess\OWA has read access for authenticated users, and full permissions for system and administrators

Checking the logs I get an error

The Module DLL C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll failed to load.  The data is the error.

About to follow steps i nthis article

http://social.technet.microsoft.com/Forums/exchange/en-US/686d1a90-a016-4a4c-ae2e-6725914a5d5a/the-module-dll-cprogram-filesmicrosoftexchange-serverv14clientaccessowaauthexppwdll-failed?forum=exchangesvrsecuremessaginglegacy
0
MajicthiseAuthor Commented:
Quote

In the particular case of owaauth.dll failing to load, you need to do the same thing with the permissions of the folder '%Program Files%\Microsoft\Exchange Server\ClientAccess\Owa\auth'.

Quote

That was the issue.
Once I'd correctly added the traverse folders/execute files permission it worked like normal.

Odd bcasue the permissions are inherited and so I had to explcitly set them.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.