CentOS 7 & VSFTPd

Hi All,

I recently setup a Cent OS 7 server on my local network.

I'm trying to enable FTP, but struggling.

I followed this guide and everything seemed to work.  However I can't telnet to port 21 on the server.  Port 22 works.

http://www.server-world.info/en/note?os=CentOS_7&p=ftp

Any suggestions?

D
LVL 2
detox1978Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
if you do netstat -at do you see it listening on port 21?
is iptables running?
0
detox1978Author Commented:
# netstat -at

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 localhost:smtp          0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:ftp             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:ssh             0.0.0.0:*               LISTEN
tcp        0     52 compare.road3.local:ssh ambackup.road3.lo:57062 ESTABLISHED
tcp6       0      0 localhost:smtp          [::]:*                  LISTEN
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN

Open in new window

0
detox1978Author Commented:
iptables is not running
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Seth SimmonsSr. Systems AdministratorCommented:
if you're on that server and you do telnet <local system name> 21 it doesn't respond?
0
detox1978Author Commented:
When I am on the server I can telnet to itself on port 21
0
Seth SimmonsSr. Systems AdministratorCommented:
ok...from another system it fails?
any firewall in between?
0
detox1978Author Commented:
from all other PC's on the same network it fails.

There are no firewalls on the other PC's.

Most notable is the fact I can telnet from other PC's to SSH port 22.  So more than likely it is a setting on the Cent OS server.
0
GaryCommented:
Did you actually start the FTP server? (Assuming the port is open in the Firewall on the Centos server)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
detox1978Author Commented:
Yes the service is running.

The server says it's listening on port 21 and I can telnet to port 21 using localhost.

Are there any filters in CentOS 7 / VSFTPd that stops network connections?
0
detox1978Author Commented:
there is a service running called firewalld
0
detox1978Author Commented:
and stopping it grants ftp access....
0
Seth SimmonsSr. Systems AdministratorCommented:
ok...that's the new firewall daemon
haven't had much time to play with RHEL/CentOS 7 yet

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Security_Guide/sec-Using_Firewalls.html
0
detox1978Author Commented:
Thanks.  I didnt realise it was there....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.