Mobile devices getting wrong server name - Exchange 2013

I have an Exchange 2013 environment that uses the following:
Username/email addresses formatted like this -  user@company.org
Mail server address - mail.company.org
Autodiscover is returning the correct values according to the ERC - mail.company.org
All internal and external urls are set correctly in exchange - mail.company.org
All DNS entries are correct internal and external - mail.company.org

Here is the problem, when setting up mobile devices (both android and apple) users put in their email address and password then get this:

username- user
server address- company.org

Is there a way to get these devices to see and autofill the correct server name which is MAIL.company.org?
We just migrated from Exchange 2007 where this worked with no issues. Now in Exchange 2013 it just does not work.
The same issue occurs internally and externally. Like I said, all of the Exchange addresses are correct: mail.company.org and the remote connectivity analyzer even returns the same: mail.company.org

Some post say that this is a mobile device issue/problem just give it up and send users instructions with the correct server address but I just cant believe that because it worked just fine before Exchange 2013.

Any help or advise would be greatly appreciated! I must be missing something.
Sean SizemoreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Autodiscover on mobile devices is very hit and miss as it is down to the vendor to implement. It works well on Windows Phone (or whatever they call it this week), Blackberry OS 10, Touchdown and some Android variants. Very spotty on iOS and other Androids.

Do you have autodiscover.example.com on the SSL certificate and relevant DNS records? Or are you using SRV records instead? Autodiscover A records I find are more reliable than SRV records with mobile devices.

Simon.
0
Sean SizemoreAuthor Commented:
The old 2007 Exchange server used and the new 2013 server is using the companies wildcard certificate with the msstd:*.company.org  for the principal name on EXCH, EXPR and WEB. We are using A records both internally and externally. I tried using SRV records but it made no difference. The mobile clients get the infamous "Failed to search exchange server automatically. Enter settings manually." If they put 'mail.' in front of the company.org entry it goes right through. This is very frustrating because it all worked fine before the migration. We have hundreds of mobile users, and get regular calls to the help desk just to tell them to put mail.company.org instead of company.org. I hate to give up on this but it looks like I may not have a choice! I appreciate your input  =)
0
Simon Butler (Sembee)ConsultantCommented:
MSSTD value, EXCH, EXPR and web have nothing to do with ActiveSync. ActiveSync uses only the URLs configured on the ActiveSync virtual directory. If those are configured correctly then you need to confirm what is being issued by Autodiscover.

Try running a test account through http://exrca.com/ and see what that returns. If it is returning the correct information then it is a problem with the mobile devices not interpreting the settings correctly.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sean SizemoreAuthor Commented:
Yes it returns the correct information. I was hoping it was something I had overlooked. I appreciate the input from both of you! Looks like I will be adding a help page to our self service portal to show users how to set the server name themselves.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.