FM - Reducing height of rows in 150% Table View

In the attached screenshot, notice how high the rows are in 150% table view.  (When I started in 100% view with about Times New Roman 12 font, the row height looked fine.)  I've tried changing to several different themes with no luck.  Font is Times New Roman 8.  I could put this in list view and make it work, but would like to avoid that.  Thank you.
--Screenshot.jpg
LVL 2
rvfowler2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will LovingPresidentCommented:
I'm not sure what would be causing this but I would try also changing the font itself to Arial or Verdana to see if it makes any difference. Some fonts render differently in terms of the overall height. And, while it's shouldn't really affect things in Table view, also check the Line Height settings under Format -> Line Spacing -> Other
0
rvfowler2Author Commented:
Tried different fonts already, but tried some more with no luck.  Yes, tried line spacing per your suggestion, but no luck there either.
0
slinkygnPresidentCommented:
What version of FM are you using?  There were some rendering updates to the later bug fix versions of FM 12, for example.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

rvfowler2Author Commented:
Version FM12.0v 4
0
rvfowler2Author Commented:
No real answer.
0
Will LovingPresidentCommented:
Randy, by any chance did you apply a "theme" to any of these fields? Check the "Advanced Graphic" settings in the Inspector to see if there is any padding applied. I didn't think padding affected table view and I don't have time to test right now but take a look and see if it's there. If it is, change it to zero for all settings. Also check your Line Spacing formatting for line Height and Space above and below. Again, I don't think these normally affect table view but it's worth taking a look at.
0
rvfowler2Author Commented:
Will, sorry I didn't see this last comment, so had it reopened.  Looked for padding, but couldn't find it on the Inspector (couldn't find the Advanced Graphics section), so maybe it is part of FM13 and not FM12?  All I could find was "corner radius" and it was set to 3.
0
slinkygnPresidentCommented:
Could you possibly get us an image of it at 100% as well?  Maybe a bit larger one with some other objects to compare to would be good too.
0
rvfowler2Author Commented:
I see now that I did a workaround (must have changed the theme).  However, here are screen shots of another one with a theme applied.  But notice the line height is set to 1 and no corner radius; yet, there is still spacing below the text in Table View.  The only way to get rid of this is to change the theme or change it to List View.
-Capture.jpg
-Capture2.jpg
0
slinkygnPresidentCommented:
There will always be a slight bit of spacing in the text in Table view.  The Inspector items you're looking at affect the field size in Form or List views; in Table view, the rows and columns are independent UI items from the fields themselves.  You adjust row size by adjusting font size in your fields; the row will collapse to the size of the largest font in that row plus a few pixels buffer.

In other words, what you see is intended behavior for Table view. If you want more customized row sizes, you'll have to build your own "Table view" using List View with a header and a very narrow body.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rvfowler2Author Commented:
Thanks, I suspected this, though being able to adjust row heights in table view might be a suggestion for the next version.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FileMaker Pro

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.