Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

How to: Disable SSH public key authentication on RedHat Linux server

Posted on 2014-10-08
13
Medium Priority
?
384 Views
Last Modified: 2014-11-22
I have a RedHat server and would like to remove SSH public key authentication on it, so that i can SSH into it without needing a key.

What I have already tried is this:
Added PubkeyAuthentication No into /etc/ssh/sshd_config config file. Then ran the command sudo /etc/init.d/sshd reload
0
Comment
Question by:cgruber
  • 4
  • 4
  • 2
  • +2
13 Comments
 
LVL 8

Expert Comment

by:Pepe2323
ID: 40369729
Hi

that option that you set on ur sshd_config will force you  to authenticate only by password, this is what you want ??

Regards.
0
 

Author Comment

by:cgruber
ID: 40369762
Well at the moment when I try to connect to the server via SSH using putty.exe, as soon as I type in the username (root) a popup appears saying.

"Disconnected: No supported authentication methods available (server sent: gssapi-with-mic)"
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40370068
paste your ssh config file

TY/SA
0
WatchGuard Case Study: NCR

With business operations for thousands of customers largely depending on the internal systems they support, NCR can’t afford to waste time or money on security products that are anything less than exceptional. That’s why they chose WatchGuard.

 

Author Comment

by:cgruber
ID: 40370133
shh or sshd?
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40370136
sshd_config
0
 
LVL 38

Expert Comment

by:Gerwin Jansen, EE MVE
ID: 40370286
@cgruber - Always keep one session open to a server that you're changing the ssh config for. That way you can test the new configuration using a second session and rollback if the change isn't working.

Add this to your ssh config file:

PasswordAuthentication yes
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40370289
agree with GJ

TY/SA
0
 
LVL 31

Expert Comment

by:serialband
ID: 40372000
Why don't you just use a key?  It's not that difficult to create and use.  If you're using putty, you can run pagent.exe and load your key until the next reboot.
0
 

Accepted Solution

by:
cgruber earned 0 total points
ID: 40407442
Anyone can help at all?
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40407806
What you have done seems correct.. Now please tell us what exactly the help you are looking at ?


TY/SA
0
 
LVL 31

Expert Comment

by:serialband
ID: 40411545
What other entries are in your sshd_config?  The default settings allow for both password and passphrase access.  This suggests that you have an entry that disables access.
0
 

Author Closing Comment

by:cgruber
ID: 40459259
Deleted config file and re-created. Set Pubkeyauthentication to No and it works now.
0

Featured Post

WatchGuard Case Study: Museum of Flight

“With limited money and limited staffing, we didn’t have a lot of choices in terms of what we could do to bring efficiency. WatchGuard played a central part in changing that.” To provide strong, secure Wi-Fi access within the museum, Hunter chose to deploy WatchGuard’s AP120 APs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Fine Tune your automatic Updates for Ubuntu / Debian
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month11 days, 8 hours left to enroll

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question