Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Timeout when trying to open an Office365 shared mailbox in Outlook 2013

Posted on 2014-10-09
23
Medium Priority
?
3,248 Views
Last Modified: 2014-10-18
I just migrated my organization to Office365. I created a test shared mailbox and gave my self Full and Send As permissions. This works great when using the web-mail client though a browser. However when I add the shared mailbox to my Outlook 2013, it hangs for a while then eventually says that it cannot reach the Microsoft exchange server. What is the deal?
0
Comment
Question by:GMSMRM
  • 13
  • 10
23 Comments
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40370952
How did you add the permissions, via the Admin center? If this is the case, the mailbox will automatically appear in your Outlook, you dont need to add it. Go to Accounts settings -> More settings -> Advanced and remove the shared mailbox from there, then simply restart Outlook and wait for it to get the updated autodiscover info.
0
 

Author Comment

by:GMSMRM
ID: 40370969
I added this shared mailbox via the Admin Center. In my browser window I still see teh shared maiblox there, but after closing and re-opening Outlook it is not there.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40370998
Run the Autodiscover test from ExRCA -> Office 365 tab here: https://testconnectivity.microsoft.com/
Or if you prefer locally via Outlook (hold the CTRL key, right click on Outlook icon in the tray, select Test E-Mail autoconfiguration, enter username and password and clear the two guessmart checkboxes).

If the test doesnt complete successfully, you will need to check what is preventing Outlook to get the autodiscover info. If it completes successfully, check the content of the XML file, look at the end for entry of type <AlternativeMailbox>. Is the mailbox in question listed there?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:GMSMRM
ID: 40371218
I ran the local test as you suggested. It was successful. In the XML file the Alternative email tags did list the Shared mailbox SMTP address .
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40371305
Have you removed the shared mailbox account from Account settings?
0
 

Author Comment

by:GMSMRM
ID: 40371312
Yes. I have removed the shared mailbox within my Outlook setting.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40371354
You are killing me :) Try to reconfigure the profile in Online mode?
0
 

Author Comment

by:GMSMRM
ID: 40371417
Tell me about it. I have my Office 365 implementation consultant working on the problem too and he cant't figure it out. The thing that flagged me the most was that after I added the shared folder and re-opened outlook, It kept asking me for credentials and it would not take mine. It would ask over and over. So for the heck of it I canceled it and outlook opened. Then my regular email account works just fine. However when I try to drill down the Tested shared folder account listed below, my outlook went to not responding for a while then a message came up and said that Microsoft Exchange could not be contacted. But my main email account still went fine after that. So it leads me to beleive that O365 is not accepting my credentials from Outlook for the shared account, even though it is correct, and it works perfect in OWA.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40371488
OK, that's important info. It this a domain joined machine? Do you, or previously had, on-prem Exchange server? How was the mailbox migrated to Office 365?

Do you have AD FS in place? What did the password prompt look like, did you notice a server name there?

One other thing - try clearing any stored credentials for Outlook in cred manager.
0
 

Author Comment

by:GMSMRM
ID: 40371502
Yes. I originally have a Exchange 2007 machine but now also have a Exchange Hybrid setup using 2010. My previous login use  to be domain\username. Now on O365 the UN is the email address, with AD sync to O365. I cleared all my Outlook in cred manager yesterday trying to troubleshoot this.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40371609
And both your and the shared mailbox are in the cloud?

You know what, try to configure the shared mailbox as additional account in Outlook. It will at least give us some error message we can work with. If you need help configuring that follow these steps: http://www.michev.info/Blog/Post/24/How-to-add-a-shared-mailbox-as-additional-account-in-Outlook
0
 

Author Comment

by:GMSMRM
ID: 40371638
Yes. I have already migraded my mailbox. I created the new test shared mailbox directly in the OWA console. it was not migrated.
0
 

Author Comment

by:GMSMRM
ID: 40371657
I attempted to add the shared mailbox as it's own account, as suggested in the link. When I go to add the account the wizard stays on searching for sharedmaibox@mydoamin.com for a long time and then fails - for encrypted and unencrypted. Like it cannot find it.

I see the shared mailbox on my hybrid server. I don;t understand why outlook fails searching for it.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40371671
Um, well there's your issue. Cross premises permissions are NOT supported. OWA works fine because of the redirect I guess, but otherwise you will not be able to access the shared mailbox. Move it to the cloud, it will work just fine (after your reapply the permissions).

http://technet.microsoft.com/en-us/library/hh852414
0
 

Author Comment

by:GMSMRM
ID: 40371703
I may have mis-spoke. Within my exchange hybrid server, I added access to my could O365 account for viewing. Everything is out on the cloud as I previously explained.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40372272
Then let's see if it's an autodiscover issue. Run again the ExRCA test, this time put "shared@domain.com" in the first field and "user@domain.com" in the second, again use your password. You will effectively be getting the autodiscover info for the shared mailbox.

The test will probably fail, because Outlook will end up trying to connect to your on-prem server instead, and for cloud created mailbox it will return no info. To work around this, use the reg keys in the following article to disable the local lookup: http://support2.microsoft.com/kb/2212902

Alternatively, try to configure the shared mailbox manually: http://www.michev.info/Blog/Post/12/How-to-manually-configure-your-Exchange-Online-(Office-365)-email-account-in-Outlook
0
 

Author Comment

by:GMSMRM
ID: 40373031
I went with your thoughts about autodiscover and did some digging. I ran the Test E-mail Auto Configuration on my outlook and found that the autodiscover failed when running HTTPS://mydomain.mail.onmicrosoft.com but passed running HTTP://

I am not sure what is causing this to fail, or even if it is the problem causing the shared mailbox not to authenticate. I also disabled all add-ons with my outlook 2013 client to make sure they were not interfering.
0
 

Author Comment

by:GMSMRM
ID: 40373666
I read somewhere that I may be missing a public DNS CNAME record for autodiscover. I can get into my Godaddy account and add one. Do you know what the specific record should be set as?
0
 

Assisted Solution

by:GMSMRM
GMSMRM earned 0 total points
ID: 40373711
I think I may have found the issue. I am still running the autodiscover record pointing to my exchange hybrid server IP address. I was not ready to take the leap and point the record to outlook.com yet. But I think that is where I am at.
0
 
LVL 45

Accepted Solution

by:
Vasil Michev (MVP) earned 2000 total points
ID: 40373905
It's not a problem for Autodiscover to point on-prem, you do however need it to be a public CNAME record.
0
 

Author Comment

by:GMSMRM
ID: 40373922
Godaddy DNS would not allow me to have a Host @ record and a CNAME record of the same name, autodiscover, in this case.
0
 
LVL 45

Expert Comment

by:Vasil Michev (MVP)
ID: 40374516
You only need CNAME externally, for internal GoDaddy cannot stop you :)
0
 

Author Closing Comment

by:GMSMRM
ID: 40388522
I found the problem on my own. Expert did mention an issue with Autodiscover could be the cause which brought me to the ultimate solution.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If Skype for Business came with your office 2016 or office 365 installation, you may find that it's almost impossible to either disable or remove it. The application will often launch with each start of Windows, even when explicitly configured not t…
Often, the users face difficulty in accessing Outlook 2016 PST files on Windows 10 computer. One of the reasons behind it is the improper functioning of MS Outlook when the user tries to open it. MS Outlook suddenly stops working, or it will not op…
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…
As many of you are aware about Scanpst.exe utility which is owned by Microsoft itself to repair inaccessible or damaged PST files, but the question is do you really think Scanpst.exe is capable to repair all sorts of PST related corruption issues?
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question