MS RDP client disconnect on Mac 10.8.5

We have Mac running OS v 10.8.5 and they are using the MS Remote Desktop v8.0.9 to connected to a RD server running Windows 2012 Server. During remote sessions the clients are often getting 'failed to read from socket -1' and then get thrown out of the remote session.

I researched and do not see any details to resolve this matter.

Any ideas?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dunno what is causing that, but you might try CoRD instead:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
You could also try uninstalling and re-installing the MS client.
bnrtechAuthor Commented:
strung - thanks for this tip. We installed the Cord app. The Mac that we have for testing still seems to disconnect from the remote network. It no longer gives the 'failed to read from socket -1' error but we still get disconnected (while Windows clients are not getting disconnected)
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

bnrtechAuthor Commented:
We have also tried uninstalling and reinstalling the MS client
What do the console logs say when you get disconnected?
bnrtechAuthor Commented:
I will check again, but thus far on the W2012 server there are no details being captured in the log files
I meant the log files on the Mac.
bnrtechAuthor Commented:
Got it. We will check the Mac now. Interesting on the W2012 server I did find an error (but the details do not support our setup given that the W2012 is a member of Terminal Server License Servers group and is NOT a domain controller). The warning in the server log states...

The Remote Desktop license server cannot update the license attributes for user "MAC USER" in the Active Directory Domain "". Ensure that the computer account for the license server is a member of Terminal Server License Servers group in Active Directory domain "".
If the license server is installed on a domain controller, the Network Service account also needs to be a member of the Terminal Server License Servers group.
If the license server is installed on a domain controller, after you have added the appropriate accounts to the Terminal Server License Servers group, you must restart the Remote Desktop Licensing service to track or report the usage of RDS Per User CALs.
Win32 error code: 0x80070005
Have a look to see a proposed solution for the licensing problem here:

(It does refer to an older version of the rdp client)
bnrtechAuthor Commented:
That looked interesting but it was not valid.

On the Mac when we go to  'Macintosh HD' > 'Users' > 'Shared'  there is no 'Microsoft' folder. Still poking around.
Perhaps that solution is just for the older version of the RDP client.

Do the Mac logs shed any light?
bnrtechAuthor Commented:
The Mac logs do not shed any light. Nor does MS. We opened a case with them and they are not having much luck figuring it out either
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.