Solved

Exchange 2010 to use Fully Qualified Domain Name Since

Posted on 2014-10-09
4
280 Views
Last Modified: 2014-10-15
Hi All, I hope you can help me understand and resolve my issue.

Scenario: we have exchange 2010 that has an expiring SSL Cert.
                  we have renew the cert. in godaddy.com but needed to take the SAN with a .local parameter since they are not  
                  allowing it anymore. So now after all the cert request, completing the request and Assigning services to use the
                  cert. We end up with one issue.  Once a client computer opens outlook we are getting a security alert
                   message that says The name on the security certificate in invalid or does not match the name of the site.


my question is. : We know that we are getting this because the SAN "servername.domain.local" is not in the Cert
                               anymore. Since Cert. Auth. is Phasing it out.
                           
                                We would like to know what steps we need to do to get it straightened it out. I red some article from
                                godaddy.com on how to configure the exchange server to use FQDN using a shell but not sure what
                                it can cause after running the command.

                                I think if we can make our email clients to resolve name with one of the SAN in the Cert. we will be fine
                                but we don't know how to handle it.

any solution with brief explanation will be appreciated. thanks in advance

Security alert after outlook pulls up.
0
Comment
Question by:mod2inc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 500 total points
ID: 40372190
You basically need to reconfigure all your Internal URLs in Exchange to match what's in your External URLs. Then configure split-brain DNS to point those newly created Internal URLs to the local IPs of your Exchange servers (or load balancers).

The whole process is explained here. From Split-Brain creation, to configuring all the URLs in GUI/PowerShell, to processing the cert.
http://supertekboy.com/2014/05/27/designing-a-simple-name-space-for-exchange-2010/
0
 
LVL 25

Expert Comment

by:-MAS
ID: 40372209
Gareth provided a link/artcicle which explains how to configure your internal DNS server FLzones and exchange URLs. If you follow that your issue will be solved.
0
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 40372372
you have to buy SAN certificate for exchange.
0
 

Author Closing Comment

by:mod2inc
ID: 40382759
Thank you. I resolved it. The link is very helpful.
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This video discusses moving either the default database or any database to a new volume.

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question