com.jcraft.jsch.agentproxy.AgentProxyException not found

I'm using apache service mix 5.1.2 with the built in jclouds 1.7.2 feature.  When I try to run my service that uses jclouds, I get the following error:

java.lang.ClassNotFoundException: com.jcraft.jsch.agentproxy.AgentProxyException not found by wrap_mvn_com.jcraft_jsch.agentproxy.jsch_0.0.7 [247]
      at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460)

First, I thought this should be included in the jclouds feature.  But I can't even find what maven package AgentyProxyException is in so can't even add an appropriate dependency.
I
LVL 6
HyperBPPAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HyperBPPAuthor Commented:
I tried that and still had the same problem.  The com.jcraft bundles are using are 0.0.7 and there is only a POM for Jcraft jsch 0.0.7.  Not sure what packages.  Also, why doen'st htis work with the jclouds feature in ASM?
0
CEHJCommented:
I tried that and still had the same problem.
What exactly did you do?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

HyperBPPAuthor Commented:
I installed the mvn bundle for Jcraft jsch and I still had the agentproxyexception error.
0
CEHJCommented:
So that stopped the running app, added the missing jar(s) to its classpath, and restarted it?
0
HyperBPPAuthor Commented:
I got it working:

1. Got a fresh distro of ASM 5.1.2
2. Removed the Jclouds 1.7.2 URL
3. Added the Jclouds 1.8.0 URL
4. Installed necessary Jclouds URL features
5. And God saw it and said that it was good.
0
HyperBPPAuthor Commented:
My answer has ultimate solution.  Other information helped lead me to this answer.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.