Solved

RDS - How to set up default program application for remoteapps?

Posted on 2014-10-10
22
2,379 Views
Last Modified: 2014-10-11
Currently trying to deploy remoteapp using remote desktop services on a 2008 R2 server.   I need to make the default application program MODI (Microsoft Office Document Imaging) instead of Microsoft Photo viewer when trying to view TIFF or TIF files.    I had to install Sharepoint designer to implement MODI when using Microsoft Office 2010.   On the folder itself I was able to make the MODI open TIFF and TIF files.   However, users are getting Microsoft Photo Viewer using the remoteapp to view TIFF or TIF.   I need MODI to be the default application program.

Thanks
0
Comment
Question by:rmartes
  • 13
  • 9
22 Comments
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374066
0
 

Author Comment

by:rmartes
ID: 40374682
The instructions for making the changes using the UI is not the same for 2008 R2 as it is detailed for 2012.   I am not familiar with Powershell, so I am having problem trying to follow those instructions.  Any other suggestions?
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374691
The instructions should still apply to 2008 R2, have you tried them?

Publishing file type associations using UI

When a RemoteApp program is published, we calculate the list of file type associations that it can support when running as a RemoteApp program. To see this list, open up the properties of a published RemoteApp program in the new Server Manager UI, and navigate to the File Type Associations tab:

(Go to the properties of the Microsoft Office Document Imaging)

To publish file type associations for this RemoteApp program, simply select the file types that you want to be made available to end-users and click OK or Apply.

After you have published file type associations for your apps, they will automatically be installed for all users who are subscribed to the RemoteApp and Desktop Connection as a default connection. That installation will happen the next time the user’s client updates the connection (by default it updates every night around midnight).

So basically you're amending the properties of the actual application to ensure when users click .TIFF or .TIF that it opens with Microsoft Office Document Imaging
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374694
If the above doesn't work or make sense the below guide will help you change the file association by making an amendment to the registry on the server where the application is published from.

http://www.grouppolicy.biz/2011/09/how-to-use-group-policy-to-change-open-with-file-associations/
0
 

Author Comment

by:rmartes
ID: 40374724
The first option that you gave me Roshan  does not seem to apply as I am not seeing the UI interface that you mentioned.   I just created a group policy to force the file association, so I am waiting for the changes to take place to confirm results.
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374775
Okay,

Let me know how it goes.
0
 

Author Comment

by:rmartes
ID: 40374784
I am still having issues either way
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374795
So you've applied the group policy and you're still having the issue? When the user opens a .TIFF does it not prompt them what they want to use as a default opener? if you remote onto the server and you open a .TIFF does it prompt you?

Have you tried changing this in the Control Panel on the server?

I've posted a screenshot of a server in my test lab.

TIFFFile
0
 

Author Comment

by:rmartes
ID: 40374811
As you can see, my default settings on the server is indeed MODI and it opens it up automatically.

tiff.jpg
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374818
So if a user opens up a .TIFF on RDS01 they get MS PhotoViewer instead of MODI correct?

Does this effect all users?
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374820
Have you also rebooted the server since making the above Group Policy change?
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:rmartes
ID: 40374825
If any user using RD Web Access from a remote computer tries to open a .TIF or .TIFF, they are getting MS PhotoViewer instead of MODI.   I will reboot the server and try again, because I did not reboot the server after making changes to the group policy.
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374826
Reboot the server and post back your results. Did you make the change on the server the users would be essentially using to use the published application?
0
 

Author Comment

by:rmartes
ID: 40374834
Yes all changes are on the server in question where they will run the RemoteApps.   I am still getting the same thing after rebooting the server.  Sorry
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374838
I've ask my colleague about this and he emailed me this:

1. Log on to the RDSH server as the yourdomain.co.uk\Administrator user account.

2.Server Manager will start automatically. If it does not automatically start, click Start, type servermanager.exe, and then click Server Manager.

3.On the left side of the window, click Remote Desktop Services.

4.Under Collections, click SessionCollection.

5.Under the REMOTEAPP PROGAMS heading, right-click MODI, and then click Edit Properties.

6.Click File Type Association.

7.Select .TIF and .TIFF

8.Click OK.

9. Retest, a server reboot maybe required.
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374843
0
 

Author Comment

by:rmartes
ID: 40374848
I was able to see 1-3, but do not see 4 anywhere


no-collections.jpg
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374878
What about under RemoteApp Manager and RemoteApp sources?
0
 
LVL 13

Accepted Solution

by:
Rizzle earned 500 total points
ID: 40374886
I think I've found the answer to your issue.

http://technet.microsoft.com/en-gb/library/cc730673(v=ws.10).aspx

Then scroll down to Create a Windows Installer package from a RemoteApp Program.
0
 

Author Closing Comment

by:rmartes
ID: 40374961
This worked like a charm, because has the option to state to use the associated file extension
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40374972
Which solution worked in the end? Literally jumped with joy when you marked this as RESOLVED!!!

Perseverance has paid off :)
0
 

Author Comment

by:rmartes
ID: 40375152
Correct your last solution worked as you expected.  I now have another question and will post shortly.   Yes it does paid off...
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now