?
Solved

Exchange 2010 new cert problem

Posted on 2014-10-13
5
Medium Priority
?
29 Views
Last Modified: 2015-06-02
I have two Exch2010SP3 servers, one in each of two AD sites.  Layout below:

SiteA-------------------------------Internet
    EXCH1
|
|
|
SiteB
    EXCH2

In preparation for a migration to Office365, I bought a 3rd party cert for EXCH2 to allow external access for mailbox migrations.  I assume that I'll need to redirect OWA/ECP to this new cert's URL.  We currently have the one OWA cert to SiteA/EXCH1 that proxies for SiteB/EXCH2.  
In order to change this proxy and allow external OWA access to EXCH2 I will need to do the following:

Change ExternalURI values for OWA and ECP on EXCH2
Bind the new cert to https on EXCH2

I know there's at least two other steps but I'm drawing blanks..
What am I missing?
0
Comment
Question by:Ben Hart
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40377002
It is the presence of the external URL that tells Exchange whether to proxy or redirect.
Therefore if you configure an external URL then restart IIS, you shouldn't need to do anything else on Exchange. Open port 443 and ensure the second host name resolves to the Exchange server and Exchange will do the rest.

Simon.
0
 
LVL 14

Author Comment

by:Ben Hart
ID: 40377632
Thanks Simon.  Will I also need to change the type of Redirection?  From Manual to Silent?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 40378340
Did you change the value for redirection on the OWA virtual directory?
If so, then you should ensure that silent is enabled.

Neat write up on the process on the Exchange team blog (saves me writing it all out)
http://blogs.technet.com/b/exchange/archive/2011/12/12/owa-cross-site-silent-redirection-in-exchange-2010-sp2.aspx

Simon.
0
 
LVL 14

Author Comment

by:Ben Hart
ID: 40379768
I coulda swore the redirect was silent back when we first set these servers up *cough* 4 years ago *cough*.  But it was set to Manual.  Change to Silent and tested yesterday and today.  Redirect worked and every internal/externalurl is now the new url.  I did resetiis on both servers just in case...

I now have a mailtip issue but that might be a different topic posting. Thanks Simon.
0
 
LVL 14

Author Closing Comment

by:Ben Hart
ID: 40808988
Sorry it took so bloody long Simon.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question