Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Save several RDP usernames on 1 Windows 7 PC

Posted on 2014-10-13
10
248 Views
Last Modified: 2014-10-23
I have a Windows 7 PC with several RDP shortcuts to servers/pc's. But when Ichange the username of one rdp shortcut, all the shortcuts are getting the same username and this is not correct.

With Windows XP this worked fine, but now I have to fill-in the username and password.
0
Comment
Question by:rsjmeijer
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 17

Assisted Solution

by:lruiz52
lruiz52 earned 250 total points
ID: 40377294
Try opening up Remote Desktop,

Click Show more option on bottom left corner.

type Computer name of computer you want to connect to.

Type User Name of account you want to use to connect .

Click Save As. and give the connection a name.

Save it to your desktop
.
0
 
LVL 54

Expert Comment

by:McKnife
ID: 40377415
I am quite sure, this will not work. Instead, you could use dns aliases for the computer, one per user.

User A would connect to servernamehereA, B to servernamehereB. Each credential set would be saved separately that way.
0
 

Author Comment

by:rsjmeijer
ID: 40377604
lruiz52 -> I did try that but this does not work, it did with Windows XP no problem there. Now with Windows 7 it does not work.

McKnife -> The servers have different IP adresses, thats not the problem.

I have 2 RDP shortcuts on my desktop with the correct IP adresses. When I change the user name of RDP shortcut 1 the username allso changes from RDP schortcut 2. And that not what I want to happen.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 17

Accepted Solution

by:
Spike99 earned 250 total points
ID: 40377787
What is the RDP shortcut pointing to? Check properties of the shortcut: it sounds like they're pointing to the same RDP shortcut.  They're probably both pointing to C:\Users\%username%\documents\Default.RDP, which is the default shortcut created for remote desktop connections when you first connect to a remote server or PC.  So, if you change settings & just click on "Save," you are changing the default settings for all connections and saving to the same RDP file.

You can save the RDP connection as an .RDP file on your computer.    Once you save that separate RDP file, you can edit the remote server IP, user name, RDP gateway server address, etc.  It's completely customizable & you can save those specific settings for just that RDP file which won't effect any other RDP connections you have saved to other .RDP files.

To save a separate RDP file for each server you want to connect to, adjust the connection settings the way you want. Then, when it's all set up the way you like, click on the General tab & click on "Save as...." to save the RDP icon where you like (saving it to the desktop works best for most people).

I hope this helps.
0
 
LVL 54

Expert Comment

by:McKnife
ID: 40378122
You did not understand my comment. The problem you face can be solved that way. Try the following and you will agree: For one user, use the name as rdp target, for the second user, use the IP. Now you have two independent credential sets that can be saved.
0
 
LVL 54

Expert Comment

by:McKnife
ID: 40378241
It's a different problem here http://support.microsoft.com/kb/938120 but the solution is the same.
Also, please see the problem cause confirmed here, it's the newest RDP client: http://support.microsoft.com/kb/951609 "You cannot save multiple credentials for the same remote computer when you use the RDP client that is included in Windows XP Service Pack 3 " <- xp sp3 had the same problem :)
0
 

Author Closing Comment

by:rsjmeijer
ID: 40396843
I had the option "save user references" turned on. This caused the problem.
When this option is turned on, the user references will change for all the RDP shortcuts. Perhaps a bug within Windows 7?

After disableling  this option, I did enter the username again and saved the rdp file. Now it works fine.

Thanks for the help!
0
 
LVL 54

Expert Comment

by:McKnife
ID: 40397005
What option are you talking about, where does one select/deselect it, please?
0
 

Author Comment

by:rsjmeijer
ID: 40400109
The Save user references option
0
 
LVL 17

Expert Comment

by:Spike99
ID: 40400153
Where is that option found? I am not familiar with that one.
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question