Solved

Synology ds211j backup failure

Posted on 2014-10-13
18
984 Views
Last Modified: 2014-11-04
Hello,

I've been having some troubles getting a backup to run on my Synology ds211j NAS enclosure. The attached/embedded jpeg images show the issue and the configuration. It's a simple backup of one 3TB drive to another of equal capacity. The target drive is freshly formatted with more than enough free space. But when the backup task runs, I get this error:
          "Failed to backup because backup space is insufficient."
I'm not sure how to proceed from here; don't know what else to try.

Scott.


NAS-log.jpgNAS-taskfail.jpgNAS-shareconfig.jpgNAS-Vol1Config.jpgNAS-Vol2Config.jpg
0
Comment
Question by:JonahGroup
  • 10
  • 6
  • 2
18 Comments
 
LVL 35

Expert Comment

by:Kimputer
ID: 40377293
Clearly Volume2 is totally full. That's because Volume1 is pretty full too, however, Volume2 needs more data as it probably keeps a bit more info (could be info on the files, or it keeps some versions of the files). Time to syphon off some older files (store them somewhere else) or change the volumes to RAID1 (no backup needed, the two volumes will be mirrored). You will lose the suspected multiple file versions feature of the backup tough.
0
 

Author Comment

by:JonahGroup
ID: 40377373
I don't think I'm understanding what you're saying.

Here's what I see. The disks have the same total capacity. The target disk, Volume 2, is almost completely empty (301.07MB used, of 2.68TB in total). The source disk, Volume 1 is almost full, with 34.1GB free, 2.65TB used. So there's 34.1GB of "wiggle room", which is a lot. I'm copying an almost full disk to an empty target disk of equal capacity. So I don't understand the error.

Or, are you saying that these two volumes are part of the same RAID volume/disk group? My understanding is that these two volumes are completely separate, basic, stand-alone, no RAID protection. Could I be wrong about this? It was not my intention to use any RAID or protection features. Volume 1 is SHR, but I didn't specifically configure it to have any redundancy or protection. And this is indicated by the description "Without data protection".
0
 
LVL 35

Assisted Solution

by:Kimputer
Kimputer earned 100 total points
ID: 40377395
Yes you're totally correct, I read it wrong (thought it was only 300MB free space left).
Can you pull up info on the backup job? And the backup log?
0
 

Author Comment

by:JonahGroup
ID: 40377428
The first two images of my original post show the backup task/log details. I'm not sure where else to look for better detail.

The images below show the backup job details (each of the tabs for the job edit window).

NAS-backupFolder.jpgNAS-backupDest.jpgNAS-backupApplication.jpgNAS-backupSched.jpg
0
 
LVL 26

Assisted Solution

by:akahan
akahan earned 400 total points
ID: 40379196
What happens if you uncheck "enable metadata backup"?
0
 

Author Comment

by:JonahGroup
ID: 40380477
I figured that whatever metadata they're talking about wouldn't add substantial storage overhead (and certainly not 34GB more). Nonetheless, I'll try it when I get home this evening. I don't have any better ideas at this point.
0
 
LVL 26

Assisted Solution

by:akahan
akahan earned 400 total points
ID: 40380588
I agree, it is hard to imagine the metadata taking up THAT much space, but I  have seen many postings on Synology's own forums where people are finding that it takes a tremendous amount of time to do the backup if metadata is enabled.   If it's taking a lot of time, perhaps it's transferring a lot of data.

Keep in mind that this backup is not simply copying the files, it's doing more than that.  If it's Synology's Time Backup, for example, it's also creating files that summarize what was backed up when, so that, next time, it doesn't have to back up every single file again, just what's changed.  So the backup occupies more space than the original (though I'd agree with you that 30+GB more than the original seems excessive.)
0
 

Author Comment

by:JonahGroup
ID: 40381904
Tried it again last night, with the "enable metadata backup" not checked, but the same result. The email notification  works well.

----------------------------
Subject: Synology Report: The Local Backup on DiskStation was aborted
From: DiskStation - Synology DiskStationAdd contact
Date: Wed, 15 Oct 2014 00:03:05 -0400

Dear user,

The Local Backup on DiskStation was canceled because of insufficient disk space on the Local Backup disk.

Task: Backup Volume_3 DISK2
Destination: /volume2/Volume_4

Sincerely,
Synology DiskStation
0
 
LVL 26

Assisted Solution

by:akahan
akahan earned 400 total points
ID: 40382464
Exactly which Synology backup program are you using?  Time Backup, or something else?  And which version?

Also, exactly what is the shared folder "Volume_3"?   It doesn't appear to be the entire drive, it appears to be a shared folder that is separate from video, music, and photo.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:JonahGroup
ID: 40384087
The image below is the general system information tab. DSM version is shown.

General System Information
This image shows the pop-up main menu that appears when you click on the drop-down selector (the triangle icon). The backup program is the "Backup and Restore" application. I can't see how to find out if there's a separate version number for this application, but the DSM version is 3.1-1748.

Main drop-down menu
And yes, the share name for Volume 1 is "Volume_3", as shown in the third image from the top of this page.  From this page/screen, I understand this to mean that the share called "Volume_3" is the entire disk volume known as "Volume 1".

The other share names I didn't create (music, photo, video), but they appear to be share names mapped to the same thing -- Volume 1. I suppose these were automatically created by the system. But in my backup job, I only select the share called "Volume_3" to be backed up.
0
 
LVL 26

Assisted Solution

by:akahan
akahan earned 400 total points
ID: 40390409
Can you expand "Volume_3" by clicking on the plus sign next to it, so we can see if it really is what you think it is?  And, then, assuming that it is, try backing up just a portion (some subfolder of it, perhaps), to see if that works...I'm wondering whether this really is a size issue, or whether it would give you this error even if you tried to back up something much smaller.
0
 

Author Comment

by:JonahGroup
ID: 40390689
The Volume_3 share is what I think it is -- the root directory of the volume. But choosing less than the entire volume is a good idea; just to see what happens. If it can't back up even a very small folder, then we know that part of the problem is with bad error reporting. I'll do this and report back.

Expanded backup folder
0
 

Author Comment

by:JonahGroup
ID: 40393414
I was able to perform a successful backup of just a very small subfolder. The first image below shows details of a much smaller source backup folder (a subfolder of the Volume_3 share). The second image shows details of the target folder after the backup successfully completed.

NAS-BackupSourceDetail.jpg NAS-BackupTargetDetail.jpg
As you can see, the actual space (bytes) occupied by these folders is not the same. It takes more space to hold the same files on the target. For this small example it's about 0.04% more space needed. Extrapolating to the full backup of Volume_3 data, it might amount to about 1GB more space needed on the target. But I have about 34GB of slack, so somehow I doubt this will account for there being a lack of space on the target.

It does indicate differences in the underlying block allocation units between the two drives. I wonder if there's a way to control this -- to match up the characteristics of the source with the target.

Next, I will attempt a much bigger subset of folders and compare the space differences between source & target.
0
 
LVL 26

Assisted Solution

by:akahan
akahan earned 400 total points
ID: 40393450
I wonder if the backup process also temporarily consumes some space on the target drive for some reason (storing a progress report, or error log, maybe), and releases the extra space when the process completes.  Perhaps it allocates space on the target at the outset for this purpose.
0
 

Author Comment

by:JonahGroup
ID: 40406810
I've been experimenting with ever increasing backup sizes on the source side. It will do a full 2TB backup without any trouble.  I'm looking for the largest threshold where it begins failing. I also want to observe the target space as it fills, to see if that make sense as it executes. In the beginning, I don't see anything unusual happening, but I need to see it to the very end (which is time consuming).
0
 

Accepted Solution

by:
JonahGroup earned 0 total points
ID: 40414591
The image below shows the end result of a full backup of Volume 1 (share: Volume_3) to Volume 2 (share: Volume_4). As a single task/job, it still fails. In order to have this succeed, I had to split the task into two sequential backup tasks, approximately 80/20 in workload.  During each backup, I wasn't able to observe any excessive use of the target amounting to more than 1MB for status/progress/errorlog. But it is interesting to note the difference in space used when finished -- identical capacity drives, holding identical data, but the target uses 48GB more space because the underlying default block allocation characteristics are different (guessing here). The source drive is Hitachi, while the target is Seagate.
NAS-SystemStorage2.jpgI don't think there's going to be a real answer to this one without getting Synology tech support involved. And I have a work-around, so I'm closing this question. Thanks for helping!
0
 

Author Closing Comment

by:JonahGroup
ID: 40421197
Much of the process of partially figuring out this issue was just having someone poke me with questions, and this would lead me to think and experiment. I awarded points to both experts answering my post.
0
 
LVL 26

Expert Comment

by:akahan
ID: 40421508
Thanks, I think this may be helpful to others having the same problem, due to your thorough experimenting and reporting back.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now