Solved

Why is my Veeam Backup & Replication shutting down my Exchange Server when backup job runs?

Posted on 2014-10-13
10
844 Views
Last Modified: 2016-02-25
We have 14 virtual servers running on two hosts using VMware ESXi 5.0 which have been running without issues for nearly a year now. Unfortunately we had one server fail a few weeks ago which required restoring six virtual servers.

Since the restore everything is running fine except for the 2010 Exchange Server Backup. For some odd ball reason the server is being turned off during the Veeam backup job. I have tried creating new jobs, but nothing has resolved this issue. I'm not having this issue with any other server and have never experienced this issue in the past.

Every morning I have had to manually power the Exchange Server back on which is obviously unacceptable. I can't find anything on the internet about this which seems odd to me.
0
Comment
Question by:techstang
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 47

Expert Comment

by:noxcho
ID: 40377821
Check if vmware tools have been installed on this vm.
0
 

Author Comment

by:techstang
ID: 40377879
Just verified and yes it was installed. I uninstalled and reinstalled just a moment ago but I can't say I'm confident that was the issue.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40378470
Usually the VSS requestor is accessed through vmware tools and if they are not installed or disabled this could prevent online backup. Have you checked if the backup shuts it down now?
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:techstang
ID: 40378549
The backup is definitely shutting it down, that much I'm positive of. If I disable the backup the server is fine, if I enable the backup it will shutdown. I just uninstalled and reinstalled earlier, will see what happens this evening. I can't do much during business hours unfortunately so will follow up with you tomorrow.

Thanks Noxcho
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40378624
Ok, keep me updated. Meanwhile you can look in events of this server if there was any sequence of events which let the server shut down.
0
 
LVL 12

Expert Comment

by:S00007359
ID: 40379091
whats the vss status on your exchange server?

from an elevated command prompt, please run

vssadmin list providers and
vssadmin list writers

also check what time your backups start and if there are any corresponding events in the event log file

this may sound funny, but chnage the backup time on when you are available to see what happens. log onto exchange server and run the backup, see what happens, a graceful shutdown or a bsod? and shutdown/
0
 

Author Comment

by:techstang
ID: 40380340
Hello Everyone - Last night I changed the backup to 9am and watched as suggested. The backup started just fine and the server stayed online. I monitored for the next few hours while it ran and the Exchange Server stayed online until the very end and which point it was turned off. Now I'm not positive how it's being shutdown but I know it's not a graceful shutdown because when I manually power on the server it says it was not shutdown correctly, and asks if I want to start windows normally. It powers on without issues, etc.

This caused me to dig around more and I noticed in VSphere that my Exchange Server Summary says "Virtual Machine Disks Consolidation is needed"

So I proceeded to go through the steps to do this and the server shutdown and process stopped after getting through 3%... Now at this point it's Midnight so I powered the server back on and made sure everything was operating correctly. I will need to look into this further but I'm starting to think this is the issue. Any thoughts or recommendations on this is welcomed as I've never had to deal with this issue. I found a few articles on it and the process seemed pretty straight forward assuming it worked correctly.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40380885
0
 

Accepted Solution

by:
techstang earned 0 total points
ID: 40408685
Sorry for the delay on this everyone. At this point the issue is resolved.

I attempted to upgrade from ESXi 5.0 to ESXi 5.5 on Friday night and received an error that basically stated the disk was corrupt. At this point my backups were good and up to date and proceeded to delete the VD, then created a new one and initialized, etc. I loaded ESXi 5.5 from scratch and restored my servers from backup. At this point the backups for Exchange is back to normal and none of my disks need consolidation.
0
 

Author Closing Comment

by:techstang
ID: 40418003
This solution worked but definitely isn't ideal and not what I was hoping for in the long run. Ultimately I needed to solve it and this did the trick.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
In previous parts of this Nano Server deployment series, we learned how to create, deploy and configure Nano Server as a Hyper-V host. In this part, we will look for a clustering option. We will create a Hyper-V cluster of 3 Nano Server host nodes w…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question