Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 384
  • Last Modified:

Please help with changing language in windows 8 x64 pro

Hi

I'm trying (and failing) to change the default display language of Windows 8 x64 pro on a users laptop.

Currently the display language is English, however they need it to be German.

I have added the language under Language via control panel and the keyboard input is German (with german keyboard) so that works.

I've tried the tutorials online including setting German as the Primary language but even after a reboot I'm left with English display still.

Thank you
Steve
0
steve_york
Asked:
steve_york
  • 12
  • 11
  • 6
  • +2
1 Solution
 
McKnifeCommented:
I used this (en and de) on 8 pro without problem with setup. What happens when?
0
 
steve_yorkAuthor Commented:
Hi

Sorry but I am unsure what you are asking?

Steve
0
 
GlingoCommented:
Hi,

If you go to your control panel, languages, advanced settings, select German in the "Override for Windows display language" if it's not already selected.

Also you can follow the link bellow "Apply language settings to the welcome screen..." and click on "Copy settings" to check if the display language is German.
0
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

 
steve_yorkAuthor Commented:
Hi Glingo,

When I get to the Override part, the only options I have are English (United States) which is selected or Use language list

Also, the current display language according to the link is English (United States), the input language is German though

Steve
0
 
McKnifeCommented:
I ask simply what are you doing and what happens instead of the expected.
0
 
GlingoCommented:
And if you go to control panel/language and click on "Add language", then select german there and move it up to the top of the language list?
0
 
GlingoCommented:
Oh and also once you added it to the language list, clic on the german option link and select the option "make this the primary language", if this link isn't available you'll have a link to download the appropriate language pack.
0
 
steve_yorkAuthor Commented:
McKnife: I've set the language options to be German and restarted but the display language is still English,

Glingo: When I go to Control panel > Language the languages there currently are:

Deutsch - 1st
English - 2nd
0
 
steve_yorkAuthor Commented:
Glingo, when I click on the german option that's top of the list I do not get the option to set as primary language.
0
 
Phillip BurtonCommented:
I don't either.
0
 
GlingoCommented:
But in that option window, the first option is "Windows display language" right? under this you should have the option to set as primary language, if not  you should have a link "Download and install language pack", if so click on it and install the appropriate language pack. Once the language pack is installed you should have the option to set it as primary language
0
 
steve_yorkAuthor Commented:
You're quite right the first option is win display language, however it says that a language pack is not available. :(

Do you know if there is an offline version I can download and install manually? I did check on MS website but they suggest to install via control panel for the German language.
0
 
Phillip BurtonCommented:
This is what one can see.
Language.PNG
0
 
GlingoCommented:
Huh! That's weird, here's what I have when I try to add german:

German.JPG
Is that computer connected to the internet? Also are you logged in as administrator on it?
0
 
steve_yorkAuthor Commented:
It is connected to the internet and I am as an admin. :(
0
 
Phillip BurtonCommented:
Yes, and yes.
0
 
steve_yorkAuthor Commented:
Are you able to save the download pack at all?

I'm trying again but this time over iPhone hotspot to eliminate firewall.
0
 
Phillip BurtonCommented:
0
 
Phillip BurtonCommented:
Unfortunately, there is no option to download German.
0
 
steve_yorkAuthor Commented:
Thanks Phillip, I was hoping it would be on there but like you say there is no option.
0
 
GlingoCommented:
Maybe try this:

There are advanced language settings that may block the download of language packs. To revert these settings to their defaults values so that you can download language packs, follow these steps: 1.Open Control Panel. To do this, type Control Panel in the Search box, and then tap or click Control Panel in the search results list.
2.Tap or click Clock, Language and Region. (If you are viewing Control Panel in icon display, select Language, and then go to step 4.)
3.Tap or click Language.
4.Tap or click Advanced settings.
5.Examine the Override for Windows display language and Override for default input method lists. Make sure that the Use language list (recommended) option is selected for both lists (see Figure 5). Then, tap or click Save.
6.After you save the settings, you are returned to the standard language settings. In the list of previously installed languages, click Options next to the language you want to install.
7.Click the download link to install the language pack
Note: After the installation is finished, you are prompted to restart the computer.
0
 
Phillip BurtonCommented:
No change - "Use language list (recommended)" was already selected twice. Maybe Steve_York may have better luck.
0
 
GlingoCommented:
Are you on Windows 8 or 8.1? If you're on 8.1 the languages packs are not the same, looks like you can download them here:

http://winaero.com/blog/download-official-mui-language-packs-for-windows-8-1-windows-8-and-windows-7/
0
 
GlingoCommented:
Oh and on that link you can also download german for Windows 8, so maybe you'll be able to install it from there :)
0
 
GlingoCommented:
Also once you've downloaded the file it looks like you should rename the .cab file to .mlc (it's a L not a I)
0
 
steve_yorkAuthor Commented:
I'm on windows 8.1

only problem is, that site is blocked by our firewall :( - never rains but it pours round here.
0
 
steve_yorkAuthor Commented:
Right, I've got a .cab file off the Windows 8 disk :)

However, I've renamed the file to .mLc (mlc) but when running I get:

The language cannot be installed on this computer.
0
 
GlingoCommented:
Hum, I suppose you downloaded the appropriate version (32 or 64bits and Windows 8 or 8.1)?
0
 
nobusCommented:
i tried to install  dutch language on an english version of Win8.1, and while it installed seemingly ok, most of the metro tiles were still in English
after a couple of days (and updates) several got to dutch, but not all
btw have you checked the "copy settings" in the regionand language>administrative settings tab?
look here at Mc Knife's answer :  http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_8/Q_28511329.html
0
 
GlingoCommented:
Any update on this issue Steve?
0
 
steve_yorkAuthor Commented:
After checking the right versions again, it was my error in assuming that I had chosen the right one.

This is all setup now so thank you one and all.

Steve
0
 
GlingoCommented:
Great, glad to help :)
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 12
  • 11
  • 6
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now