Code 38 - Driver still in memory with Server 2012 R2

I set up a Server 2012 R2 server with the following Roles and Applications.

Dell openmanage
Symantec BEX 2014
SQL 2008 R2
PowerChute Business Edition Server
Dell SonicWALL UMS
SonicWALL Directory Connector

The Issue is, when i plug out the Seagate UAS 3TB external drive and plug in the other drive for the next days backup, the new drive shows a Code 38 error in device manager, stating that the previous drive is still in memory.
After a reboot , the new drive is detected until the next drive is plugged in.

This happens every time with all 4 exact same drives.

I have set up another Server 2012R2 server with BEX 2014, plugged in and swopped the drives with no issues.
I have also plugged and swopped the drives in a Windows 8.1 laptop (same driver version as the 2012 R2 driver).


I have also tried deleting the drivers and redetecting them, same issue.
When disabling the wrongly detected device and enabling it again, it automatically reboots the server.


Any good ideas would be appreciated.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

There is a difference between drive and driver....

Was the drive ejected ("safely removed") by backup exec? (I hope i decoded your abbrecviation "BEX" right?
jrobbertseAuthor Commented:
gheist... the drive cannot be safely removed at that time.
Please look at the image 5.png.

The issue is, we have this setup working at 100's of clients, but this is the only client where this is a problem.
I am just posting this question here to get a fresh eye on the problem.

We have had quite a few people looking at this, so the obvious have been checked.
Maybe take care to attach image 5.png?
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

jrobbertseAuthor Commented:
For some reason the attachments aren't included anymore, i uploaded them 2 days ago, anyway. here they are.
did you install Kaseya endpoint.... ?
jrobbertseAuthor Commented:
Yes, the Kaseya client is installed, the same one we use on 100's of clients with server 2012 R2 and BEX, with no issues so far.
I would recommend to remove device with exclamation mark and 1) rescan for new hardware, filing that 2) remove driver and reboot.
jrobbertseAuthor Commented:
I have removed all hidden devices previously and scanned for new devices, same issue.
After a reboot it normally detects the new drive because then the driver is no longer in memory, so i am trying to get a solution where i do not have to reboot the server.

to reveal the hidden devices i also ran the command "set devmgr_show_nonpresent_devices=1" as well as the "show hidden devices"option in device manager.

Trust me when i say, all obvious solutions have been looked at.
jrobbertseAuthor Commented:
KB2911106 and KB2919355 have also been installed, associated with this problem.
Still having issues.
You can show hidden devices in device manager from menu - any of thoes in yellow state? Like ones around antivirus?
jrobbertseAuthor Commented:
the hidden devices are not in yellow state now.
what do you mean by "like ones around antivirus?"
like antivirus kernel drivers (which somehow control disk accesses etc)
is USB port well powered? i.e show devices by connecion and it is alone on usb hub?
jrobbertseAuthor Commented:
The drives are connected via their own USB 3 card (which has also been replaced)
There are no AV policies in place to control disk access.
jrobbertseAuthor Commented:
The problem only happens a few hours after the server has been rebooted.
Once the server has been rebooted, the drives can be swopped without any problems.
The issue only comes in after a few hours or a day, then when they was to plug in the next drive for that day's backup, then it fails to detect the drive and the error code is "code 38" as seen in the screenshots.
Is it same drive you connect to other servers to test? i.e. if there is any firmware issues...
jrobbertseAuthor Commented:
The same drives did not show the same issues when we replicated the server config on another Dell server.
This time we only installed Server 2012 R2 and Bex 2014, but those drives worked every time.
Me out of ideas....
jrobbertseAuthor Commented:
Is there perhaps someone else that can assist?
This is one of the errors in the event log when the new drive is plugged in.
This is off course part the Code 38 problem.
Device USB\VID_0BC2&PID_AB31\MSFT30NA7E1ZQL had a problem starting.

Driver Name: uaspstor.inf
Class Guid: {4D36E97B-E325-11CE-BFC1-08002BE10318}
Service: UASPStor
Lower Filters:
Upper Filters:
Problem: 0x26
Status: 0x0
I'd wait for 24h then ask moderators to call more attention to the question.
It is all HCL drivers (actually builtin in windows) - so it should not fail ever.
Gary PattersonVP Technology / Senior Consultant Commented:
We have no way of knowing what is "obvious" to you.  We know nothing about your background, training, or troubleshooting skills, and even then, even the best of us skip a step sometimes.

So, anyway, it sounds like the USB device isn't being properly ejected.  Safest procedure is to first take the drive Offline in Disk Manager, and then "Eject" the device using the system tray app, for example.

If you can't safely eject, you really need to troubleshoot that problem - something is holding files open on that device.  I'd use Process Explorer (make sure you run it as Administrator) to track down the offending process.  Most common offender is an AV program.  Exclude the USB drive letter(s) from your AV scanning, shut down your AV scanner, or make sure no scanning is going on prior to ejecting.

- Gary
jrobbertseAuthor Commented:
Ok, so the problem was the iDrac cache that picked up as drive F briefly at bootup in Explorer, then disappears.
I only saw this because i opened My Computer directly after the server booted up.
As soon as i changed the one drive from F: to K, everything worked.

The drives were, F: , G:, H:, I:
So every time F was swopped for G, or I was swopped for F, the problem occured. Which caused the illusion that it was intermittent.

Thanks for the help :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.