Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cannot remote desktop to Windows XP machines

Posted on 2014-10-14
11
Medium Priority
?
175 Views
Last Modified: 2014-10-28
Hello,

I am working with a very old network and have slowly been updating the computers. However, do to backward compatibility with older software, some workstations are still running Windows XP.

I would like to RDP to the Windows XP machines. However, when I try to do so, I cannot connect. It is not a user access issue as I do not even get prompted for user name and password.

On the same network, I am able to RDP to the server, so the problem lies specifically with XP clients.

I have disabled the firewall as well as the Anti-Virus (McAfee), but still no luck.

All computers are on the same subnet. I can ping all of them (including XP clients).

RDP has been enabled on the Windows XP machines.

Any suggestions or ideas as to how to fix?

Thanks,

Mark
0
Comment
Question by:mbudman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 13

Expert Comment

by:Rizzle
ID: 40381236
Does it work via hostname or ip? Can you post a screenshot of the error you get when toy attempt the RDP connection to the XP machine?
0
 
LVL 29

Expert Comment

by:Dr. Klahn
ID: 40381343
McAfee can not be completely disabled once it has been installed, and in my experience it can be problematic.  Try an experiment with another XP machine which has never had an antivirus installed.
0
 
LVL 29

Expert Comment

by:Dr. Klahn
ID: 40381344
... and check the Windows Firewall settings.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 1

Author Comment

by:mbudman
ID: 40381359
Firewall is off.

The only thing that might play a factor is that the computers have both a wireless and built in network cards.

Only one of the two network cards is active as the second one (depending on how computer connects to the network) is disabled.

Thanks.
0
 
LVL 4

Expert Comment

by:Nice-Ghaza
ID: 40381582
Dear. your system  window XP they have  administrator  Can you use this Account .if they don't have  Password . Please write the Administrator Password. and try it Thanks
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40381738
Just to clarify you have enabled RDP with the firewall service on and then you have given yourself permission to RDP to these machines? Is there anyway in mcafee to enable the firewall service but an exclusion for remote access port 3389
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40381742
0
 
LVL 1

Author Comment

by:mbudman
ID: 40382374
I uninstalled the anti-virus program and rebooted. Still no luck. it seems to be components specifically related to Windows XP.

Firewall service is off. RDP is enabled as well as all the users have been granted permission.

Running netstat -a does not show that it is listening on port 3389 (on computer that I would like to remote desktop to) even though service is running
0
 
LVL 29

Expert Comment

by:Dr. Klahn
ID: 40382928
Check Control Panel / Administrative Tools / Services and confirm that the Remote Access services are all set to Automatic and are Running.

new-1.gif
Not like the XP system shown above!

If they are not, set them to Automatic and reboot, then check again.

Also download a copy of Microsoft Technet TCP View, and see if the services have the proper ports open.  TCP View is easier to read than netstat, and shows operation in real time.

Side note:  Uninstalling McAfee does not get it completely out of the system.  It is a lazy uninstaller and does uninstall most of it, but significant chunks remain that are supposedly deactivated.  To confirm that McAfee is not the problem, start with a clean system that has never had an antivirus installed.
0
 
LVL 1

Accepted Solution

by:
mbudman earned 0 total points
ID: 40382950
I found the issue;  the previous tech changed the rdp listening port;  once restored to 3389 it worked
0
 
LVL 1

Author Closing Comment

by:mbudman
ID: 40407992
I discovered the resolution, and no other users suggested that this could be a problem
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question