User Account Control

I have a set of users who all use a particular application to do their work. They all use Windows 7 SP1 64-bit Professional. The application in question will not update unless these users are local administrators on their machine and UAC is deactivated.

A couple of these users have abused the ability to install programs onto their computer and it's becoming a problem.

Is there a way to selectively deactivate UAC by path or application such that it will still update, but keeping the usual UAC activity normal?

I have attempted to make the user an owner in the folder that the program is in, and I used this:

http://social.technet.microsoft.com/wiki/contents/articles/19900.how-to-make-uac-exception-for-applications-in-windows-vista-windows-7-and-windows-8.aspx

however, it did not achieve the desired result.

Thank you!
flipm0Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
You should never disable UAC - to do so invites problems.

If the application vendor cannot provide a fix, look at a different application. Everything we run for all our clients runs with UAC enabled.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jcimarronCommented:
flipm0 --
Here is a detailed explanation of how to create elevated shortcuts for programs that you wish to open without involving UAC.
http://www.thewindowsclub.com/create-elevated-shortcut-run-programs-bypass-uac

 For other programs I suggest you use the Default setting in the User Account Control Settings window.  That is the notch second from the top in the slider.
0
JohnBusiness Consultant (Owner)Commented:
@flipm0  - Thank you and I was happy to help you with this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.