Solved

Remove assigned POP and IMAP from Exchange 2013 Certificate

Posted on 2014-10-15
3
550 Views
Last Modified: 2015-02-10
Hello Experts,
I am new to certificate creation editing and management, and I recently added services to our exchange certificate which ended up breaking emails. A friend fixed the smpt & IIS side and was able to remove the IIS and SMTP services from the certificate, but the IMAP and POP services remain.
I tried:
Disabling the services on a Certificate without removing it,
Enable-ExchangeCertificate -Thumbprint 0000000000000000000000000000000000000 -Services 'None'
This did not work.
To fix this from my readings on the web, I think I will need to recreate the self signed certificate and move the POP and IMAP services to them?  will this work, do I have to do this when. We are running Exchange server 2013 (on Server 2012R2), with the transporter located on an SBS 2008 running Exchange 2007
0
Comment
Question by:Hec C
  • 2
3 Comments
 
LVL 12

Accepted Solution

by:
Md. Mojahid earned 500 total points
ID: 40383623
Following info applies to your case:
Source: http://technet.microsoft.com/en-us/library/aa997231.aspx

"The Enable-ExchangeCertificate cmdlet is additive. When you specify a subset of services for which a certificate is enabled, the services that aren't specified aren't removed from the Services property. If you don't want to use an existing enabled certificate for Exchange services, you must enable another certificate, and then remove the certificate you don't want to use."

So you would enable the certificate for services that are required from the Exchange Mgmt Shell. For example:
Enable-ExchangeCertificate -Thumbprint 5113ae0233a72fccb75b1d0198628675333d010e -Services POP,IMAP,SMTP,IIS

Then remove the certificate that was associated with the services that are not required. For example:
(most likely the same certificate as in the previous example, your thumbprint will be different)
Remove-ExchangeCertificate -Thumbprint 5113ae0233a72fccb75b1d0198628675333d010e

That should do it. Might need to restart IIS:
iisreset /noforce
0
 

Author Comment

by:Hec C
ID: 40602019
I deleted the certificate then recreated a self signed one, this removed all the services associated to it, which was what I was after. Thanks for your assistance.
0
 

Author Closing Comment

by:Hec C
ID: 40602025
Simply deleting then creating a new self signed certificated solved this particular issue.
0

Featured Post

Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now