Solved

Google Chrome "Aw Snap" error

Posted on 2014-10-16
21
1,082 Views
Last Modified: 2014-10-20
Hi,

My Google Chrome keeps crashing for two weeks now. I tried all the suggestions from the google support (here). I also tried to add the "--no-sandbox" in the target of the Chrome shortcut.

I also uninstalled Chrome, cleaned my registry, reboot, install Chrome again, same crash.

And I get this crash on every pages even on the "plugins" and "settings" pages.

Any help would be appreciated!
0
Comment
Question by:Glingo
  • 11
  • 10
21 Comments
 
LVL 70

Expert Comment

by:Merete
ID: 40385722
Any errors with the crash?
open start orb in the search type >  reli  < open the reliability monitor history at the top

When you uninstall Chrome go to your Appdata and delete the folder Google.
C:\Users\User\AppData\Local\Google <<  rename  the Google Folder to old so you can get your bookmarks back  then delete it
or delete the whole folder.
Reboot
This is just to show the contents of the Google Folder. Always remove the  empty folders for uninstalled programs  if any are left behind they can store a file like a .dat.
Delete Google FolderThere is also your TEMP
Check your taskmanager what is running anything related to Google?
Is this windows 32 or 64?
Install the 32 bit Google Chrome
In your firewall add Google to exceptions
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386158
Hi Merete,

Thanks for your feedback, it's a Windows 8 64bits, I'll try to rename the Google folder and add firewall exceptions. About the TEMP I ran a ccleaner after uninstalling Chrome so I think I got this covered :)
0
 
LVL 70

Expert Comment

by:Merete
ID: 40386207
Thank you Glingo ,  windows 8 shouldn't differ from windows 7.
I used to offer Ccleaner but have been kind of warned not to as it can damage the registry if not used wisely when deleting everything it finds.
It should be setup first here's Piriform guide for it
http://www.piriform.com/docs
with pictures
http://www.technorms.com/5386/ccleaner-usage-guide
All the Best
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386214
Ok so I uninstalled Chrome, deleted all Google related folders in the appdata and program files folders, also my temporary files and folders, cleaned the registry, reboot, install Chrome 32bits, checked firewall settings, opened Chrome and got this error:

Chrome.JPG
I tried to browse to other pages, same error :/
0
 
LVL 70

Expert Comment

by:Merete
ID: 40386254
Ok that's a problem
could be malware?
If I may
It used to work and then stopped?
Does your other browsers work?
Firefox internet explorer?
 Disable Hardware rendering in chrome settings using the Chrome flags
 Close the browser and restart it
http://www.sevenforums.com/tutorials/271264-chrome-gpu-hardware-acceleration-turn-off.html
Have you been tinkering with Chrome and how many cores it uses?
What Does “Dual Core” & “Quad Core” Mean
scroll down to
Controlling & Monitoring Cores
http://www.makeuseof.com/tag/what-does-dual-core-and-quad-core-mean-makeuseof-explains/
I see in your first comment> "--no-sandbox" in the target of the Chrome shortcut.
follow this and let me know if it solves it
How to fix Google Chrome Blank page(s) problem.
http://www.wintips.org/fix-google-chrome-blank-page-problem/
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386276
I don't think it's a malware, I clean my comp every week with Malwarebyte, scanned it yesterday and it found nothing, I don't have any weird processes running nor auto-startup entries. My other browsers work properly. I didn't modified anything with chrome cores settings.

I'm going to try your suggestions and get back to you.
0
 
LVL 70

Accepted Solution

by:
Merete earned 500 total points
ID: 40386289
I thought as much/ what if any stopped it from running? broke it?
Is Chrome your default browser?
Current Runtime Release Version
Flash Player for Windows 8.1 (ActiveX) 11.9.900.152
http://helpx.adobe.com/flash-player/release-note/fp119win81.html

I just found this sigh it's related to flash
He's dead jim / Aw snap! when Flash is enabled.
https://productforums.google.com/forum/#!topic/chrome/QNApCV6Tmvg
The fact it is only Chrome is so odd as Chrome has it's own pepper flash.
I'm not going to put you through all that have done this so many times, there is a simple things you can try, these are three I have narrowed it down to
when you go to a page note it shows https in the browser take that s off and return the url and  try open that web page without the S
https://www.youtube.com/  to  http://www.youtube.com/
Could be the active x filtering
Is your windows adobe flash up to date as well?
Did you recently upgrade to windows 8 to windows 8.1
Some users have reported that updating Windows Defender has resolved the issue.
Try launching it in windows 8 mode
side idea
Google Chrome 64 bit Windows 8 Free Download
http://www.chromestory.com/download-google-chrome-for-64-bit-windows-8/
Take a look here
Chrome secuityedited
How do I fix almost all Shockwave and Flash Player issues?
You can resolve almost all difficulties encountered with the Adobe Shockwave and Flash Players by taking the following steps:
For Windows:
Uninstall Shockwave Player via the Control Panel. Go to Add/Remove programs, and choose Macromedia or Adobe Shockwave Player.
To remove the Flash Player download the uninstaller here:
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14157&sliceId=1
*IMPORTANT; After uninstalling both Players, restart your computer.
Then reinstall both the Shockwave and Flash Players here:
http://www.adobe.com/downloads/
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386408
Tried to access the Chrome flags but I was also getting the error on this page.

I tried out different compatibility settings without luck.

Then I tried again the -no-sandbox, and Chrome worked properly, but I was still not sure of the result (on one of my previous attempts the -no-sandbox worked for a day then stopped working).

The annoying thing was Chrome wasn't importing my sync bookmarks with the -no-sandbox, so I tried again without it and now Chrome is working and imported all my bookmarks :|

Then I made a reboot. Started Chrome, it opens properly but blank page, not loading anything, I knew from experience it was a compatibility setting, so I checked it and it was activated (XP SP3), so I removed it, launched Chrome again: he's dead Jim error^^

So I added again the -no-sandbox and it's working, but if I remove it it doesn't.

Just FYI, when I got this problem I thought about Flash and completely uninstalled it. Also in my previous attempts I tried with the 64bit version and I was also getting the aw snap error. And also I desactivated the setting for letting Chrome running in the background and google now notifications center.

I'll try to reinstall Flash and Shockwave and I'll get back to you, and many thanks for your help :)
0
 
LVL 70

Expert Comment

by:Merete
ID: 40386434
Thanks for the detailed explainations that helps me a lot.
Glingo it amazes me how many different flash Chrome problems there are.
This sounds like a permissions problem>then I tried again the -no-sandbox, and Chrome worked properly, but I was still not sure of the result (on one of my previous attempts the -no-sandbox worked for a day then stopped working).
So I added again the -no-sandbox and it's working, but if I remove it it doesn't.
Dont worry about uninstalling flash try this instead,
Allow unsandboxed plug-ins to directly access your computer
https://support.google.com/chrome/answer/2898352?hl=en
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386553
To answer your questions:

- Chrome isn't my default browser (it was when it was working :p)
- When it's not working there's no difference if I try to go to the http url instead of the https
- I'm not using windows defender (and also when I make my tests I always try the same test with my AV disabled.
- I'm running Windows 8, didn't updated to 8.1 yet.
- The problem is also occurring in Windows 8 mode.
- Tried to allow unsandboxed plugins to directly access the computer but that didn't solved the issue.
- Also with the no-sandbox mode I was able to access the plugins page, so I tried to disable all plugins but the problem still occurs if I'm not using the no-sandbox.
- Also if I reboot the computer, the -no-sandbox is still in the shortcut properties but the problem occurs anyway. I have to remove it, save, then add again the -no-sandbox and then it's working :/

I'm going to try to install Flash and Shockwave (already uninstalled them).
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 3

Author Comment

by:Glingo
ID: 40386560
And here are the version infos:

Google Chrome      38.0.2125.104 (Official Build 290379) m
OS      Windows
Blink      537.36 (@183466)
JavaScript      V8 3.28.71.15
Flash      15.0.0.189
User Agent      Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.104 Safari/537.36
Command Line      "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -no-sandbox --flag-switches-begin --flag-switches-end
Executable Path      C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Profile Path      C:\Users\Aurel\AppData\Local\Google\Chrome\User Data\Default
Variations      d0bd833b-3f4a17df
f2d919bf-3f4a17df
74785582-3f4a17df
8afebf76-164ff01c
c70841c8-a2567007
195ce1b5-d93a0620
9e5c75f1-4572ea13
f79cb77b-3d47f4f4
24dca50e-837c4893
ca65a9fe-91ac3782
8d790604-9cb2a91c
4ea303a6-3d47f4f4
d8f57532-3f4a17df
61544484-ca7d8d80
b310ecc7-ca7d8d80
9736de91-ca7d8d80
b2612322-8a9180b2
ea1014b7-dd21eb5a
5a3c10b5-e1cc0f14
244ca1ac-4ad60575
f47ae82a-746c2ad4
5e29d81-f23d1dea
3ac60855-486e2a9c
246fb659-d7f6b13c
f296190c-90ee1655
4442aae2-4ad60575
ed1d377-e1cc0f14
75f0f0a0-d7f6b13c
e2b18481-6754d7b7
e7e71889-4ad60575
cbf0c14e-bf3e6cfd
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386568
I also tried to go to chrome://conflicts, it didn't found any.

And here is the chrome://gpu settings:
gpu.html
0
 
LVL 70

Expert Comment

by:Merete
ID: 40386608
You got me  don't know what this is>Chrome/38.0.2125.104 Safari/537.36<< safari?
 Google Chrome Dev Release
Command Line      "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -no-sandbox --flag-switches-begin --flag-switches-end
The last Idea I had was your profile maybe corrupted
I believe you had a memory problem and Google Crashed and then all the trying to fix may not be resolved if you dont have enough memory?

Google Chrome errors and crashes
https://support.google.com/chrome/table/3097302?hl=en&ref_topic=3421642
Google Chrome errorsawe smapHe's Dead JimYour thoughts?
0
 
LVL 3

Author Comment

by:Glingo
ID: 40386703
Well about the safari thing I don't know, never installed Safari on this computer.

About my profile behing corrupted I would agree, that's what I thought when it started happening, but when making a fresh install after cleaning all Google files and all Chrome is obviously creating a new profile, but Chrome still crashed at the first launch after the install.

And about the memory I think Chrome is bull****ing me, maybe if it was only sometimes, but I get this error even if I have nothing else running, I have 4Gb of RAM and I like my comp to run smoothly so I almost have no applications running in background (anti-virus, smart gesture for touchpad, Realtek audio manager and intel HD graphic that's all).

I really don't get why Chrome is crashing when I don't use the no-sandbox.

Also I tried to reinstall flash and shockwave and I still get the error :p
0
 
LVL 70

Expert Comment

by:Merete
ID: 40387754
Morning here in Australia, well lets see if we can get to the bottom of it.
What results did you see in the reliability monitor history?
Have you looked on your events, applications errors? In control panel administrative tools event viewer
Post back any snaps if you don't understand them.
Event viewerEvent Viewer applications errorsSomething happens when you load a page, and what page is that please?
What is your system model brand  all those details please. I take it is a laptop as you mention a touchpad.
How old is it?
Lets see if we can workout if it is hardware or software.
Sandboxing helps prevent malware from installing itself on your computer or using what happens in one browser tab to affect what happens in another.
When you first run Chrome  does  it crash/lockup? stop responding and throws those errors?
 just opening it or when you use the new tab?
Just to determine if the page your opening is the problem or if it's Chrome and windows?
do you have a homepage or just open/start to a new tab?
does it open to your last session?
Have a look in the Chrome settings
I have it set to open/start in a new tab, no home page
 Chrome settings When you start Chrome have a look at your taskmanager and how much cpu utilisation is going on. How high is it?
How to Use the New Task Manager in Windows 8
What is running besides Chrome? Is Safari listed there running?
Become familiar with your running tasks so in the event of a problem you check what is running and stop it.
Chrome in TaskmanagerOpen View and select columns here you add more details sometimes I need to check the handles and thread, this shows me what programs are using my cores and how much
Have you checked your laptop for dust in the vents.
Dust can cause the Laptop to over heat and then cause lockups crashes on load.
Have you tried system restore back to before this started?
Can you recall what you did when this started?
Safari is a web browser developed by Apple Inc. and included with the OS X and iOS operating systems?

A version of Safari for the Microsoft Windows operating system was first released on June 11, 2007, and supported Windows XP Service Pack 2, or later,but it has been discontinued.
Safari 5.1.7, released on May 9, 2012, is the last version available for Windows. Still outdated ..
Apple provides it
Safari 5.1.7 for Windows contains improvements to performance, stability, compatibility, and security, including changes that:

You have Windows 8  x64bits ?
In your control panel uninstall a program uninstall Safari since you don't use it.
And it's likely not really compatible with windows 8.
Uninstall any programs you don't use,  this will also stop any background services, check for any programs that came with your system and maybe trials of mcfee or some form of antivirus?
Have only one AV running at any time.

With the corrupted profile I am referring to your windows account/profile.

You have not updated your 8 to windows 8.1?
Update to Windows 8.1 from Windows 8
http://windows.microsoft.com/en-au/windows-8/update-from-windows-8-tutorial
Update to Windows 8.1: FAQ
http://windows.microsoft.com/en-AU/windows-8/upgrade-to-windows-8

There is windows lockups and then there is program crashes.
Crashes are caused by many things, but the bottom line is  how your windows/ram utilises the power and runs these programs, windows is talking to this program from the registry.
If there is any inconsistencies there windows cannot talk to it.

This computer I'm on has windows 7 prof  x 32  sp1  with 4 gig of ram, 3 GHz dual core 850w power supply nvidiea 250 1 gig of ram on video card.
My windows 7 x 64 sp 1  has 8 gig ddr3 ram 3.4 GHz. quad core 850w power supply  nvidia 680 OC with 3 gig of ram
I built both them so they run better than any OEM.
Your computer is windows 8 x64  and has 4 gig of ram. home / pro ? how big is the GHz
if your GHz is under 3 and you have 4 gig of ram with 250 watts PSU
4 gig of ram in a windows 8 x64 may not be enough  as you install software and update stuff it uses more and more power, there should be balance between these three.
So when you give me your computer brand and model I can look up your system specs

Your thoughts.
Chrome-new-tab-start-page.JPG
0
 
LVL 3

Author Comment

by:Glingo
ID: 40391456
Hi Merete,

Here is the error I get in the event viewer:

Chrome2.JPG
When the sandbox is active Chrome crashes on any page, even on the settings page (chrome://settings), and it doesn't lockup it just shows the awsnap or he's dead jim errors, and it's set to open a new tab, no home page.

My comp is an Asus Zenbook UX31A with a Core I5-3317U (1.7Ghz) and 4GB of RAM, running Windows 8 Pro 64Bits (hard drive is a SSD)

I just reproduced the crash an at the moment my CPU usage is 8%, and RAM is 30%.

My comp is not over heating, didn't tried a system restore, and I did nothing special when this started (didn't installed any new software...)

I never installed Safari on this computer, so there is no safari process running in the background.

I have only one anti-virus installed (Avast).

I really don't think this is hardware related tbh.

It's working now with the -no-sandbox setting so I think I m going to mark  this as solved waiting to see if you have some last suggestion (and yeah I'll update to 8.1 ;) )
0
 
LVL 70

Expert Comment

by:Merete
ID: 40391598
Thanks Glingo
the error points to the latest version of Chrome/ C programfiles x86
chrome://help/
Chrome versionThe fact you have windows 8 not windows 8.1 could be related if you installed Chrome x64 for windows 8.1
http://www.chromestory.com/download-google-chrome-for-64-bit-windows-8/
When you uninstalled it did you also delete the registry key for Chrome? so that there was no residual of the previous?
in the run type regedit press enter
 expand HKEY_CURRENT_USER then open Software look down to Google and see Chrome and the many other components, could be some of these are not running nicely with Google. A conflict?
If you have the Google toolbar might be a good idea to uninstall Chrome and the Google Toolbar everything related to Google then delete the Google Key
HKEY_CURRENT_USER\Software\Google
Google reg key all applicationsI understand your desire to just get on with using it with no sandbox, but it would have been nice to get the bottom of the problem.
I wouldn't use Sandbox anyway as it restricts things.
The Chromium Projects
Sandbox  http://www.chromium.org/developers/design-documents/sandbox
Sandbox FAQ
What is the sandbox
http://www.chromium.org/developers/design-documents/sandbox/Sandbox-FAQ
Regards Merete
0
 
LVL 3

Author Comment

by:Glingo
ID: 40391630
In my multiple attempts to make Chrome works I tried both  32 & 64bits versions, got the same error.

I'm running the same version as you do, and as you can see Chrome is the only soft from Google that I have installed:

Chrome.JPG
0
 
LVL 70

Expert Comment

by:Merete
ID: 40391661
Well I believe it is a slow computer that is causing it as shown here Chrome has become completely unusable
My comp is an Asus Zenbook UX31A with a Core I5-3317U (1.7Ghz)<<that is 1.7Ghz per core and still only uses that
 and 4GB of RAM, running Windows 8 Pro 64Bits (hard drive is a SSD)
contributing factors 4 gig of ram is not much and using an SSD.
Take a moment to see how Chrome is using your dual core or quad core.
What Does “Dual Core” & “Quad Core” Mean?
http://www.makeuseof.com/tag/what-does-dual-core-and-quad-core-mean-makeuseof-explains/
Like a Sata HDD it occasionally requires a defrag and a disk cleanup
With the SSD Take a moment to read this as well, do you have the Trim /  Cleanup capable SSD? with your HP and is it enabled?
How to Enable TRIM Support for Windows 7 and 8
http://www.buildcomputers.net/trim-support.html
How to: Enable Trim on Windows 8 SSD YTB video
https://www.youtube.com/watch?v=fWPjFZv_eII
The problem is that capacity in solid state drives can also play an important role in the performance of the drive as well.
TRIM / Cleanup
A process of garbage collection can be used within the firmware to try and cleanup the drive for improve performance.
http://compreviews.about.com/od/storage/a/SSD-Buyers-Guide.htm
0
 
LVL 3

Author Comment

by:Glingo
ID: 40391710
It's not a performance issue, Chrome was working properly, and when I mean properly i mean that I could have 20 tabs open and it would run smoothly, and I can still do that with the -no-sandbox launch setting.

And yeah 4Gb is not that much but it is enough to work with multiple word documents open, chrome running, outlook open and multiple mremote connexions open, so if I can run all of this without any slowdown it should be enough to run chrome without any application running :p

It's clearly a problem with the sandbox, I sent a report to google support about this, I'll post here their reply.

Tanks for all your help Merete :)
0
 
LVL 70

Expert Comment

by:Merete
ID: 40391787
yes Please!!!  just post it back here if you could, I would really appreciate your updates from Google Chrome  support, just for my knowledge-base  ;)

Thanks for the points  Glingo you had a lot of choices. It was my pleasure to help where I can.
All the best,
regards Merete
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

A list of useful business intelligence software.
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
This video shows how use content aware, what it’s used for, and when to use it over other tools.
The viewer will learn how to create multiple layers to apply various filters and how to delete areas from each layer’s filter.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now