Global Address list is not updated from exchange server 2013

dear all,
since two weeks almost,
the GAL in my outlook is not updating anymore.my mailbox is in cached mode. if I remove the cache mode then i will see the updated GAL.but i want to keep the cache mode for its effects on performance.
this is happening with all the users in my company.still i noticed that when i create i new profile on the PC for any user,he sees the updated GAL which could mean that the ost file is corrupted.but with all users!!!!!!????

i have outlook 2013 and i tried to download the GAl manually but it is giving me an error"operation failed,an object cannot be found" and i tried on many users and i always get the same result.i have made changes one week ago and still they are not appearing.
i appreciate a solution that i can implement on all users from a global point and not individually.
Thnank you
nayef hamzehAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Miguel Angel Perez MuñozCommented:
Could you check your OAB virtual directory? Run on powershell get-oabvirtualdirectory
0
nayef hamzehAuthor Commented:
alo i need to mention that i have a DAG.
i ran the command and it gave me two records (one for each server)
with a url .
i opened the url and after entering my credentials ,it is blank,is this normal?
i am doubting that this is a permissions issue but not sure what exactly.
0
Miguel Angel Perez MuñozCommented:
I´m not sure, but URL without 404 error is good signal. You can try to refresh: http://jeffwouters.nl/index.php/2012/09/powershell-howto-update-the-gal-and-oab-in-exchange/
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

nayef hamzehAuthor Commented:
Miguel,
i already ran the two first commands but the last one concerning filedistributionservices gave an error.
as i believe in 2013 there is no more filedistributionservice .maybe the article was for exchange 2010.
but still nothing changed in my GAL.the weird is that from outlook when i choose all users list,it comes updated.when i select GAL,it is two weeks old almost.
0
Simon Butler (Sembee)ConsultantCommented:
To be picky, you aren't talking about the GAL, but the Offline Address Book. The GAL is the live information, the OAB is an offline version of it, which is generated daily.

First - on your desktop the OAB is not in the OST file, but stored in a separate file with the extension *.oab. Deleting that will force Outlook to download the full OAB.

Second - the OAB is actually generated in two formats - a full OAB and an incremental OAB. It sounds like the incremental OAB is not working correctly.

First thing I would try is to force an update

get-offlineaddressbook | update-offlineaddressbook

Wait 20 minutes or so, then restart Outlook. Wait five minutes and check the GAL again.

Simon.
0
nayef hamzehAuthor Commented:
dear simon,
i already ran the command 3 days ago and nothing changed.
i deleted the OAB files from my PC and restarted outlook and now the list id updated.
but i have this issue with all employees in my company.
is there a different solution rather than deleting OABs for all users.
0
Simon Butler (Sembee)ConsultantCommented:
That means the incremental files are broken.
The only way I know of to correct that is to create a new OAB, delete the old one and then set the new OAB on each mailbox database.

http://blogs.technet.com/b/exchange/archive/2013/01/14/managing-oab-in-exchange-server-2013.aspx

Simon.
0
nayef hamzehAuthor Commented:
well thank you guys..
it was solved by installing the CU6 on exchange servers..i don t know if it solved it or it merleey reset some settings that were corrupted...but it is working now..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dsnegi_25decCommented:
Hi ..

OFFLIINE ADDRESS BOOK Troubleshooting :-
The offline address book can be a beast to troubleshoot. I have found success many times by following a procedure that I have pieced together. My hope is that it proves helpful to others that run into similar issues. These are the steps I follow when troubleshooting OAB issues for Exchange 2010 environments.
 
Check the following for misconfigurations
      How is the OAB distributed?
      Check for web based distribution
      Note the cas servers
      Note the OAB generation server
Check on each of the distributing cas servers for IIS redirects or incorrect auth or SSL settings on the OAB virtual directory
Correct settings should be
SSL – none, ignore; Auth – windows auth; redirect should be off
Checktime stamps on the file locations on the distributing cas servers
c:\program files\microsoft\exchange server\v14\client access\oab\***
Check time stamp on the OAB generation server
c:\program files\microsoft\exchange server\v14\OAB***
Run the following cmdlet on the generation server
      Update-OfflineAddressbook “Default offline address book”
Check the event viewer on the generation server for events
Check the time stamp on the OAB generation server
c:\program files\microsoft\exchange server\v14\OAB***
If you see an updated timestamp then proceed with the below command for each distributing cas server if not then check event viewer
      Update-FileDistributionService “CASServerName” -Type OAB
After running this cmdlet check the time stamps on the file location of the distributing cas servers
if all look updated then proceed with testing the download of the OAB via outlook.
Troubleshooting External OAB access is similar but also make sure that your Autodiscover is successful
If these do not fix the missing items issues you will need to proceed by enabling reporting for oal generation
      Set-EventLogLevel -Identity “MSExchangeSA\OAL Generator” –Level Expert
Check the event viewer for warnings/ errors ( 9325/9327/9320)
Run the following cmdlets on the OAB generation server
      Update-OfflineAddressbook “Default offline address book”
Recheck the event viewer
Run the following cmdlets on the OAB generation server
      Update-FileDistributionService “CASServerName” -Type OAB
Remember to set the reporting back to lowest when done
      Set-EventLogLevel -Identity “MSExchangeSA\OAL Generator” –Level lowest
0
nayef hamzehAuthor Commented:
the solution that worked was to install Cumulative update6.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.