Solved

Windows 7 File Sharing Windows XP Issues

Posted on 2014-10-16
12
356 Views
Last Modified: 2016-10-27
Hi everybody,

At wits end on this issue.

Customer has a small network of 6 computers. 2x windows 7, 4x windows XP, 1x virtualized Windows NT4.0 Server.

One of the windows 7 machines is configured to act as a file server for the rest of the network,

It has 4 different shares containing around 2.5TB of files. It also has VMware workstation installed and hosts a virtual server running legacy application on Windows Server NT 4.0. There is no domain however, all computers in a workgroup and access the legacy application hosted on the NT server virtual.

All shares are mapped as network drives on the other computers.

Consistently having issues making the windows XP machines stay connected to the Windows 7 file server with their mapped drives. Its making me batty.

First, it was something which was happening over night only, works all day, but left over night and in the morning all the windows XP machines would report "Local device name already in use" error message. Meanwhile, the Windows 7 machines still access the shares no problem.

Restarting the XP machines wouldnt fix the issue either. They would still report local device name already in use after a restart. Only rebooting the Windows 7 machine hosting the shares would resolve the issue, and that meant that the VM would have to get shut on and off all the time which we don't like at all, the application database it hosts is old and seems fragile.

My first step was to look at how the sharing had been implemented. I turned off password protected sharing when first setup, so all computers were just connecting to the shares without a username and password. I though this might be a problem so I enabled password protected sharing and created an unique login account for each network device on the server.

So each windows XP machine now maps the network drives with its own unique username and password such as "desktop1" "desktop2" ETC. This seemed to calm things down, the XP machines stayed connected for around 2 or 3 weeks without dropping off until all of a sudden it started happening a lot, not just during the night, but throughout the day. One of the XP machines reported a unique error that the others had not. It was saying the cause of the issue was resource shortage, rather then the name in use error the others had. I discovered some log entries in the event log on the Windows 7 host regarding IRP Stack size. We use Acronis True Image, and I have stumbled accross issues in the past were this applications presence has messed with the IRPStack and caused these sort of problems.

Eureka, I figured that possible the issue was allways regarding the IRP stack, and that even the windows XP machines reporting device name in use were doing so as a result of this IRP stack size issue on server side, because device name in use is normally resolved by restarting the XP machine in my experience, though in this situation only restarting the server resolves it.

I increased the IRP stack to 25 on the Windows 7 host machine rebooted and the resource error was gone and this calmed down again for a few days until now, when the overnight drop outs started up again. Driving me nuts, before we implemented the Windows 7 machine to host all the shares we had a kick about cheap Thecus NAS that was slow as buggery but it worked fine, all these windows XP machines had no issues with mapping drives on the Thecus nas. I suggested we chuck it all on Windows 7 Computer as it was gigabit and would perform alot faster, they said great and now we have these annoying problems.

Any help in the right direction? Further increasing IRP stack size?? Event logs are clean for the IRP issue now mind you. There is however, a continuous error in the log every few seconds in relation to the lanmanserver. Only seems to have surfaced since increasing the IRPStackSize


Event ID:      2017
Task Category: None
Level:         Error

Description:
The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

    <Data>\Device\LanmanServer</Data>
0
Comment
Question by:Paul
12 Comments
 
LVL 90

Expert Comment

by:John Hurst
ID: 40385809
Make sure that your folder mappings are either (a) not persistent or (b) you delete the mappings at XP log off to make sure it uses the same drive / letter at next log on.

I always use password protected sharing so I leave that on.

Look through my article on Folder Sharing and work through the various pieces of it. XP is dead so I did not refer to it. Make sure XP Simple File sharing is turned off.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/A_16639-Folder-sharing-on-modern-machines.html
0
 
LVL 1

Author Comment

by:Paul
ID: 40385822
Hi John

Thanks for your post. Just to confirm, all the machines are configured to use the same drive letters as each other for the respective shares

So that

"Artwork" is always X:
"Backup" is always B:

ETC

They are also all programmed to map with their specific credentials on the remote machine (I.E. remote-machine-name\remote-username)

The drives are set to remap on reboot each time, but these machines are not being turned off. They are on all the time. Working fine all day, left on all night, then in the AM no dice!
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40385828
Still check Persistence, because a loss of drive map and remap can cause additional drive maps in the drive cache (Set to "reconnect" in Map Network Drive).

I need to look around to see why mappings should go away over night. I leave my Windows 7 machine on 24x7 and whenever I wish to map a drive, I can. Any time. But I do not leave my laptop on overnight.

Is your switch set to disconnect connections overnight?  I don't think I have seen that but you might check.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40385835
The drives are set to remap on reboot each time,

Are these machines rebooting nightly?

Map drives with a script:

NET USE Z: \\server\share   at log on.

NET USE Z: /Delete at every log off, reboot.
0
 
LVL 9

Expert Comment

by:nattygreg
ID: 40385852
try reinstalling the driver on the Ethernet card, sometimes that solves problems
0
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 40385896
Don't forget the 20 connection limit.. with 6 computers and multiple shares you are going to have problems.. simple solution buy a cheap NAS or make one using freeNAS
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 1

Author Comment

by:Paul
ID: 40386002
David very good point.

I would have thought that each computer comprised a single connection, not one connection per network share. Does each network drive constitute a seperate connection?

Also with that 20 connection limit in mind it does seem strange for it to be an after hours type of issue when nobody is using it. Just had another dropout now.

I'm currently removing AV, increasing IRP stack size again, and trying a second NIC to see if that helps
0
 
LVL 1

Author Comment

by:Paul
ID: 40386125
Also, seems this error message in the event log for lanmanserver service is related..

Event ID:      2017
Task Category: None
Level:         Error

Description:
The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

    <Data>\Device\LanmanServer</Data>
0
 
LVL 1

Accepted Solution

by:
Paul earned 0 total points
ID: 40398352
Ok gents,

John,
Computers are always on, as detailed in OP, so its not a case of unmap remap issues.

David,
Reduced share numbers to 1, so only 1 map per machine to account, but problem persisted.


Seems I MAY have found a resolution. Lets wait and see what happens.

To summarise what was tried in order:

1) Increase IRP stack size

2) Reduced number of shares to accomodate for 20 connection limit, just a single share now but problem persisted.

3) Seems to me that the fact it magoritively occurs over night point to the possibility that its related to inactivity. Network cards entering powersave, windows timing out network connection ETC. Adjusted time out for dropping idle connections on client side with no luck (see here)

4) Seems the answer was actually related to the allocation of memory resources to the lanman server as per the event log error above see here

Ill let you know how we go in a few days
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40398360
4) Seems the answer was actually related to the allocation of memory resources to the Lanman server

Could be. I looked at the article and I do not recall seeing this in my experience.
0
 
LVL 1

Author Comment

by:Paul
ID: 40398375
Hi John,

I did read through your article on sharing settings and the evolution of shared between windows XP to Vista/7/8/10, however I think because the examples in your articles make reference to smaller environments, where less resources are required by the computer hosting the share, that there is not enough demand on your host computer to create the issue we are experiencing. Seems that its the 3 or more client side machine threshold where this resource issue becomes a problem.

Seems odd that you can come from a windows xp machine with 1GB ram hosting the same amount of files and not having these resource issues. Or a tiny little nas with a 300mhz processor and 512mb ram. To a brand new windows 7 64 bit machine with 8GB of ram and large paging files and have resource issues. I think its perhaps loosely related to the additional framework surrounding the higher levels of encryption windows homegroup gadgetry that creates the issue.

The lanmanserver seems to have its own limits on how much nonpaged memory its entitled to consume, which explains how there can be a resource shortage at the network share level whilst there is so much memory available to the operating system left unused.

Time will tell on this fix. To be honest, I have made so many registry changes to no effect that its going to be very hard to know whether it was all of them required, or only the 1. I am tempted to fresh format and start again from the top down, but I suspect the client isn't in the mood for any guinea pig style arrangements given the persistent inconvenience posed by this issue.

Thanks for your input. Sincerely, Paul
0
 
LVL 1

Author Closing Comment

by:Paul
ID: 40446854
Thanks for every bodies input. Unfortunately none of the answers provided dealt with the problem at hand. Independent research led to the solution I found and subsequently shared
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Is your company's data protection keeping pace with virtualization? Here are 7 dynamic ways to adapt to rapid breakthroughs in technology.
We have come a long way with backup and data protection — from backing up to floppies, external drives, CDs, Blu-ray, flash drives, SSD drives, and now to the cloud.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now