installshield prerequisite

Working with a .Net 2.0 windows forms application. Under Redistributables have the  Installshield "Microsoft .Net Framework 2.0 SP2" prerequisite checked. My questions is: under what OS conditions should this merge module (prereqisite be installed? Currently have two OS listed under Conditions tab as depicted in attached picture. This doesn't seem right and have a couple of users that, although installer installs w/o error when program starts it crashes.Installshield Prerequisite: .NET 2.0 Framework Installation Conditions
gcook17Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vadim RappCommented:
It's right, because starting from Vista, Net framework has become part of the system, so it does not need to be installed separately.

One possible reason for your problem may be if your application expects very specific version of .Net framework and does not work with later versions. I suggest that you check article Version Compatibility in the .NET Framework
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gcook17Author Commented:
Thank you for your reply. OK so the 2 default OS conditions are correct? This application uses .Net 2.0 Framework. I understand that .Net Framework 3.5 sp1 includes .Net Framework 2.0. Would it be better to simply include .Net Framework 3.5 sp1 and install that on all OS where needed? This would provide 2.0 clr. Are later versions of .Net Framework also including compatibility with 2.0 (for example Framework 4.0-4.5, etc.)?
0
Vadim RappCommented:
> OK so the 2 default OS conditions are correct?

Yes, because in later OS the framework is already in place.

For other questions, you will find the answer in the article I mentioned, including what to do if your application is really incompatible with later framework. If you really need only 2.0, you can install it by modifying the conditions of the prerequisite, using prerequisite editor that comes with Installshield.
0
Jacques Bourgeois (James Burger)PresidentCommented:
According ro the documentation for Framework 3.5, it includes 2.0 SP1, while your setup requires 2.0 SP2.

There is an article in the Knowledge Base that seems to address your situation.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.